aboutsummaryrefslogtreecommitdiffstats
path: root/cad
diff options
context:
space:
mode:
authorrakuco <rakuco@FreeBSD.org>2015-09-16 16:55:04 +0800
committerrakuco <rakuco@FreeBSD.org>2015-09-16 16:55:04 +0800
commitd5338a9cd4d4b1f27857bddfb442b5aa31c9ec39 (patch)
treee7c188c382abfae82fd4ac0c5e99a8570491f129 /cad
parent0fdf37c9da152a83e3f3fbafad84909f358db8e2 (diff)
downloadfreebsd-ports-gnome-d5338a9cd4d4b1f27857bddfb442b5aa31c9ec39.tar.gz
freebsd-ports-gnome-d5338a9cd4d4b1f27857bddfb442b5aa31c9ec39.tar.zst
freebsd-ports-gnome-d5338a9cd4d4b1f27857bddfb442b5aa31c9ec39.zip
Update the Qt4 ports to 4.8.7.
According to upstream, this is the last planned Qt4 release. A list of changes since 4.8.6 can be found here: <http://download.qt.io/official_releases/qt/4.8/4.8.7/changes-4.8.7> Porting notes and changes: - Remove several patches that have been upstreamed. - Make Uses/qmake.mk pass the contents of LIBS to the qmake environment. [1] - Repurpose devel/qt4/files/extrapatch-src-corelib-global-qglobal.h now the original patch is part of the release (curiously enough, the original patch was never actually used, as the ?= assignment in r362837 after r362770 was never possible). This works around the way compiler support for C++11 features is detected in Qt 4.8.7: while it originally only uses the compiler to determine if something is supported or not, the initializer lists feature also depends on the C++ standard library being used. It's a problem in FreeBSD 9.x, where USES=compiler:c++0x or USES=compiler:c++11-lang means we will use clang to build a port but use libstdc++ from base (GCC 4.2). The latter obviously does not support initializer lists, and the build fails because Qt tries to include headers that do not exist (<initializer_list>). Since detecting libstdc++'s version is not trivial (we need to include a non-lightweight header like cstdio and then check for __GLIBCXX__), we just enable Q_COMPILER_INITIALIZER_LISTS support only when libc++ is used (there should be no reason for someone to be using clang with GCC 4.8's libstdc++, for example). x11/kdelibs4's FindQt4.cmake had to include a backported change from the upstream FindQt4.cmake in CMake itself to use a C++ compiler to detect flags like Q_WS_X11, otherwise the inclusion of <ciso646> in qglobal.h makes the build fail. This patch contains changes by me, makc@ and alonso@. PR: 202552 [1] PR: 202808 [exp-run] Submitted by: pawel@ [1]
Diffstat (limited to 'cad')
-rw-r--r--cad/qcad/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/cad/qcad/Makefile b/cad/qcad/Makefile
index bab5d8e839b2..f0bae2786d6e 100644
--- a/cad/qcad/Makefile
+++ b/cad/qcad/Makefile
@@ -52,12 +52,12 @@ pre-configure:
${REINPLACE_CMD} -e "s|%%DATADIR%%|${DATADIR}|" \
${WRKSRC}/src/core/RSettings.cpp
-# Temporary hack for Qt 4.8.6 support while upstream does not add proper
+# Temporary hack for Qt 4.8.7 support while upstream does not add proper
# bindings.
(cd ${WRKSRC}/src/3rdparty/qt-labs-qtscriptgenerator-4.8.5 && \
- ${COPYTREE_SHARE} . ../qt-labs-qtscriptgenerator-4.8.6)
- (cd ${WRKSRC}/src/3rdparty/qt-labs-qtscriptgenerator-4.8.6 && \
- mv qt-labs-qtscriptgenerator-4.8.5.pro qt-labs-qtscriptgenerator-4.8.6.pro)
+ ${COPYTREE_SHARE} . ../qt-labs-qtscriptgenerator-4.8.7)
+ (cd ${WRKSRC}/src/3rdparty/qt-labs-qtscriptgenerator-4.8.7 && \
+ mv qt-labs-qtscriptgenerator-4.8.5.pro qt-labs-qtscriptgenerator-4.8.7.pro)
do-install:
${INSTALL_PROGRAM} ${RESDIR}/qcad-bin ${STAGEDIR}${PREFIX}/bin/