aboutsummaryrefslogtreecommitdiffstats
path: root/chinese/fcitx
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2010-08-03 09:41:38 +0800
committerdanfe <danfe@FreeBSD.org>2010-08-03 09:41:38 +0800
commit03ac110c5770aa14e6ed7eb363cb14cf149d1495 (patch)
tree6a3f21d94dd46aea244fa212cbcd6b29766cff12 /chinese/fcitx
parent6a3c5f366aa2e0208f762123c8fcbc3af9ba831a (diff)
downloadfreebsd-ports-gnome-03ac110c5770aa14e6ed7eb363cb14cf149d1495.tar.gz
freebsd-ports-gnome-03ac110c5770aa14e6ed7eb363cb14cf149d1495.tar.zst
freebsd-ports-gnome-03ac110c5770aa14e6ed7eb363cb14cf149d1495.zip
- Update to version 3.6.3
- Remove obsolete master sites - Add LICENSE - Utilize OPTIONS - Correctly track dependencies (prevent silent dependency injection) - Minor Makefile cleanups Approved by: maintainer timeout
Diffstat (limited to 'chinese/fcitx')
-rw-r--r--chinese/fcitx/Makefile51
-rw-r--r--chinese/fcitx/distinfo6
-rw-r--r--chinese/fcitx/pkg-plist2
3 files changed, 43 insertions, 16 deletions
diff --git a/chinese/fcitx/Makefile b/chinese/fcitx/Makefile
index 9936b3412c37..75a64b1e610c 100644
--- a/chinese/fcitx/Makefile
+++ b/chinese/fcitx/Makefile
@@ -1,39 +1,66 @@
-# New ports collection makefile for: zh-fcitx
-# Date created: 26 March 2003
+# New ports collection makefile for: Free Chinese Input Toy of X
+# Date created: 26 March 2003
# Whom: Shen Chuan-Hsing <statue@freebsd.sinica.edu.tw>
#
# $FreeBSD$
#
PORTNAME= fcitx
-PORTVERSION= 3.6.2
+PORTVERSION= 3.6.3
CATEGORIES= chinese x11
MASTER_SITES= http://www.fcitx.org/download/ \
- ftp://mirrors.redv.com/pub/fcitx/ \
- ${MASTER_SITE_LOCAL} \
- http://dryice.name/computer/FreeBSD/distfiles/
-MASTER_SITE_SUBDIR= dryice
+ ftp://mirrors.redv.com/pub/fcitx/
MAINTAINER= darcsis@gmail.com
COMMENT= A simple and fast GBK Chinese XIM server
-LIB_DEPENDS= Xft.2:${PORTSDIR}/x11-fonts/libXft
+LICENSE= GPLv2
USE_BZIP2= yes
USE_XORG= xpm x11 xtst
USE_ICONV= yes
GNU_CONFIGURE= yes
USE_GMAKE= yes
-WRKSRC= ${WRKDIR}/fcitx-${PORTVERSION}
+
+OPTIONS= XFT "Use Xft for Freetype font support" on \
+ DBUS "Enable D-Bus for KIMPanel support" off \
+ RECORDING "Enable recording of user input" off \
+ DEBUG "Enable debug build with logging" off \
+
+.include <bsd.port.options.mk>
+
+.if defined(WITH_XFT)
+LIB_DEPENDS+= Xft.2:${PORTSDIR}/x11-fonts/libXft
+.else
+CONFIGURE_ARGS+= --disable-xft
+.endif
+
+.if defined(WITH_DBUS)
+LIB_DEPENDS+= dbus-1.3:${PORTSDIR}/devel/dbus
+.else
+CONFIGURE_ARGS+= --disable-dbus
+.endif
+
+.if defined(WITH_RECORDING)
+CONFIGURE_ARGS+= --enable-recording
+.endif
+
+.if defined(WITH_DEBUG)
+CONFIGURE_ARGS+= --enable-debug --enable-log
+.endif
post-patch:
- @${REINPLACE_CMD} -e 's#zh_CN.GB2312#zh_CN.eucCN#g' ${WRKSRC}/src/xim.c
- @${REINPLACE_CMD} -e 's#zh_CN.gb2312#zh_CN.eucCN#g' ${WRKSRC}/src/ui.c ${WRKSRC}/src/tools.c
+ @${REINPLACE_CMD} -e 's#zh_CN.GB2312#zh_CN.eucCN#g' \
+ ${WRKSRC}/src/xim.c
+ @${REINPLACE_CMD} -e 's#zh_CN.gb2312#zh_CN.eucCN#g' \
+ ${WRKSRC}/src/ui.c ${WRKSRC}/src/tools.c
pre-install:
- @${CHMOD} 0755 ${WRKSRC}/install-sh
+ @${CHMOD} +x ${WRKSRC}/install-sh
post-install:
+ @${ECHO_CMD}
@${CAT} ${PKGMESSAGE}
+ @${ECHO_CMD}
.include <bsd.port.mk>
diff --git a/chinese/fcitx/distinfo b/chinese/fcitx/distinfo
index c4bbc8be5ad3..c5b309d9ff4d 100644
--- a/chinese/fcitx/distinfo
+++ b/chinese/fcitx/distinfo
@@ -1,3 +1,3 @@
-MD5 (fcitx-3.6.2.tar.bz2) = 6a66cda4a8221f1d6685e5a400d8763e
-SHA256 (fcitx-3.6.2.tar.bz2) = 8f757cfb7e1611546f6e736424826c45c5811492d5fc1920ec9cbc6735210e08
-SIZE (fcitx-3.6.2.tar.bz2) = 6347362
+MD5 (fcitx-3.6.3.tar.bz2) = b1da30c72374d7b3d70738493d44d300
+SHA256 (fcitx-3.6.3.tar.bz2) = e986f1223d758d57b87e74b75dd9b635366ee4bf6ea90779f5a48e44498de5b5
+SIZE (fcitx-3.6.3.tar.bz2) = 6385159
diff --git a/chinese/fcitx/pkg-plist b/chinese/fcitx/pkg-plist
index d75d764db95b..4a27de9858c8 100644
--- a/chinese/fcitx/pkg-plist
+++ b/chinese/fcitx/pkg-plist
@@ -1,5 +1,6 @@
bin/createPYMB
bin/fcitx
+bin/fcitx-remote
bin/jd2fcitx
bin/mb2org
bin/mb2txt
@@ -43,7 +44,6 @@ bin/win2fcitx
%%DOCSDIR%%/API.txt
%%DOCSDIR%%/Develop_Readme.GBK
%%DOCSDIR%%/cjkvinput.txt
-%%DOCSDIR%%/fcitx3.odt
%%DOCSDIR%%/fcitx3.pdf
%%DOCSDIR%%/fcitx_trunk.doxyfile
%%DOCSDIR%%/pinyin.txt