aboutsummaryrefslogtreecommitdiffstats
path: root/chinese/gcin
diff options
context:
space:
mode:
authorClive Lin <clive@FreeBSD.org>2005-10-05 06:13:25 +0800
committerClive Lin <clive@FreeBSD.org>2005-10-05 06:13:25 +0800
commit2ae10b590409ca913e26e41195d59be8b75a6a52 (patch)
tree717770a010b261cd2fe8d552bd5e7140def28e3a /chinese/gcin
parentedc4795f1e215d1215eb062f2e64fa6609182248 (diff)
downloadfreebsd-ports-gnome-2ae10b590409ca913e26e41195d59be8b75a6a52.tar.gz
freebsd-ports-gnome-2ae10b590409ca913e26e41195d59be8b75a6a52.tar.zst
freebsd-ports-gnome-2ae10b590409ca913e26e41195d59be8b75a6a52.zip
Upgrade to 1.0.9:
files/patch-im-client_gcin-im-client.c: Without this, connecting to gcin daemon via unix domain socket (which is gcin's preferred method) NEVER works. Not sure how it works on Linux, I'd like to discuss this with gcin author. Unknown to me at this time. files/patch-win0.c: On its discussion forum, people said 1.0.9 needs this otherwise the build won't work.
Diffstat (limited to 'chinese/gcin')
-rw-r--r--chinese/gcin/Makefile2
-rw-r--r--chinese/gcin/distinfo4
-rw-r--r--chinese/gcin/files/patch-im-client_gcin-im-client.c11
-rw-r--r--chinese/gcin/files/patch-win0.c51
4 files changed, 65 insertions, 3 deletions
diff --git a/chinese/gcin/Makefile b/chinese/gcin/Makefile
index 56daccdd8e44..ce5b43b3ad5a 100644
--- a/chinese/gcin/Makefile
+++ b/chinese/gcin/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= gcin
-PORTVERSION= 1.0.8
+PORTVERSION= 1.0.9
CATEGORIES= chinese
MASTER_SITES= http://www.csie.nctu.edu.tw/~cp76/gcin/download/ \
http://edt1023.sayya.org/gcin/source/ \
diff --git a/chinese/gcin/distinfo b/chinese/gcin/distinfo
index 11279c767a5d..7457837523b5 100644
--- a/chinese/gcin/distinfo
+++ b/chinese/gcin/distinfo
@@ -1,3 +1,3 @@
-MD5 (gcin-1.0.8.tar.bz2) = 8180feeac41138b824858b33d538b5ad
-SIZE (gcin-1.0.8.tar.bz2) = 1292364
+MD5 (gcin-1.0.9.tar.bz2) = cdb51a89e44f152278528353634bfff1
+SIZE (gcin-1.0.9.tar.bz2) = 1294391
MD5 (noseeing.tar.gz) = IGNORE
diff --git a/chinese/gcin/files/patch-im-client_gcin-im-client.c b/chinese/gcin/files/patch-im-client_gcin-im-client.c
new file mode 100644
index 000000000000..89aea7a4c99f
--- /dev/null
+++ b/chinese/gcin/files/patch-im-client_gcin-im-client.c
@@ -0,0 +1,11 @@
+--- im-client/gcin-im-client.c.orig Wed Oct 5 05:56:02 2005
++++ im-client/gcin-im-client.c Wed Oct 5 05:56:23 2005
+@@ -94,7 +94,7 @@
+ get_gcin_im_srv_sock_path(sock_path, sizeof(sock_path));
+ addr = sock_path;
+ strcpy(serv_addr.sun_path, sock_path);
+- servlen = strlen(serv_addr.sun_path) + sizeof(serv_addr.sun_family);
++ servlen = strlen(serv_addr.sun_path) + sizeof(serv_addr.sun_family) +1;
+
+ if ((sockfd = socket(AF_UNIX, SOCK_STREAM, 0)) < 0) {
+ perror("cannot open socket");
diff --git a/chinese/gcin/files/patch-win0.c b/chinese/gcin/files/patch-win0.c
new file mode 100644
index 000000000000..248105150034
--- /dev/null
+++ b/chinese/gcin/files/patch-win0.c
@@ -0,0 +1,51 @@
+--- win0.c.orig Tue Oct 4 22:35:52 2005
++++ win0.c Tue Oct 4 13:25:26 2005
+@@ -28,6 +28,8 @@
+ static GtkWidget *button_eng_ph;
+ static int max_yl;
+
++static void create_win0_gui();
++
+ static void recreate_win0()
+ {
+ int i;
+@@ -41,8 +43,8 @@
+
+ void change_win0_style()
+ {
+- if (!top_bin || current_pho_simple_win == pho_simple_win &&
+- current_gcin_inner_frame == gcin_inner_frame)
++ if (!top_bin || (current_pho_simple_win == pho_simple_win &&
++ current_gcin_inner_frame == gcin_inner_frame))
+ return;
+
+ gtk_widget_destroy(top_bin);
+@@ -153,7 +155,7 @@
+ }
+
+
+-void disp_char(int index, u_char *ch)
++void disp_char(int index, char *ch)
+ {
+ char tt[CH_SZ+1];
+
+@@ -342,6 +344,7 @@
+ raw_move(best_win_x, best_win_y);
+ }
+
++gboolean tsin_has_input();
+
+ void move_win0(int x, int y)
+ {
+@@ -505,9 +508,9 @@
+ pango_attr_list_insert (attr_list, white_fg);
+ }
+
++void create_win1_gui();
+
+-
+-void create_win0_gui()
++static void create_win0_gui()
+ {
+ if (top_bin)
+ return;