aboutsummaryrefslogtreecommitdiffstats
path: root/chinese/ntuttf/Makefile
diff options
context:
space:
mode:
authorleeym <leeym@FreeBSD.org>2005-02-19 21:51:50 +0800
committerleeym <leeym@FreeBSD.org>2005-02-19 21:51:50 +0800
commit31459e01770eecb2584fba51544d7b5855a6300f (patch)
tree4b1bb35388cb87d2d1c66e786f5ae233b418c9f9 /chinese/ntuttf/Makefile
parent5f8f4cbde94a90e2f70c8e265d8a42fc29b483ee (diff)
downloadfreebsd-ports-gnome-31459e01770eecb2584fba51544d7b5855a6300f.tar.gz
freebsd-ports-gnome-31459e01770eecb2584fba51544d7b5855a6300f.tar.zst
freebsd-ports-gnome-31459e01770eecb2584fba51544d7b5855a6300f.zip
- add chinese/Makefile.ttf to control install/deinstall process of all
TrueType fonts in chinese/*ttf - update related Makefile(s) and remove pkg-{install,pkg-deinstall,pkg-plist} - relocate non-font files to DATADIR or DOCSDIR - fix "unable to reomve fonts from gscjk" problem in ttfm.sh and gscjk.ttfm - update chinese/zh-fireflyttf to 1.2.6 [1] PR: [1] 77438 Submitted by: leeym Approved by: statue at freebsd.sinica.edu.tw
Diffstat (limited to 'chinese/ntuttf/Makefile')
-rw-r--r--chinese/ntuttf/Makefile48
1 files changed, 6 insertions, 42 deletions
diff --git a/chinese/ntuttf/Makefile b/chinese/ntuttf/Makefile
index e2833b968af3..b803cd28448a 100644
--- a/chinese/ntuttf/Makefile
+++ b/chinese/ntuttf/Makefile
@@ -17,52 +17,16 @@ EXTRACT_ONLY= # empty
MAINTAINER= statue@freebsd.netlab.cse.yzu.edu.tw
COMMENT= Seven Chinese Big5 TrueType fonts made by NTU
-RUN_DEPENDS= ttfm.sh:${PORTSDIR}/chinese/ttfm
-
NO_BUILD= yes
-SHAREMODE= 644
-USE_XLIB= yes
-FONTDIR= ${PREFIX}/share/fonts/TrueType
-XFONTDIR= ${X11BASE}/lib/X11/fonts/TrueType
-INSTALL_ENV= PKG_PREFIX=${PREFIX} \
- WANT_CJK=${WANT_CJK} WANT_GS=${WANT_GS} \
- WITHOUT_X=${WITHOUT_X}
-
-.include <bsd.port.pre.mk>
-.if defined(WANT_CJK)
-RUN_DEPENDS+= bg5latex:${PORTSDIR}/chinese/CJK
-.endif
-.if defined(WANT_GS)
-RUN_DEPENDS+= ${LOCALBASE}/share/ghostscript/Resource/ai0/CMap/Identity-H:${PORTSDIR}/print/adobe-cmaps
-.endif
-
-pre-fetch:
-.if defined(WANT_CJK)
- @${ECHO} "CJK support will be added."
-.endif
-.if defined(WANT_GS)
- @${ECHO} "Ghostscript support will be added."
-.endif
-.if defined(WITHOUT_X)
- @${ECHO} "X Window support will NOT be added."
-.endif
-.if !defined(WANT_CJK) && !defined(WANT_GS) && !defined(WITHOUT_X)
- @${ECHO} --
- @${ECHO} "Type \"make WANT_CJK=yes\" if you want CJK support."
- @${ECHO} "Type \"make WANT_GS=yes\" if you want Ghostscript support."
- @${ECHO} "Type \"make WITHOUT_X=yes\" if you DONT want X Window support."
- @${ECHO} "You can use them in combinations."
- @${ECHO} --
-.endif
+TTF= ${DISTFILES}
do-install:
-.if !exists(${FONTDIR})
- @${MKDIR} ${FONTDIR}
-.endif
-.for i in ${DISTFILES}
- @${INSTALL_DATA} ${DISTDIR}/${i} ${FONTDIR}
+ @${MKDIR} ${FONTSDIR}
+.for i in ${TTF}
+ @${INSTALL_DATA} ${DISTDIR}/${i} ${FONTSDIR}
.endfor
- @${SETENV} ${INSTALL_ENV} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/chinese/ttfm/Makefile.ttf"
.include <bsd.port.post.mk>