aboutsummaryrefslogtreecommitdiffstats
path: root/chinese/sunpinyin/files
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2021-01-01 18:11:34 +0800
committerAntoine Brodin <antoine@FreeBSD.org>2021-01-01 18:11:34 +0800
commit26b4c8f71f91d22e081b27814782686edde0c90a (patch)
tree1c321c39372c25d8634e75b5c8e08edc676b296d /chinese/sunpinyin/files
parent548f16bd1a2915f08878b716eed92ff3267e6de2 (diff)
downloadfreebsd-ports-gnome-26b4c8f71f91d22e081b27814782686edde0c90a.tar.gz
freebsd-ports-gnome-26b4c8f71f91d22e081b27814782686edde0c90a.tar.zst
freebsd-ports-gnome-26b4c8f71f91d22e081b27814782686edde0c90a.zip
Revert r559792 to unbreak INDEX and bulk -a
It seems a lot of reverse dependencies were missed With hat: portmgr
Diffstat (limited to 'chinese/sunpinyin/files')
-rw-r--r--chinese/sunpinyin/files/patch-SConstruct34
-rw-r--r--chinese/sunpinyin/files/patch-man_SConscript11
-rw-r--r--chinese/sunpinyin/files/patch-src_ime-core_imi__winHandler.cpp18
-rw-r--r--chinese/sunpinyin/files/patch-src_portability.h10
-rw-r--r--chinese/sunpinyin/files/patch-src_slm_thread_slmthread.cpp17
-rw-r--r--chinese/sunpinyin/files/patch-src_sunpinyin-dictgen.mk.in26
-rw-r--r--chinese/sunpinyin/files/patch-xdg35
7 files changed, 151 insertions, 0 deletions
diff --git a/chinese/sunpinyin/files/patch-SConstruct b/chinese/sunpinyin/files/patch-SConstruct
new file mode 100644
index 000000000000..ffd859c026ff
--- /dev/null
+++ b/chinese/sunpinyin/files/patch-SConstruct
@@ -0,0 +1,34 @@
+--- SConstruct.orig 2014-11-14 14:17:48 UTC
++++ SConstruct
+@@ -215,10 +215,11 @@ def CreateEnvironment():
+ make = 'gmake'
+ tar = 'gtar'
+ libln_builder = Builder(action='cd ${TARGET.dir} && ln -s ${SOURCE.name} ${TARGET.name}')
+- env = Environment(ENV=os.environ, CFLAGS=cflags, CXXFLAGS='',
++ env = Environment(ENV=os.environ,
+ MAKE=make, WGET=wget, W3M=w3m, TAR=tar,
+- CPPPATH=['.'] + allinc(),
+- tools=['default', 'textfile'])
++ tools=['default', 'textfile'],
++ **ARGUMENTS)
++ env['CPPPATH'] = ['.'] + allinc()
+ env.Append(BUILDERS={'InstallAsSymlink': libln_builder})
+ env['ENDIANNESS'] = "be" if sys.byteorder == "big" else "le"
+ return env
+@@ -375,7 +376,6 @@ def DoConfigure():
+ conf.CheckFunc('getopt_long')
+ conf.CheckFunc('getpagesize')
+ conf.CheckFunc('get_opt')
+- conf.CheckCHeader('iconv.h')
+ conf.CheckCHeader('inttypes.h')
+ conf.CheckCHeader('locale.h')
+ conf.CheckCHeader('libintl.h')
+@@ -463,7 +463,7 @@ def DoInstall():
+ lib_target_bin),
+ ]
+
+- lib_pkgconfig_target = env.Install(os.path.join(libdir, 'pkgconfig'),
++ lib_pkgconfig_target = env.Install(os.path.join(env['PREFIX'], 'libdata/pkgconfig'),
+ ['sunpinyin-2.0.pc'])
+ bin_target = env.Install(bindir, bins)
+ man1_target = env.Install(man1dir, man1s)
diff --git a/chinese/sunpinyin/files/patch-man_SConscript b/chinese/sunpinyin/files/patch-man_SConscript
new file mode 100644
index 000000000000..e04f8c8623af
--- /dev/null
+++ b/chinese/sunpinyin/files/patch-man_SConscript
@@ -0,0 +1,11 @@
+--- man/SConscript.orig 2014-11-14 14:17:48 UTC
++++ man/SConscript
+@@ -1,7 +1,7 @@
+ import os
+ Import('env')
+
+-pod2man = Builder(action = 'pod2man < $SOURCE > $TARGET')
++pod2man = Builder(action = 'pod2man $SOURCE $TARGET')
+ env.Append(BUILDERS = {'Man': pod2man})
+
+ env.Man('mmseg.1', 'mmseg.pod')
diff --git a/chinese/sunpinyin/files/patch-src_ime-core_imi__winHandler.cpp b/chinese/sunpinyin/files/patch-src_ime-core_imi__winHandler.cpp
new file mode 100644
index 000000000000..74fdf4f2fa59
--- /dev/null
+++ b/chinese/sunpinyin/files/patch-src_ime-core_imi__winHandler.cpp
@@ -0,0 +1,18 @@
+--- src/ime-core/imi_winHandler.cpp.orig 2014-11-14 14:17:48 UTC
++++ src/ime-core/imi_winHandler.cpp
+@@ -87,6 +87,7 @@ CIMIWinHandler::throwBackKey(unsigned ke
+ void
+ CIMIWinHandler::updateStatus(int key, int value)
+ {
++#ifdef DEBUG
+ switch (key) {
+ case STATUS_ID_CN:
+ printf("CN status is "); break;
+@@ -101,6 +102,7 @@ CIMIWinHandler::updateStatus(int key, in
+
+ printf("%d\n", value);
+ fflush(stdout);
++#endif
+ }
+
+ // -*- indent-tabs-mode: nil -*- vim:et:ts=4
diff --git a/chinese/sunpinyin/files/patch-src_portability.h b/chinese/sunpinyin/files/patch-src_portability.h
new file mode 100644
index 000000000000..93c117af2c66
--- /dev/null
+++ b/chinese/sunpinyin/files/patch-src_portability.h
@@ -0,0 +1,10 @@
+--- src/portability.h.orig 2014-11-14 14:17:48 UTC
++++ src/portability.h
+@@ -42,6 +42,7 @@
+ #include <stdio.h>
+ #include <math.h>
+ #include <stdint.h>
++#include <stdlib.h>
+ #include <string>
+ #include <cstring>
+
diff --git a/chinese/sunpinyin/files/patch-src_slm_thread_slmthread.cpp b/chinese/sunpinyin/files/patch-src_slm_thread_slmthread.cpp
new file mode 100644
index 000000000000..723c45843d74
--- /dev/null
+++ b/chinese/sunpinyin/files/patch-src_slm_thread_slmthread.cpp
@@ -0,0 +1,17 @@
+--- src/slm/thread/slmthread.cpp.orig 2014-11-14 14:17:48 UTC
++++ src/slm/thread/slmthread.cpp
+@@ -250,10 +250,10 @@ main(int argc, char* argv[])
+
+ bool usingLogPr = slm.isUseLogPr();
+
+- #define EffectivePr(a) (float((usingLogPr) ? ((a) / log(2.0)) : (-log2((a)))))
+- #define OriginalPr(b) (float((usingLogPr) ? ((b) * log(2.0)) : (exp2(-(b)))))
+- #define EffectiveBow(a) (float((usingLogPr) ? (exp(-(a))) : ((a))))
+- #define OriginalBow(b) (float((usingLogPr) ? (-log((b))) : ((b))))
++ #define EffectivePr(a) (float((usingLogPr) ? ((a) / logf(2.0f)) : (-log2f((a)))))
++ #define OriginalPr(b) (float((usingLogPr) ? ((b) * logf(2.0f)) : (exp2f(-(b)))))
++ #define EffectiveBow(a) (float((usingLogPr) ? (expf(-(a))) : ((a))))
++ #define OriginalBow(b) (float((usingLogPr) ? (-logf((b))) : ((b))))
+
+ printf("\nfirst pass..."); fflush(stdout);
+ for (int lvl = 0; lvl <= slm.getN(); ++lvl) {
diff --git a/chinese/sunpinyin/files/patch-src_sunpinyin-dictgen.mk.in b/chinese/sunpinyin/files/patch-src_sunpinyin-dictgen.mk.in
new file mode 100644
index 000000000000..4372c17738ef
--- /dev/null
+++ b/chinese/sunpinyin/files/patch-src_sunpinyin-dictgen.mk.in
@@ -0,0 +1,26 @@
+--- src/sunpinyin-dictgen.mk.in.orig 2014-11-14 14:17:48 UTC
++++ src/sunpinyin-dictgen.mk.in
+@@ -42,22 +42,7 @@ DL_ROOT = ${DL_HOST}/open-gram
+ DICT_PAT = 'dict\.utf8-[0-9]\+.tar.bz2'
+ SLM_PAT = 'lm_sc\.3gm\.arpa-[0-9]\+.tar.bz2'
+
+-DICT_AR = $(shell ${W3M} ${DL_LIST} | grep -o ${DICT_PAT} | sort | tail -n 1)
+-SLM_AR = $(shell ${W3M} ${DL_LIST} | grep -o ${SLM_PAT} | sort | tail -n 1)
+-
+-all: install
+-
+-${DICT_AR}:
+- ${WGET} ${DL_ROOT}/$@
+-
+-dict.utf8: ${DICT_AR}
+- ${TAR} xmf $^
+-
+-${SLM_AR}:
+- ${WGET} ${DL_ROOT}/$@
+-
+-lm_sc.3gm.arpa: ${SLM_AR}
+- ${TAR} xmf $^
++all: lm_sc.t3g pydict_sc.bin
+
+ lm_sc.3gm: lm_sc.3gm.arpa dict.utf8
+ slmpack $^ $@
diff --git a/chinese/sunpinyin/files/patch-xdg b/chinese/sunpinyin/files/patch-xdg
new file mode 100644
index 000000000000..452c3aacb46f
--- /dev/null
+++ b/chinese/sunpinyin/files/patch-xdg
@@ -0,0 +1,35 @@
+--- src/ime-core/imi_options.cpp.orig 2014-11-14 14:17:48 UTC
++++ src/ime-core/imi_options.cpp
+@@ -73,12 +73,15 @@ CSimplifiedChinesePolicy::loadResources(
+
+ if (!m_user_data_dir.size()) {
+ char path[256];
+- const char *home = getenv("HOME");
+- snprintf(path,
+- sizeof(path),
+- "%s/%s",
+- home,
+- SUNPINYIN_USERDATA_DIR_PREFIX);
++ const char *home = getenv("XDG_CONFIG_HOME");
++ if (home == NULL)
++ snprintf(path, sizeof(path),
++ "%s/.config/%s", getenv("HOME"),
++ SUNPINYIN_USERDATA_DIR_PREFIX);
++ else
++ snprintf(path, sizeof(path),
++ "%s/%s", home,
++ SUNPINYIN_USERDATA_DIR_PREFIX);
+ m_user_data_dir = path;
+ }
+
+--- src/ime-core/imi_options.h.orig 2014-11-14 14:17:48 UTC
++++ src/ime-core/imi_options.h
+@@ -52,7 +52,7 @@
+ #include "pinyin/hunpin_seg.h"
+
+ #ifndef SUNPINYIN_USERDATA_DIR_PREFIX
+-#define SUNPINYIN_USERDATA_DIR_PREFIX ".sunpinyin"
++#define SUNPINYIN_USERDATA_DIR_PREFIX "sunpinyin"
+ #endif
+
+ struct CSimplifiedChinesePolicy : public IConfigurable {