aboutsummaryrefslogtreecommitdiffstats
path: root/chinese/zhcon/Makefile
diff options
context:
space:
mode:
authorclive <clive@FreeBSD.org>2001-09-09 00:37:56 +0800
committerclive <clive@FreeBSD.org>2001-09-09 00:37:56 +0800
commit9d1c9e2e129a594e5c831d026285e92389d3b489 (patch)
tree34ec83044cb03d28f5e27bff17ba494888724c33 /chinese/zhcon/Makefile
parent1684df15e1c3a04fd16037eb7ea3053f185e38ea (diff)
downloadfreebsd-ports-gnome-9d1c9e2e129a594e5c831d026285e92389d3b489.tar.gz
freebsd-ports-gnome-9d1c9e2e129a594e5c831d026285e92389d3b489.tar.zst
freebsd-ports-gnome-9d1c9e2e129a594e5c831d026285e92389d3b489.zip
New port: zhcon
Zhcon is a fast Linux Console Chinese System which supports framebuffer device.It can display Chinese,Japanese or Korean double byte characters.Supported language encodings include: GB2312,GBK,BIG5,JIS and KSCM. It can also use input methods(table based) from Windows 98 and UCDOS for MS-DOS. PR: ports/30433 Submitted by: Statue <statue@freebsd.sinica.edu.tw>
Diffstat (limited to 'chinese/zhcon/Makefile')
-rw-r--r--chinese/zhcon/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/chinese/zhcon/Makefile b/chinese/zhcon/Makefile
new file mode 100644
index 000000000000..f94219bf0983
--- /dev/null
+++ b/chinese/zhcon/Makefile
@@ -0,0 +1,26 @@
+# Ports collection makefile for: zhcon
+# Date created: Sun Sep 9, 2001
+# Whom: statue@freebsd.sinica.edu.tw
+#
+# $FreeBSD$
+#
+
+PORTNAME= zhcon
+PORTVERSION= 0.14f
+CATEGORIES= chinese
+MASTER_SITES= http://freebsd.sinica.edu.tw/~statue/ \
+ ftp://ftp.gnuchina.org/pub/linux/chinese/inputmethod/console/zhcon/BSDPort/
+
+MAINTAINER= statue@freebsd.sinica.edu.tw
+
+HAS_CONFIGURE= yes
+USE_GMAKE= yes
+
+MAN1= zhcon.1
+
+.include <bsd.port.pre.mk>
+.if ${OSVERSION} > 500012
+post-patch:
+ @${PERL} -pi -e 's,machine/console.h>,sys/consio.h>\n#include <sys/fbio.h>\n#include <sys/kbio.h>\n,' ${WRKSRC}/${PORTNAME}/*.cpp
+.endif
+.include <bsd.port.post.mk>