aboutsummaryrefslogtreecommitdiffstats
path: root/chinese
diff options
context:
space:
mode:
authorrafan <rafan@FreeBSD.org>2006-11-05 18:24:01 +0800
committerrafan <rafan@FreeBSD.org>2006-11-05 18:24:01 +0800
commit7ac8bf775f4fb78e39dc966a8da787c10a54aa10 (patch)
tree7c5cb0f5be3d7a73be6665562f014af8394273a9 /chinese
parent2aaf9c6184478c98d5a91e4145aff2572b2ae155 (diff)
downloadfreebsd-ports-gnome-7ac8bf775f4fb78e39dc966a8da787c10a54aa10.tar.gz
freebsd-ports-gnome-7ac8bf775f4fb78e39dc966a8da787c10a54aa10.tar.zst
freebsd-ports-gnome-7ac8bf775f4fb78e39dc966a8da787c10a54aa10.zip
- Move chinese/xcin25 to chinese/xcin to reflect its real portname.
Please note that this is not a repo-copied directory due to we had chinese/xcin before. So, I just add all files from chinese/xcin25. For the record, the revisions are: 1.64 ports/chinese/xcin25/Makefile 1.22 ports/chinese/xcin25/distinfo 1.4 ports/chinese/xcin25/pkg-descr 1.19 ports/chinese/xcin25/pkg-plist 1.9 ports/chinese/xcin25/files/patch-aa 1.4 ports/chinese/xcin25/files/patch-ad 1.1 ports/chinese/xcin25/files/patch-ah 1.1 ports/chinese/xcin25/files/patch-chewing::sort_word.c 1.1 ports/chinese/xcin25/files/patch-configure 1.1 ports/chinese/xcin25/files/patch-gen_inp.c 1.1 ports/chinese/xcin25/files/patch-gui_main.c 1.2 ports/chinese/xcin25/files/patch-xcinrc.FREEBSD
Diffstat (limited to 'chinese')
-rw-r--r--chinese/xcin/Makefile100
-rw-r--r--chinese/xcin/distinfo6
-rw-r--r--chinese/xcin/files/patch-aa9
-rw-r--r--chinese/xcin/files/patch-ad11
-rw-r--r--chinese/xcin/files/patch-ah11
-rw-r--r--chinese/xcin/files/patch-chewing::sort_word.c10
-rw-r--r--chinese/xcin/files/patch-configure68
-rw-r--r--chinese/xcin/files/patch-gen_inp.c46
-rw-r--r--chinese/xcin/files/patch-gui_main.c11
-rw-r--r--chinese/xcin/files/patch-xcinrc.FREEBSD47
-rw-r--r--chinese/xcin/pkg-descr11
-rw-r--r--chinese/xcin/pkg-plist83
12 files changed, 413 insertions, 0 deletions
diff --git a/chinese/xcin/Makefile b/chinese/xcin/Makefile
new file mode 100644
index 000000000000..bafd425a4b32
--- /dev/null
+++ b/chinese/xcin/Makefile
@@ -0,0 +1,100 @@
+# New ports collection makefile for: xcin25
+# Date created: 18 Oct 1999
+# Whom: Keith Jang <keith@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xcin
+PORTVERSION= 2.5.3.p2
+PORTREVISION= 6
+CATEGORIES= chinese x11
+MASTER_SITES= ftp://ftp.linux.org.tw/pub/xcin/xcin/ \
+ ftp://ftp.linux.org.tw/pub/xcin/xcin/devel/ \
+ LOCAL/rafan
+DISTNAME= ${PORTNAME}-${PORTVERSION:S/p/pre/}
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} chewing-2002Jan07-snapshot.tar.gz
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Chinese input method server under X
+
+LIB_DEPENDS= tabe.3:${PORTSDIR}/chinese/libtabe
+RUN_DEPENDS= ${X11BASE}/lib/X11/fonts/local/kc15f.pcf.gz:${PORTSDIR}/chinese/kcfonts
+
+WRKSRC= ${WRKDIR}/xcin
+USE_BDB= yes
+OBSOLETE_BDB_VAR= USE_DB2
+USE_GETTEXT= yes
+USE_ICONV= yes
+USE_X_PREFIX= yes
+GNU_CONFIGURE= yes
+INSTALLS_SHLIB= yes
+CONFIGURE_ARGS= --prefix=${PREFIX} \
+ --x-libraries=${X11BASE}/lib \
+ --with-xcin-dir=${PREFIX}/lib/X11/xcin25 \
+ --with-db-name=${BDB_LIB_NAME} \
+ --with-db-inc=${BDB_INCLUDE_DIR} \
+ --with-db-lib=${BDB_LIB_DIR} \
+ --with-tabe-inc=${LOCALBASE}/include/tabe \
+ --with-tabe-lib=${LOCALBASE}/lib \
+ --with-intl-inc=${LOCALBASE}/include \
+ --with-intl-lib=${LOCALBASE}/lib \
+ --with-iconv-inc=${LOCALBASE}/include \
+ --with-iconv-lib=${LOCALBASE}/lib
+
+MAN1= xcin.1
+
+.include <bsd.port.pre.mk>
+
+pre-everything::
+.if defined(WITH_BDB_VER)
+ @${ECHO_CMD} ""
+ @${ECHO_CMD} "WARNING:"
+ @${ECHO_CMD} " You have defined WITH_BDB_VER. Make sure you use the same"
+ @${ECHO_CMD} " db version that libtabe uses. Otherwise, this port may"
+ @${ECHO_CMD} " not work correctly."
+ @${ECHO_CMD} ""
+.endif
+
+post-extract:
+ ${MV} ${WRKDIR}/chewing ${WRKSRC}/src/Cinput
+
+post-patch:
+ @cd ${WRKSRC}/src/Cinput/chewing; ${SH} ./patch_chewing
+ ${REINPLACE_CMD} -e "s,@euc,@euccn,g" \
+ -e "s,@gb2312,@euccn,g" \
+ ${WRKSRC}/etc/xcinrc.FREEBSD
+ ${REINPLACE_CMD} -e "s,euc ,euccn ,g" \
+ ${WRKSRC}/cin/gb/Makefile.in
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/lib/X11/xcin25/doc
+.for DOC in Bugs COPYING CREDITS Changes Cin CopyRight FAQ README \
+ SETUP Todo Usage UserGuide
+ ${INSTALL_DATA} ${WRKSRC}/doc/${DOC} ${PREFIX}/lib/X11/xcin25/doc
+.endfor
+ ${MKDIR} ${PREFIX}/lib/X11/xcin25/doc/En
+ ${MKDIR} ${PREFIX}/lib/X11/xcin25/doc/En/internal
+.for En in README.En SETUP.En Usage.En UserGuide.En
+ ${INSTALL_DATA} ${WRKSRC}/doc/En/${En} ${PREFIX}/lib/X11/xcin25/doc/En
+.endfor
+.for Eninternal in module.En structer.En
+ ${INSTALL_DATA} ${WRKSRC}/doc/En/internal/${Eninternal} ${PREFIX}/lib/X11/xcin25/doc/En/internal
+.endfor
+ ${MKDIR} ${PREFIX}/lib/X11/xcin25/doc/history
+ ${INSTALL_DATA} ${WRKSRC}/doc/history/Changes-19991011 \
+ ${PREFIX}/lib/X11/xcin25/doc/history
+ ${MKDIR} ${PREFIX}/lib/X11/xcin25/doc/internal
+.for INTERNAL in IMdkit gen_inp gui_request module structer
+ ${INSTALL_DATA} ${WRKSRC}/doc/internal/${INTERNAL} \
+ ${PREFIX}/lib/X11/xcin25/doc/internal
+.endfor
+ ${MKDIR} ${PREFIX}/lib/X11/xcin25/doc/modules
+.for MODULES in bimsphone gen_inp im_comm zh_hex
+ ${INSTALL_DATA} ${WRKSRC}/doc/modules/${MODULES} \
+ ${PREFIX}/lib/X11/xcin25/doc/modules
+.endfor
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/chinese/xcin/distinfo b/chinese/xcin/distinfo
new file mode 100644
index 000000000000..58621300ffcd
--- /dev/null
+++ b/chinese/xcin/distinfo
@@ -0,0 +1,6 @@
+MD5 (xcin-2.5.3.pre2.tar.gz) = 6f47203be515f505d5a6750dfbabc0bc
+SHA256 (xcin-2.5.3.pre2.tar.gz) = c55598853fae94fa72cf0517af9ac965dac11fa4d8b269eea4d6581dcd6405a0
+SIZE (xcin-2.5.3.pre2.tar.gz) = 1433915
+MD5 (chewing-2002Jan07-snapshot.tar.gz) = 6aea52faf907cb79beac5838057d8edb
+SHA256 (chewing-2002Jan07-snapshot.tar.gz) = 4c601aeee56a8d47264935249acc82ebb3653cf5b28fe6565b92f665ce8a949d
+SIZE (chewing-2002Jan07-snapshot.tar.gz) = 1152865
diff --git a/chinese/xcin/files/patch-aa b/chinese/xcin/files/patch-aa
new file mode 100644
index 000000000000..f426ba58619c
--- /dev/null
+++ b/chinese/xcin/files/patch-aa
@@ -0,0 +1,9 @@
+--- src/util/cin2tab/Makefile.in.orig Sat Sep 8 21:35:30 2001
++++ src/util/cin2tab/Makefile.in Sun Nov 4 17:09:07 2001
+@@ -25,4 +25,5 @@
+ distclean: clean
+ rm -rf Makefile .libs
+ install: $(BIN)
+- $(LIBTOOL) --mode=install $(INSTALL_PROGRAM) $(BIN) $(xcin_binp)
++ mkdir -p $(xcin_modp)/bin
++ $(LIBTOOL) --mode=install $(INSTALL_PROGRAM) $(BIN) $(xcin_modp)/bin
diff --git a/chinese/xcin/files/patch-ad b/chinese/xcin/files/patch-ad
new file mode 100644
index 000000000000..362a58c09674
--- /dev/null
+++ b/chinese/xcin/files/patch-ad
@@ -0,0 +1,11 @@
+--- src/Makefile.in.orig Sat Sep 22 00:41:41 2001
++++ src/Makefile.in Sun Nov 4 17:20:59 2001
+@@ -9,7 +9,7 @@
+ LIB = ${xcinlib} -lXimd -lim_comm lib/libxcin.la \
+ ${x_libraries} ${locale_lib} ${dl_lib} ${intl_lib} -lm
+
+-BIN = xcin
++BIN = xcin2.5
+ SRC = xcin_main.c module.c gui.c xim.c xim_IC.c fkey.c gui_main.c \
+ gui_menusel.c gui_overspot.c gui_main2.c
+ OBJ = $(SRC:.c=.o)
diff --git a/chinese/xcin/files/patch-ah b/chinese/xcin/files/patch-ah
new file mode 100644
index 000000000000..b27844556b58
--- /dev/null
+++ b/chinese/xcin/files/patch-ah
@@ -0,0 +1,11 @@
+--- po/Makefile.in.orig Sun Oct 8 12:12:14 2000
++++ po/Makefile.in Mon Oct 9 01:11:33 2000
+@@ -27,7 +27,7 @@
+ install:
+ if [ "$(GNU_GETTEXT)" = 1 ]; then \
+ for l in $(LC_MESG); do \
+- msgpath=$(xcin_msgp)/$$l/LC_MESSAGES; \
++ msgpath=$(xcin_msgp)/zh_TW.Big5/LC_MESSAGES; \
+ if [ ! -d $$msgpath ]; then \
+ $(INSTALL) -d $$msgpath; fi; \
+ msgfmt -o $$msgpath/xcin.mo xcin-$$l.po; \
diff --git a/chinese/xcin/files/patch-chewing::sort_word.c b/chinese/xcin/files/patch-chewing::sort_word.c
new file mode 100644
index 000000000000..933d29f960c6
--- /dev/null
+++ b/chinese/xcin/files/patch-chewing::sort_word.c
@@ -0,0 +1,10 @@
+--- src/Cinput/chewing/sort_word.c.orig Sun Aug 11 12:32:03 2002
++++ src/Cinput/chewing/sort_word.c Sun Aug 11 12:32:20 2002
+@@ -40,6 +40,7 @@
+ Key2Pho(phoneBuf, keyBuf, KB_DEFAULT, 1) ;
+ word_data[nWord].num = PhoneBg2Uint(phoneBuf) ;
+ nWord++ ;
++ return 0;
+ }
+
+ void Output()
diff --git a/chinese/xcin/files/patch-configure b/chinese/xcin/files/patch-configure
new file mode 100644
index 000000000000..50d0f2630665
--- /dev/null
+++ b/chinese/xcin/files/patch-configure
@@ -0,0 +1,68 @@
+--- configure.orig Tue Nov 27 09:21:17 2001
++++ configure Sat Apr 22 01:24:08 2006
+@@ -32,6 +32,8 @@
+ ac_help="$ac_help
+ --with-db-lib=PATH set the library dir of Berkeley DB2/3."
+ ac_help="$ac_help
++ --with-db-name=NAME set the library name of Berkeley DB."
++ac_help="$ac_help
+ --with-tabe-inc=PATH set the include dir of libtabe."
+ ac_help="$ac_help
+ --with-tabe-lib=PATH set the library dir of libtabe."
+@@ -869,6 +871,15 @@
+ fi
+
+
++# Check whether --with-db_name or --without-db_name was given.
++if test "${with_db_name+set}" = set; then
++ withval="$with_db_name"
++ test x$withval != x && with_db_name="$withval"
++else
++ with_db_name='db'
++fi;
++
++
+ # Check whether --with-tabe_inc or --without-tabe_inc was given.
+ if test "${with_tabe_inc+set}" = set; then
+ withval="$with_tabe_inc"
+@@ -7869,7 +7880,7 @@
+ fi
+
+ LIBS="$OLD_LIBS"
+-for f in db db3; do
++for f in $with_db_name; do
+ echo $ac_n "checking for db_create in -l$f""... $ac_c" 1>&6
+ echo "configure:7875: checking for db_create in -l$f" >&5
+ ac_lib_var=`echo $f'_'db_create | sed 'y%./+-%__p_%'`
+@@ -7878,16 +7889,20 @@
+ else
+ ac_save_LIBS="$LIBS"
+ LIBS="-l$f $LIBS"
++__db_create="db_create"
++if [ "$f" = "db-4.2" ]; then
++ __db_create="db_create_4002"
++fi
+ cat > conftest.$ac_ext <<EOF
+ #line 7883 "configure"
+ #include "confdefs.h"
+ /* Override any gcc2 internal prototype to avoid an error. */
+ /* We use char because int might match the return type of a gcc2
+ builtin and then its argument prototype would still apply. */
+-char db_create();
++char $__db_create();
+
+ int main() {
+-db_create()
++$__db_create()
+ ; return 0; }
+ EOF
+ if { (eval echo configure:7894: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
+@@ -7914,7 +7929,7 @@
+ test $found = y && break
+ done
+ if test $found = n; then
+- for f in db db2; do
++ for f in $with_db_name; do
+ echo $ac_n "checking for db_open in -l$f""... $ac_c" 1>&6
+ echo "configure:7920: checking for db_open in -l$f" >&5
+ ac_lib_var=`echo $f'_'db_open | sed 'y%./+-%__p_%'`
diff --git a/chinese/xcin/files/patch-gen_inp.c b/chinese/xcin/files/patch-gen_inp.c
new file mode 100644
index 000000000000..490a4d5f4ba6
--- /dev/null
+++ b/chinese/xcin/files/patch-gen_inp.c
@@ -0,0 +1,46 @@
+--- src/Cinput/gen_inp/gen_inp.c.orig Tue Nov 27 10:19:04 2001
++++ src/Cinput/gen_inp/gen_inp.c Tue Apr 9 19:15:32 2002
+@@ -1285,16 +1285,20 @@
+ inpinfo->mcch_grouping = NULL;
+
+ if ((keyinfo->keystate & Mod1Mask) && /* alt-Num/space */
+- (('1'<=keystr[0] && keystr[0]<='9') ||
++ (('0'<=keystr[0] && keystr[0]<='9') ||
+ ((cf->mode & INP_MODE_SPACEAUTOUP) && keysym==XK_space))) {
+ int choice=-1;
+
+ if (keysym == XK_space)
+ choice = 1;
+- else if (keystr[0] >= '1' && keystr[0] <= '9')
+- choice = (int)(keystr[0] - '0');
+- if (cf->mode & INP_MODE_SELKEYSHIFT)
+- choice ++;
++ else {
++ if (keystr[0] >= '1' && keystr[0] <= '9')
++ choice = (int)(keystr[0] - '0');
++ else if (keystr[0] == '0')
++ choice = 10;
++ if (cf->mode & INP_MODE_SELKEYSHIFT)
++ choice ++;
++ }
+ if (choice >= 1 && choice <= iccf->nreltsi) {
+ strncpy(cch_s, iccf->reltsi+iccf->tsiindex[choice-1],
+ iccf->tsigroup[choice]*2);
+@@ -1304,11 +1308,15 @@
+ }
+ hint_processing = 1;
+ }
+- else if (keysym==XK_Escape || keysym==XK_BackSpace ||
+- keysym==XK_Delete ||
++ else if (keysym==XK_Escape ||
+ keysym==XK_Shift_L || keysym==XK_Shift_R ||
+ keysym==XK_Control_L || keysym==XK_Control_R) {
+ hint_processing = 1;
++ }
++ else if (keysym==XK_BackSpace || keysym==XK_Delete) {
++ hint_processing = 1;
++ iccf->showtsiflag = 0;
++ ret |= IMKEY_IGNORE;
+ }
+ }
+ }
diff --git a/chinese/xcin/files/patch-gui_main.c b/chinese/xcin/files/patch-gui_main.c
new file mode 100644
index 000000000000..f0eee7a15ed8
--- /dev/null
+++ b/chinese/xcin/files/patch-gui_main.c
@@ -0,0 +1,11 @@
+--- src/gui_main.c.orig Mon Nov 26 08:54:25 2001
++++ src/gui_main.c Tue Apr 9 19:15:32 2002
+@@ -234,7 +234,7 @@
+ /*
+ len = wch_mblen(tmp);
+ */
+- len = 4;
++ len = (tmp->s[1] != '\0') ? 2 : 1;
+ XmbDrawImageString(gui->display, win->window,
+ win->font->fontset, win->wingc[GCM_idx], x, y, (char *)tmp->s, len);
+ x += XmbTextEscapement(win->font->fontset, (char *)tmp->s, len);
diff --git a/chinese/xcin/files/patch-xcinrc.FREEBSD b/chinese/xcin/files/patch-xcinrc.FREEBSD
new file mode 100644
index 000000000000..25566428e5fd
--- /dev/null
+++ b/chinese/xcin/files/patch-xcinrc.FREEBSD
@@ -0,0 +1,47 @@
+--- etc/xcinrc.FREEBSD.orig Thu Nov 29 21:50:42 2001
++++ etc/xcinrc.FREEBSD Sat Apr 20 02:08:58 2002
+@@ -75,7 +75,7 @@
+ (BEEP_WRONG YES)
+ (BEEP_DUPCHAR NO)
+ (TSI_FNAME "%tabe_data%tsi.db")
+- (HINT_SELECT NO)
++ (HINT_SELECT YES)
+ (HINT_TSI NO)))
+
+ (define bimsphone_default
+@@ -126,31 +126,27 @@
+
+ (define phone@big5
+ '((SETKEY 3)
+- (END_KEY YES)
+- (BEEP_DUPCHAR YES)))
++ (END_KEY YES)))
+
+ (define jyutping@big5
+ '((SETKEY 4)
+- (END_KEY YES)
+- (BEEP_DUPCHAR YES)))
++ (END_KEY YES)))
+
+ (define bimsphone@big5
+ '((SETKEY 6)
+ (MODULE "bimsphone")))
+
+ (define bimspinyin@big5
+- '((SETKEY 7)
++ '((SETKEY 5)
+ (MODULE "bimsphone")))
+
+ (define array30@big5
+ '((SETKEY 8)
+- (BEEP_DUPCHAR YES)
+ (DISABLE_SEL_LIST "w")
+ (KEYSTROKE_REMAP "t:0xaaba;T:0xaaba;")))
+
+ (define jyutping0@big5
+- '((SETKEY 9)
+- (BEEP_DUPCHAR YES)))
++ '((SETKEY 9)))
+
+
+ ;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
diff --git a/chinese/xcin/pkg-descr b/chinese/xcin/pkg-descr
new file mode 100644
index 000000000000..96bf5b695a3b
--- /dev/null
+++ b/chinese/xcin/pkg-descr
@@ -0,0 +1,11 @@
+xcin is a Chinese INput application in X, well support in both Traditional
+Chinese(Big5) and Simplified Chinese(GB) charsets. New version of xcin support
+standard XIM too. You can activate one xcin-XIM server, meanwhile, use
+different locale configuration to input Big5/GB words at the different
+sessions. This port is current version of xcin, code rewritten by
+Tung-Han Hsieh <thhsieh@linux.org.tw>.
+
+WWW: http://xcin.linux.org.tw/
+
+Porting to FreeBSD by Yung-Jen Hung <winard@ms11.url.com.tw>
+& Keith Jang <jtjang@gcn.net.tw>.
diff --git a/chinese/xcin/pkg-plist b/chinese/xcin/pkg-plist
new file mode 100644
index 000000000000..ec66cf3fe999
--- /dev/null
+++ b/chinese/xcin/pkg-plist
@@ -0,0 +1,83 @@
+bin/xcin2.5
+etc/xcinrc
+lib/X11/xcin25/bimsphone.a
+lib/X11/xcin25/bimsphone.la
+lib/X11/xcin25/bimsphone.so
+lib/X11/xcin25/bin/cin2tab
+lib/X11/xcin25/chewing.a
+lib/X11/xcin25/chewing.la
+lib/X11/xcin25/chewing.so
+%%PORTDOCS%%lib/X11/xcin25/doc/Bugs
+%%PORTDOCS%%lib/X11/xcin25/doc/COPYING
+%%PORTDOCS%%lib/X11/xcin25/doc/CREDITS
+%%PORTDOCS%%lib/X11/xcin25/doc/Changes
+%%PORTDOCS%%lib/X11/xcin25/doc/Cin
+%%PORTDOCS%%lib/X11/xcin25/doc/CopyRight
+%%PORTDOCS%%lib/X11/xcin25/doc/En/README.En
+%%PORTDOCS%%lib/X11/xcin25/doc/En/SETUP.En
+%%PORTDOCS%%lib/X11/xcin25/doc/En/Usage.En
+%%PORTDOCS%%lib/X11/xcin25/doc/En/UserGuide.En
+%%PORTDOCS%%lib/X11/xcin25/doc/En/internal/module.En
+%%PORTDOCS%%lib/X11/xcin25/doc/En/internal/structer.En
+%%PORTDOCS%%lib/X11/xcin25/doc/FAQ
+%%PORTDOCS%%lib/X11/xcin25/doc/README
+%%PORTDOCS%%lib/X11/xcin25/doc/SETUP
+%%PORTDOCS%%lib/X11/xcin25/doc/Todo
+%%PORTDOCS%%lib/X11/xcin25/doc/Usage
+%%PORTDOCS%%lib/X11/xcin25/doc/UserGuide
+%%PORTDOCS%%lib/X11/xcin25/doc/history/Changes-19991011
+%%PORTDOCS%%lib/X11/xcin25/doc/internal/IMdkit
+%%PORTDOCS%%lib/X11/xcin25/doc/internal/gen_inp
+%%PORTDOCS%%lib/X11/xcin25/doc/internal/gui_request
+%%PORTDOCS%%lib/X11/xcin25/doc/internal/module
+%%PORTDOCS%%lib/X11/xcin25/doc/internal/structer
+%%PORTDOCS%%lib/X11/xcin25/doc/modules/bimsphone
+%%PORTDOCS%%lib/X11/xcin25/doc/modules/gen_inp
+%%PORTDOCS%%lib/X11/xcin25/doc/modules/im_comm
+%%PORTDOCS%%lib/X11/xcin25/doc/modules/zh_hex
+lib/X11/xcin25/gen_inp.a
+lib/X11/xcin25/gen_inp.la
+lib/X11/xcin25/gen_inp.so
+lib/X11/xcin25/tab/big5/array30.tab
+lib/X11/xcin25/tab/big5/bims_pinyin.tab
+lib/X11/xcin25/tab/big5/cj.tab
+lib/X11/xcin25/tab/big5/default.phr
+lib/X11/xcin25/tab/big5/jyutping.tab
+lib/X11/xcin25/tab/big5/jyutping0.tab
+lib/X11/xcin25/tab/big5/phone.tab
+lib/X11/xcin25/tab/big5/pinyin.tab
+lib/X11/xcin25/tab/big5/pinyin0.tab
+lib/X11/xcin25/tab/big5/simplex.tab
+lib/X11/xcin25/tab/big5/sys.tab
+lib/X11/xcin25/tab/big5/telecode.tab
+lib/X11/xcin25/tab/ch_index.dat
+lib/X11/xcin25/tab/dict.dat
+lib/X11/xcin25/tab/euccn/default.phr
+lib/X11/xcin25/tab/euccn/jtcj_gb.tab
+lib/X11/xcin25/tab/euccn/pinyin.tab
+lib/X11/xcin25/tab/euccn/phonegb2.tab
+lib/X11/xcin25/tab/euccn/shuangpin.tab
+lib/X11/xcin25/tab/euccn/sys.tab
+lib/X11/xcin25/tab/euccn/wubizixing.tab
+lib/X11/xcin25/tab/fonetree.dat
+lib/X11/xcin25/tab/ph_index.dat
+lib/X11/xcin25/tab/us_freq.dat
+lib/X11/xcin25/zh_hex.a
+lib/X11/xcin25/zh_hex.la
+lib/X11/xcin25/zh_hex.so
+lib/libxcin.a
+lib/libxcin.la
+lib/libxcin.so
+lib/libxcin.so.0
+share/locale/zh_TW.Big5/LC_MESSAGES/xcin.mo
+%%PORTDOCS%%@dirrm lib/X11/xcin25/doc/En/internal
+%%PORTDOCS%%@dirrm lib/X11/xcin25/doc/En
+%%PORTDOCS%%@dirrm lib/X11/xcin25/doc/history
+%%PORTDOCS%%@dirrm lib/X11/xcin25/doc/internal
+%%PORTDOCS%%@dirrm lib/X11/xcin25/doc/modules
+%%PORTDOCS%%@dirrm lib/X11/xcin25/doc
+@dirrm lib/X11/xcin25/bin
+@dirrm lib/X11/xcin25/tab/big5
+@dirrm lib/X11/xcin25/tab/euccn
+@dirrm lib/X11/xcin25/tab
+@dirrm lib/X11/xcin25