aboutsummaryrefslogtreecommitdiffstats
path: root/chinese
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2018-01-01 03:14:12 +0800
committerKurt Jaeger <pi@FreeBSD.org>2018-01-01 03:14:12 +0800
commit7c35908087789ba37e03522e68e9db620ef9e69c (patch)
tree404eaff316999dea56b989c82ed4030b2f5b4bd8 /chinese
parent0be2c28b28c0ebe59bf8fd7c85b12bcee6ba43f4 (diff)
downloadfreebsd-ports-gnome-7c35908087789ba37e03522e68e9db620ef9e69c.tar.gz
freebsd-ports-gnome-7c35908087789ba37e03522e68e9db620ef9e69c.tar.zst
freebsd-ports-gnome-7c35908087789ba37e03522e68e9db620ef9e69c.zip
New port: chinese/libcangjie
This is a C library implementing the Cangjie input method. This library is based on Wan Leung Wong's original libcangjie with some updated API. WWW: https://github.com/Cangjians/libcangjie PR: 223565 Submitted by: hello@blubee.me
Diffstat (limited to 'chinese')
-rw-r--r--chinese/Makefile1
-rw-r--r--chinese/libcangjie/Makefile33
-rw-r--r--chinese/libcangjie/distinfo3
-rw-r--r--chinese/libcangjie/pkg-descr5
-rw-r--r--chinese/libcangjie/pkg-plist13
5 files changed, 55 insertions, 0 deletions
diff --git a/chinese/Makefile b/chinese/Makefile
index 4dbe24163c9f..29763ebec243 100644
--- a/chinese/Makefile
+++ b/chinese/Makefile
@@ -59,6 +59,7 @@
SUBDIR += kcfonts
SUBDIR += kde4-l10n-zh_CN
SUBDIR += kde4-l10n-zh_TW
+ SUBDIR += libcangjie
SUBDIR += libchewing
SUBDIR += libpinyin
SUBDIR += libreoffice-zh_CN
diff --git a/chinese/libcangjie/Makefile b/chinese/libcangjie/Makefile
new file mode 100644
index 000000000000..fbf20dcc1401
--- /dev/null
+++ b/chinese/libcangjie/Makefile
@@ -0,0 +1,33 @@
+# Created by: blubee <hello@blubee.me>
+# $FreeBSD$
+
+PORTNAME= libcangjie
+PORTVERSION= 1.3
+DISTVERSIONPREFIX= v
+CATEGORIES= chinese
+
+MAINTAINER= hello@blubee.me
+COMMENT= C library implementing the Cangjie input method
+
+LICENSE= GPLv3+
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= libsqlite3.so:databases/sqlite3 \
+ libfreetype.so:print/freetype2 \
+ libdbus-1.so:devel/dbus
+
+USES= autoreconf gmake libtool localbase pkgconfig sqlite
+
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+
+USE_XORT= xi
+
+USE_GITHUB= yes
+GH_ACCOUNT= Cangjians
+GH_PROJECT= libcangjie
+
+post-install:
+ @(${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/*.so)
+
+.include <bsd.port.mk>
diff --git a/chinese/libcangjie/distinfo b/chinese/libcangjie/distinfo
new file mode 100644
index 000000000000..504357372953
--- /dev/null
+++ b/chinese/libcangjie/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1509796688
+SHA256 (Cangjians-libcangjie-v1.3_GH0.tar.gz) = 4855f4369e2d51c23e331c6327b5be148d9ad0e61077ebe23e38e9bbeaceb25b
+SIZE (Cangjians-libcangjie-v1.3_GH0.tar.gz) = 695074
diff --git a/chinese/libcangjie/pkg-descr b/chinese/libcangjie/pkg-descr
new file mode 100644
index 000000000000..81c99fe710d1
--- /dev/null
+++ b/chinese/libcangjie/pkg-descr
@@ -0,0 +1,5 @@
+This is a C library implementing the Cangjie input method.
+This library is based on Wan Leung Wong's original libcangjie
+with some updated API.
+
+WWW: https://github.com/Cangjians/libcangjie
diff --git a/chinese/libcangjie/pkg-plist b/chinese/libcangjie/pkg-plist
new file mode 100644
index 000000000000..226345e6fbdc
--- /dev/null
+++ b/chinese/libcangjie/pkg-plist
@@ -0,0 +1,13 @@
+bin/libcangjie_bench
+bin/libcangjie_cli
+bin/libcangjie_dbbuilder
+include/cangjie/cangjie.h
+include/cangjie/cangjiechar.h
+include/cangjie/cangjiecharlist.h
+include/cangjie/cangjiecommon.h
+include/cangjie/cangjieerrors.h
+lib/libcangjie.so
+lib/libcangjie.so.2
+lib/libcangjie.so.2.0.1
+libdata/pkgconfig/cangjie.pc
+%%DATADIR%%/cangjie.db