aboutsummaryrefslogtreecommitdiffstats
path: root/chinese
diff options
context:
space:
mode:
authorscheidell <scheidell@FreeBSD.org>2012-05-01 21:53:06 +0800
committerscheidell <scheidell@FreeBSD.org>2012-05-01 21:53:06 +0800
commitd9fca1ac31526a7cb4d2170aab5ad7b3203c6352 (patch)
tree70ece727b27cee88432ebbd511ea9f8c6fe13c55 /chinese
parentcec0290a4b8a32b38550a98b145e1afef1537839 (diff)
downloadfreebsd-ports-gnome-d9fca1ac31526a7cb4d2170aab5ad7b3203c6352.tar.gz
freebsd-ports-gnome-d9fca1ac31526a7cb4d2170aab5ad7b3203c6352.tar.zst
freebsd-ports-gnome-d9fca1ac31526a7cb4d2170aab5ad7b3203c6352.zip
Add port: chinese/libpinyin, a Chinese pinyin input method algorithm
collection, as a back-end to the Fcitx IM framework. WWW: http://code.google.com/p/fcitx/ PR: ports/166716 Submitted by: Zhihao Yuan <lichray@gmail.com> (maintainer)
Diffstat (limited to 'chinese')
-rw-r--r--chinese/Makefile1
-rw-r--r--chinese/fcitx-libpinyin/Makefile35
-rw-r--r--chinese/fcitx-libpinyin/distinfo4
-rw-r--r--chinese/fcitx-libpinyin/pkg-descr4
-rw-r--r--chinese/fcitx-libpinyin/pkg-plist16
5 files changed, 60 insertions, 0 deletions
diff --git a/chinese/Makefile b/chinese/Makefile
index 82987b245602..da939c3cd053 100644
--- a/chinese/Makefile
+++ b/chinese/Makefile
@@ -40,6 +40,7 @@
SUBDIR += fcitx-cloudpinyin
SUBDIR += fcitx-configtool
SUBDIR += fcitx-googlepinyin
+ SUBDIR += fcitx-libpinyin
SUBDIR += fcitx-sunpinyin
SUBDIR += fcitx-ui-light
SUBDIR += fireflyttf
diff --git a/chinese/fcitx-libpinyin/Makefile b/chinese/fcitx-libpinyin/Makefile
new file mode 100644
index 000000000000..86702db93b9d
--- /dev/null
+++ b/chinese/fcitx-libpinyin/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: fcitx-libpinyin
+# Date created: 7 Apr 2012
+# Whom: Zhihao Yuan <lichray@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= fcitx-libpinyin
+PORTVERSION= 0.1.1
+CATEGORIES= chinese
+MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE} \
+ http://cloud.github.com/downloads/fcitx/fcitx-libpinyin/:libpinyin
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} model.text.tar.gz:libpinyin
+DIST_SUBDIR= fcitx
+EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
+
+MAINTAINER= lichray@gmail.com
+COMMENT= The libpinyin support for Fcitx
+
+LIB_DEPENDS= fcitx-config.4:${PORTSDIR}/chinese/fcitx \
+ pinyin.0:${PORTSDIR}/chinese/libpinyin
+
+USE_LDCONFIG= ${PREFIX}/lib/fcitx/
+USE_XZ= yes
+USE_GETTEXT= yes
+USE_CMAKE= yes
+USE_GNOME= intltool
+INSTALLS_ICONS= yes
+
+post-patch:
+ @${LN} -s ${_DISTDIR}/model.text.tar.gz ${WRKSRC}/data
+
+PROJECTHOST= fcitx
+
+.include <bsd.port.mk>
diff --git a/chinese/fcitx-libpinyin/distinfo b/chinese/fcitx-libpinyin/distinfo
new file mode 100644
index 000000000000..c59a0a77ba2b
--- /dev/null
+++ b/chinese/fcitx-libpinyin/distinfo
@@ -0,0 +1,4 @@
+SHA256 (fcitx/fcitx-libpinyin-0.1.1.tar.xz) = adb84d0b0f9f3bd26b124dd5c4130adacd7d15293fc0e1917266ff35c51be03c
+SIZE (fcitx/fcitx-libpinyin-0.1.1.tar.xz) = 24220
+SHA256 (fcitx/model.text.tar.gz) = 8d87d9c0b622f3163976a8c8bc57ded878cf0dee63c855b8a7afd36a151114eb
+SIZE (fcitx/model.text.tar.gz) = 9991219
diff --git a/chinese/fcitx-libpinyin/pkg-descr b/chinese/fcitx-libpinyin/pkg-descr
new file mode 100644
index 000000000000..877472a5e6fa
--- /dev/null
+++ b/chinese/fcitx-libpinyin/pkg-descr
@@ -0,0 +1,4 @@
+fcitx-libpinyin provides libpinyin, a Chinese pinyin input method algorithm
+collection, as a back-end to the Fcitx IM framework.
+
+WWW: http://code.google.com/p/fcitx/
diff --git a/chinese/fcitx-libpinyin/pkg-plist b/chinese/fcitx-libpinyin/pkg-plist
new file mode 100644
index 000000000000..23f6ef443218
--- /dev/null
+++ b/chinese/fcitx-libpinyin/pkg-plist
@@ -0,0 +1,16 @@
+lib/fcitx/fcitx-libpinyin.so
+share/fcitx/addon/fcitx-libpinyin.conf
+share/fcitx/configdesc/fcitx-libpinyin.desc
+share/fcitx/inputmethod/pinyin-libpinyin.conf
+share/fcitx/inputmethod/shuangpin-libpinyin.conf
+share/fcitx/inputmethod/zhuyin-libpinyin.conf
+share/fcitx/libpinyin/zhuyin_data/bigram.db
+share/fcitx/libpinyin/zhuyin_data/gb_char.bin
+share/fcitx/libpinyin/zhuyin_data/gbk_char.bin
+share/fcitx/libpinyin/zhuyin_data/phrase_index.bin
+share/fcitx/libpinyin/zhuyin_data/pinyin_index.bin
+share/icons/hicolor/48x48/status/fcitx-bopomofo.png
+share/locale/zh_CN/LC_MESSAGES/fcitx-libpinyin.mo
+share/locale/zh_TW/LC_MESSAGES/fcitx-libpinyin.mo
+@dirrm share/fcitx/libpinyin/zhuyin_data
+@dirrm share/fcitx/libpinyin