aboutsummaryrefslogtreecommitdiffstats
path: root/chinese
diff options
context:
space:
mode:
authorkeith <keith@FreeBSD.org>2001-06-23 01:41:48 +0800
committerkeith <keith@FreeBSD.org>2001-06-23 01:41:48 +0800
commite2f32df85976a1511754939a9488b322844abcc5 (patch)
treea4b3435b12a9b60eb273335b9011536d61cd54a3 /chinese
parent566e5e0d5eaf51a7963e9a32ae71fc71a628ff26 (diff)
downloadfreebsd-ports-gnome-e2f32df85976a1511754939a9488b322844abcc5.tar.gz
freebsd-ports-gnome-e2f32df85976a1511754939a9488b322844abcc5.tar.zst
freebsd-ports-gnome-e2f32df85976a1511754939a9488b322844abcc5.zip
Fix segmentation violation problem and make b5c works with DEVFS
in -CURRENT. Also tested under -STABLE. PR: ports/28341
Diffstat (limited to 'chinese')
-rw-r--r--chinese/big5con/Makefile1
-rw-r--r--chinese/big5con/files/patch-ai11
2 files changed, 12 insertions, 0 deletions
diff --git a/chinese/big5con/Makefile b/chinese/big5con/Makefile
index 605b7f80bbcb..c5b839a70d27 100644
--- a/chinese/big5con/Makefile
+++ b/chinese/big5con/Makefile
@@ -7,6 +7,7 @@
PORTNAME= big5con
PORTVERSION= 0.92e
+PORTREVISION= 1
CATEGORIES= chinese
MASTER_SITES= ftp://bsd.sinica.edu.tw/pub/FreeBSD/taiwan/users/woju/source/ \
ftp://bsd.sinica.edu.tw/pub/FreeBSD/taiwan/users/woju/binary/ \
diff --git a/chinese/big5con/files/patch-ai b/chinese/big5con/files/patch-ai
new file mode 100644
index 000000000000..95a9e1e89dcd
--- /dev/null
+++ b/chinese/big5con/files/patch-ai
@@ -0,0 +1,11 @@
+--- src/child.c.orig Fri Jun 22 23:14:24 2001
++++ src/child.c Sat Jun 23 00:48:55 2001
+@@ -106,7 +106,7 @@
+ #if defined(linux)
+ *(ttyname(fileno(errfp))+8));
+ #elif defined(__FreeBSD__)
+- *(ttyname(fileno(errfp))+9));
++ ttyname(fileno(errfp)) ? *(ttyname(fileno(errfp))+9) : '?');
+ #endif
+ fflush(stdout);
+