aboutsummaryrefslogtreecommitdiffstats
path: root/comms/deforaos-phone
diff options
context:
space:
mode:
authorOlivier Cochard <olivier@FreeBSD.org>2017-01-13 23:03:11 +0800
committerOlivier Cochard <olivier@FreeBSD.org>2017-01-13 23:03:11 +0800
commitcd56c05b82df4fe67e3b82273f42d8cd7a3c261e (patch)
tree7186bb188b87df04f96b287f9bfee65453362968 /comms/deforaos-phone
parent444f48a7b27c1a022e81d93fa2d64a084b84b568 (diff)
downloadfreebsd-ports-gnome-cd56c05b82df4fe67e3b82273f42d8cd7a3c261e.tar.gz
freebsd-ports-gnome-cd56c05b82df4fe67e3b82273f42d8cd7a3c261e.tar.zst
freebsd-ports-gnome-cd56c05b82df4fe67e3b82273f42d8cd7a3c261e.zip
Update to 0.5.1 (and fix build)
Diffstat (limited to 'comms/deforaos-phone')
-rw-r--r--comms/deforaos-phone/Makefile45
-rw-r--r--comms/deforaos-phone/distinfo5
-rw-r--r--comms/deforaos-phone/files/patch-doc_Makefile47
-rw-r--r--comms/deforaos-phone/files/patch-doc__Makefile23
-rw-r--r--comms/deforaos-phone/files/patch-src-plugins-Makefile11
-rw-r--r--comms/deforaos-phone/pkg-plist63
6 files changed, 131 insertions, 63 deletions
diff --git a/comms/deforaos-phone/Makefile b/comms/deforaos-phone/Makefile
index 5740fa80d90c..b5451299d085 100644
--- a/comms/deforaos-phone/Makefile
+++ b/comms/deforaos-phone/Makefile
@@ -2,10 +2,9 @@
# $FreeBSD$
PORTNAME= phone
-PORTVERSION= 0.3.12
-PORTREVISION= 3
+PORTVERSION= 0.5.1
CATEGORIES= comms
-MASTER_SITES= http://www.defora.org/os/download/download/4296/
+MASTER_SITES= http://www.defora.org/os/download/download/4455/
PKGNAMEPREFIX= deforaos-
DISTNAME= Phone-${PORTVERSION}
@@ -18,20 +17,48 @@ LIB_DEPENDS= libSystem.so:devel/deforaos-libsystem \
libDesktop.so:x11/deforaos-libdesktop \
libpulse.so:audio/pulseaudio \
libpurple.so:net-im/libpurple \
- libsofia-sip-ua.so:net/sofia-sip
+ libsofia-sip-ua.so:net/sofia-sip \
+ libfontconfig.so:x11-fonts/fontconfig \
+ libfreetype.so:print/freetype2
BUILD_DEPENDS= locker:x11/deforaos-locker \
- ${LOCALBASE}/include/linux/videodev2.h:multimedia/v4l_compat \
- xsltproc:textproc/libxslt \
- ${LOCALBASE}/share/xsl/docbook/manpages/docbook.xsl:textproc/docbook-xsl
+ ${LOCALBASE}/include/linux/videodev2.h:multimedia/v4l_compat
-USES= desktop-file-utils gettext pkgconfig
-USE_GNOME= gtk20
+USES= desktop-file-utils pkgconfig
+USE_GNOME= gtk20 cairo
INSTALLS_ICONS= yes
MAKE_ARGS+= PREFIX=${PREFIX}
MAKE_ENV+= MANDIR=${STAGEDIR}${MANPREFIX}/man
+OPTIONS_DEFINE= DOCS NLS
+OPTIONS_SUB= yes
+NLS_USES= gettext
+DOCS_BUILD_DEPENDS= xsltproc:textproc/libxslt \
+ ${LOCALBASE}/share/xsl/docbook/manpages/docbook.xsl:textproc/docbook-xsl
+
+post-patch-DOCS-off:
+ ${REINPLACE_CMD} 's|data doc include|data include|' \
+ ${WRKSRC}/Makefile
+
+post-patch-NLS-off:
+ ${REINPLACE_CMD} 's|include po src|include src|' \
+ ${WRKSRC}/Makefile
+
post-patch:
@${REINPLACE_CMD} -e 's,/dev/modem,/dev/cuaU0,g' \
${WRKSRC}/src/modems/hayes.c
+ @${REINPLACE_CMD} -e 's|/lib/|/libdata/|g' \
+ ${WRKSRC}/data/pkgconfig.sh
+ @${REINPLACE_CMD} 's|-Wl,-pie||g' \
+ ${WRKSRC}/tools/Makefile \
+ ${WRKSRC}/src/Makefile \
+ ${WRKSRC}/tests/Makefile
+ @${REINPLACE_CMD} 's|-lossaudio||' \
+ ${WRKSRC}/src/plugins/Makefile \
+ ${WRKSRC}/tests/Makefile
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/*
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/Phone/plugins/*
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/Phone/modem/*
.include <bsd.port.mk>
diff --git a/comms/deforaos-phone/distinfo b/comms/deforaos-phone/distinfo
index 89a3fb7145d1..72942936a458 100644
--- a/comms/deforaos-phone/distinfo
+++ b/comms/deforaos-phone/distinfo
@@ -1,2 +1,3 @@
-SHA256 (Phone-0.3.12.tar.gz) = 53c6d2484a3c11d6bdcd980254cfa41c5f5c8fbc811892e61bf0425a3bde416d
-SIZE (Phone-0.3.12.tar.gz) = 175768
+TIMESTAMP = 1484259053
+SHA256 (Phone-0.5.1.tar.gz) = 8762b78893725fdc8d2ec31ce2e69e5f0e77dbebc2f3b076f92db64042647e91
+SIZE (Phone-0.5.1.tar.gz) = 327180
diff --git a/comms/deforaos-phone/files/patch-doc_Makefile b/comms/deforaos-phone/files/patch-doc_Makefile
new file mode 100644
index 000000000000..0cf5656ac1af
--- /dev/null
+++ b/comms/deforaos-phone/files/patch-doc_Makefile
@@ -0,0 +1,47 @@
+--- doc/Makefile.orig 2017-01-12 16:11:40 UTC
++++ doc/Makefile
+@@ -1,7 +1,7 @@
+ MKDIR = mkdir -m 0755 -p
+ INSTALL = install
+ RM = rm -f
+-TARGETS = $(OBJDIR)gprs.1 $(OBJDIR)gprs.html $(OBJDIR)index.html $(OBJDIR)phone.1 $(OBJDIR)phone.html $(OBJDIR)phonectl.1 $(OBJDIR)phonectl.html
++TARGETS = $(OBJDIR)gprs.1 $(OBJDIR)phone.1 $(OBJDIR)phonectl.1
+ OBJDIR =
+ PREFIX = /usr/local
+ DESTDIR =
+@@ -37,23 +37,16 @@ $(OBJDIR)phonectl.html: manual.css.xml p
+ clean:
+ $(RM) -- $(gprs.1_OBJS) $(gprs.html_OBJS) $(index.html_OBJS) $(phone.1_OBJS) $(phone.html_OBJS) $(phonectl.1_OBJS) $(phonectl.html_OBJS)
+ ./docbook.sh -c -P "$(PREFIX)" -- "$(OBJDIR)gprs.1"
+- ./docbook.sh -c -P "$(PREFIX)" -- "$(OBJDIR)gprs.html"
+- ./docbook.sh -c -P "$(PREFIX)" -- "$(OBJDIR)index.html"
+ ./docbook.sh -c -P "$(PREFIX)" -- "$(OBJDIR)phone.1"
+- ./docbook.sh -c -P "$(PREFIX)" -- "$(OBJDIR)phone.html"
+ ./docbook.sh -c -P "$(PREFIX)" -- "$(OBJDIR)phonectl.1"
+- ./docbook.sh -c -P "$(PREFIX)" -- "$(OBJDIR)phonectl.html"
+
+ distclean: clean
+ $(RM) -- $(TARGETS)
+
+ install: $(TARGETS)
+ ./docbook.sh -P "$(DESTDIR)$(PREFIX)" -i -- "$(OBJDIR)gprs.1"
+- ./docbook.sh -P "$(DESTDIR)$(PREFIX)" -i -- "$(OBJDIR)gprs.html"
+ ./docbook.sh -P "$(DESTDIR)$(PREFIX)" -i -- "$(OBJDIR)phone.1"
+- ./docbook.sh -P "$(DESTDIR)$(PREFIX)" -i -- "$(OBJDIR)phone.html"
+ ./docbook.sh -P "$(DESTDIR)$(PREFIX)" -i -- "$(OBJDIR)phonectl.1"
+- ./docbook.sh -P "$(DESTDIR)$(PREFIX)" -i -- "$(OBJDIR)phonectl.html"
+ $(MKDIR) $(DESTDIR)$(PREFIX)/share/doc/Phone
+ $(INSTALL) -m 0644 phone.conf $(DESTDIR)$(PREFIX)/share/doc/Phone/phone.conf
+ $(MKDIR) $(DESTDIR)$(PREFIX)/share/doc/Phone
+@@ -65,11 +58,8 @@ install: $(TARGETS)
+
+ uninstall:
+ ./docbook.sh -P "$(DESTDIR)$(PREFIX)" -u -- "gprs.1"
+- ./docbook.sh -P "$(DESTDIR)$(PREFIX)" -u -- "gprs.html"
+ ./docbook.sh -P "$(DESTDIR)$(PREFIX)" -u -- "phone.1"
+- ./docbook.sh -P "$(DESTDIR)$(PREFIX)" -u -- "phone.html"
+ ./docbook.sh -P "$(DESTDIR)$(PREFIX)" -u -- "phonectl.1"
+- ./docbook.sh -P "$(DESTDIR)$(PREFIX)" -u -- "phonectl.html"
+ $(RM) -- $(DESTDIR)$(PREFIX)/share/doc/Phone/phone.conf
+ $(RM) -- $(DESTDIR)$(PREFIX)/share/doc/Phone/pppd-chat_gprs
+ $(RM) -- $(DESTDIR)$(PREFIX)/share/doc/Phone/pppd-peers_gprs
diff --git a/comms/deforaos-phone/files/patch-doc__Makefile b/comms/deforaos-phone/files/patch-doc__Makefile
deleted file mode 100644
index f1feeda08d81..000000000000
--- a/comms/deforaos-phone/files/patch-doc__Makefile
+++ /dev/null
@@ -1,23 +0,0 @@
---- doc/Makefile.orig 2013-11-04 12:16:46.534030500 +0100
-+++ doc/Makefile 2013-11-04 12:17:20.050448106 +0100
-@@ -1,4 +1,4 @@
--TARGETS = index.html phone.1 phone.html phonectl.1 phonectl.html
-+TARGETS = phone.1 phonectl.1
- PREFIX = /usr/local
- DESTDIR =
- RM = rm -f
-@@ -33,14 +33,10 @@
-
- install: $(TARGETS)
- ./docbook.sh -P "$(DESTDIR)$(PREFIX)" -i -- "phone.1"
-- ./docbook.sh -P "$(DESTDIR)$(PREFIX)" -i -- "phone.html"
- ./docbook.sh -P "$(DESTDIR)$(PREFIX)" -i -- "phonectl.1"
-- ./docbook.sh -P "$(DESTDIR)$(PREFIX)" -i -- "phonectl.html"
-
- uninstall:
- ./docbook.sh -P "$(DESTDIR)$(PREFIX)" -u -- "phone.1"
-- ./docbook.sh -P "$(DESTDIR)$(PREFIX)" -u -- "phone.html"
- ./docbook.sh -P "$(DESTDIR)$(PREFIX)" -u -- "phonectl.1"
-- ./docbook.sh -P "$(DESTDIR)$(PREFIX)" -u -- "phonectl.html"
-
- .PHONY: all clean distclean install uninstall
diff --git a/comms/deforaos-phone/files/patch-src-plugins-Makefile b/comms/deforaos-phone/files/patch-src-plugins-Makefile
deleted file mode 100644
index 2cb4f3240ea4..000000000000
--- a/comms/deforaos-phone/files/patch-src-plugins-Makefile
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/plugins/Makefile.orig 2012-06-24 15:48:33.000000000 +0200
-+++ src/plugins/Makefile 2012-06-24 15:48:43.000000000 +0200
-@@ -73,7 +73,7 @@
-
- oss_OBJS = oss.o
- oss_CFLAGS = $(CPPFLAGSF) $(CPPFLAGS) $(CFLAGSF) $(CFLAGS)
--oss_LDFLAGS = $(LDFLAGSF) $(LDFLAGS) -lossaudio
-+oss_LDFLAGS = $(LDFLAGSF) $(LDFLAGS)
-
- oss.so: $(oss_OBJS)
- $(CCSHARED) -o oss.so $(oss_OBJS) $(oss_LDFLAGS)
diff --git a/comms/deforaos-phone/pkg-plist b/comms/deforaos-phone/pkg-plist
index f93dc3dfaded..1ca58f72a1ad 100644
--- a/comms/deforaos-phone/pkg-plist
+++ b/comms/deforaos-phone/pkg-plist
@@ -1,3 +1,4 @@
+bin/gprs
bin/phone
bin/phonectl
include/Desktop/Phone.h
@@ -7,60 +8,86 @@ include/Desktop/Phone/phone.h
include/Desktop/Phone/plugin.h
lib/Phone/modem/debug.so
lib/Phone/modem/hayes.so
-lib/Phone/modem/purple.so
-lib/Phone/modem/sofia.so
lib/Phone/plugins/blacklist.so
+lib/Phone/plugins/console.so
lib/Phone/plugins/debug.so
lib/Phone/plugins/engineering.so
lib/Phone/plugins/gprs.so
lib/Phone/plugins/gps.so
-lib/Phone/plugins/locker.so
lib/Phone/plugins/n900.so
-lib/Phone/plugins/notify.so
lib/Phone/plugins/openmoko.so
lib/Phone/plugins/oss.so
lib/Phone/plugins/panel.so
lib/Phone/plugins/password.so
lib/Phone/plugins/profiles.so
-lib/Phone/plugins/pulseaudio.so
lib/Phone/plugins/smscrypt.so
lib/Phone/plugins/systray.so
lib/Phone/plugins/ussd.so
-man/man1/phone.1.gz
-man/man1/phonectl.1.gz
-share/applications/phone-contacts.desktop
-share/applications/phone-dialer.desktop
-share/applications/phone-log.desktop
-share/applications/phone-messages.desktop
-share/applications/phone-settings.desktop
-share/icons/hicolor/16x16/apps/phone-dialer.png
+libdata/pkgconfig/Phone.pc
+%%PORTDOCS%%man/man1/gprs.1.gz
+%%PORTDOCS%%man/man1/phone.1.gz
+%%PORTDOCS%%man/man1/phonectl.1.gz
+share/applications/deforaos-phone-contacts.desktop
+share/applications/deforaos-phone-dialer.desktop
+share/applications/deforaos-phone-log.desktop
+share/applications/deforaos-phone-messages.desktop
+share/applications/deforaos-phone-settings.desktop
+share/applications/deforaos-phone-sofia.desktop
+share/icons/hicolor/16x16/apps/phone-gprs.png
share/icons/hicolor/16x16/apps/phone-drafts.png
share/icons/hicolor/16x16/apps/phone-inbox.png
share/icons/hicolor/16x16/apps/phone-n900.png
share/icons/hicolor/16x16/apps/phone-openmoko.png
share/icons/hicolor/16x16/apps/phone-roaming.png
share/icons/hicolor/16x16/apps/phone-sent.png
-share/icons/hicolor/22x22/apps/phone-dialer.png
+share/icons/hicolor/22x22/apps/phone-gprs.png
share/icons/hicolor/22x22/apps/phone-signal-00.png
share/icons/hicolor/22x22/apps/phone-signal-100.png
share/icons/hicolor/22x22/apps/phone-signal-25.png
share/icons/hicolor/22x22/apps/phone-signal-50.png
share/icons/hicolor/22x22/apps/phone-signal-75.png
-share/icons/hicolor/24x24/apps/phone-dialer.png
+share/icons/hicolor/24x24/apps/phone-gprs.png
share/icons/hicolor/24x24/apps/phone-drafts.png
share/icons/hicolor/24x24/apps/phone-inbox.png
share/icons/hicolor/24x24/apps/phone-n900.png
share/icons/hicolor/24x24/apps/phone-openmoko.png
share/icons/hicolor/24x24/apps/phone-roaming.png
share/icons/hicolor/24x24/apps/phone-sent.png
-share/icons/hicolor/32x32/apps/phone-dialer.png
+share/icons/hicolor/32x32/apps/phone-gprs.png
share/icons/hicolor/32x32/apps/phone-n900.png
share/icons/hicolor/32x32/apps/phone-openmoko.png
share/icons/hicolor/32x32/apps/phone-roaming.png
-share/icons/hicolor/48x48/apps/phone-dialer.png
+share/icons/hicolor/48x48/apps/phone-gprs.png
share/icons/hicolor/48x48/apps/phone-inbox.png
share/icons/hicolor/48x48/apps/phone-n900.png
share/icons/hicolor/48x48/apps/phone-openmoko.png
share/icons/hicolor/48x48/apps/phone-roaming.png
share/icons/hicolor/48x48/apps/phone-sent.png
-share/locale/fr/LC_MESSAGES/Phone.mo
+share/sounds/Phone/0.wav
+share/sounds/Phone/1.wav
+share/sounds/Phone/2.wav
+share/sounds/Phone/3.wav
+share/sounds/Phone/4.wav
+share/sounds/Phone/5.wav
+share/sounds/Phone/6.wav
+share/sounds/Phone/7.wav
+share/sounds/Phone/8.wav
+share/sounds/Phone/9.wav
+share/sounds/Phone/a.wav
+share/sounds/Phone/b.wav
+share/sounds/Phone/busy.wav
+share/sounds/Phone/c.wav
+share/sounds/Phone/d.wav
+share/sounds/Phone/hash.wav
+share/sounds/Phone/keytone.wav
+share/sounds/Phone/ringback.wav
+share/sounds/Phone/ringtone.wav
+share/sounds/Phone/star.wav
+%%NLS%%share/locale/fr/LC_MESSAGES/Phone.mo
+%%NLS%%share/locale/es/LC_MESSAGES/Phone.mo
+%%PORTDOCS%%share/doc/Phone/gprs.conf
+%%PORTDOCS%%share/doc/Phone/phone.conf
+%%PORTDOCS%%share/doc/Phone/pppd-chat_gprs
+%%PORTDOCS%%share/doc/Phone/pppd-peers_gprs
+%%PORTDOCS%%share/doc/Phone/pppd-peers_phone
+%%PORTDOCS%%share/doc/Phone/ussd.conf