aboutsummaryrefslogtreecommitdiffstats
path: root/comms/echolinux/Makefile
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-11-16 07:17:54 +0800
committerpav <pav@FreeBSD.org>2004-11-16 07:17:54 +0800
commit109df961d2e8fff1a15f80235fdf556373595b09 (patch)
tree5eef3f5fa1b57350184a48a92cc0a591dfe53110 /comms/echolinux/Makefile
parentc8f43efd6aee25326f6b812af28c793f53ae2190 (diff)
downloadfreebsd-ports-gnome-109df961d2e8fff1a15f80235fdf556373595b09.tar.gz
freebsd-ports-gnome-109df961d2e8fff1a15f80235fdf556373595b09.tar.zst
freebsd-ports-gnome-109df961d2e8fff1a15f80235fdf556373595b09.zip
- Use external libgsm instead of bundled object file
PR: ports/73958 Submitted by: Diane Bruce <db@db.net> (maintainer)
Diffstat (limited to 'comms/echolinux/Makefile')
-rw-r--r--comms/echolinux/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/comms/echolinux/Makefile b/comms/echolinux/Makefile
index 37f2e671e65c..2836c697454e 100644
--- a/comms/echolinux/Makefile
+++ b/comms/echolinux/Makefile
@@ -7,6 +7,7 @@
PORTNAME= echolinux
PORTVERSION= 0.16a
+PORTREVISION= 1
CATEGORIES= comms
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= cqinet
@@ -15,7 +16,8 @@ EXTRACT_SUFX= .tgz
MAINTAINER= db@db.net
COMMENT= Amateur Radio Echolink client for UNIX
-LIB_DEPENDS= forms.1:${PORTSDIR}/x11-toolkits/xforms
+LIB_DEPENDS= forms.1:${PORTSDIR}/x11-toolkits/xforms \
+ gsm.1:${PORTSDIR}/audio/gsm
USE_REINPLACE= yes
@@ -31,6 +33,9 @@ post-patch:
${WRKSRC}/echolinux/control.c ${WRKSRC}/echolinux/vox.c
@${REINPLACE_CMD} -e 's|CC = gcc -O3|#CC = gcc -O3|' -e 's|^CFLAGS =|CFLAGS +=|' \
${WRKSRC}/echolinux/Makefile
+ @${REINPLACE_CMD} -e 's|LFLAGS = -lm|LFLAGS = -L${LOCALBASE}/lib -lm -lgsm|' \
+ -e 's|libgsm.a||' -e 's|-Igsm/inc|-I${LOCALBASE}/include|' \
+ ${WRKSRC}/echolinux/Makefile
post-install:
.if !defined(NOPORTDOCS)