aboutsummaryrefslogtreecommitdiffstats
path: root/comms/gnokii/files
diff options
context:
space:
mode:
authoranders <anders@FreeBSD.org>2003-05-21 07:52:47 +0800
committeranders <anders@FreeBSD.org>2003-05-21 07:52:47 +0800
commit10c287bf24e3396b84583a8e80363fcd9efe5406 (patch)
treea4d4e5e6bd6a0806649711ae5004357ef231c12c /comms/gnokii/files
parentfea3e80ea68e9a8d8e73c8e282b1bf0c706fd709 (diff)
downloadfreebsd-ports-gnome-10c287bf24e3396b84583a8e80363fcd9efe5406.tar.gz
freebsd-ports-gnome-10c287bf24e3396b84583a8e80363fcd9efe5406.tar.zst
freebsd-ports-gnome-10c287bf24e3396b84583a8e80363fcd9efe5406.zip
By me:
- Update to 0.5.0. - Add ftp.gnokii.org as MASTER_SITE, as it is back. And from Simon: - Fix package building - use pkg-install for adding/removing the gnokii group. - Use REINPLACE_CMD instead of sed for cleanliness. - Unbreak building on -current. PR: ports/47516 Submitted by: Simon Schubert <corecode@corecode.ath.cx> (partly)
Diffstat (limited to 'comms/gnokii/files')
-rw-r--r--comms/gnokii/files/patch-Docs-Makefile30
-rw-r--r--comms/gnokii/files/patch-Makefile.global.in7
-rw-r--r--comms/gnokii/files/patch-common-Makefile41
-rw-r--r--comms/gnokii/files/patch-configure18
-rw-r--r--comms/gnokii/files/patch-gnokii-Makefile16
-rw-r--r--comms/gnokii/files/patch-gnokiirc28
-rw-r--r--comms/gnokii/files/patch-po-Makefile.in.in12
7 files changed, 92 insertions, 60 deletions
diff --git a/comms/gnokii/files/patch-Docs-Makefile b/comms/gnokii/files/patch-Docs-Makefile
index 726d8ff324da..a7ff5cc2849b 100644
--- a/comms/gnokii/files/patch-Docs-Makefile
+++ b/comms/gnokii/files/patch-Docs-Makefile
@@ -1,25 +1,23 @@
---- Docs/Makefile.orig Thu Aug 8 23:07:58 2002
-+++ Docs/Makefile Thu Aug 8 23:08:44 2002
-@@ -32,19 +32,20 @@
+--- Docs/Makefile.orig Tue May 20 20:53:33 2003
++++ Docs/Makefile Tue May 20 20:54:25 2003
+@@ -62,6 +62,7 @@
@echo
install:
+ifndef NOPORTDOCS
- $(INSTALL) -d $(DESTDIR)/$(docdir)
- @for xxx in $(INSTALL_DOCS); do \
- if [ -e $$xxx ]; then \
- $(INSTALL) -m 0444 $$xxx $(DESTDIR)/$(docdir)/$$xxx; \
- fi; \
- done
-+endif
- $(INSTALL) -d $(DESTDIR)/$(man1dir)
- $(INSTALL) -d $(DESTDIR)/$(man8dir)
- $(INSTALL) $(GNOKII1_MAN) $(DESTDIR)/$(man1dir)
- $(INSTALL) $(GNOKII8_MAN) $(DESTDIR)/$(man8dir)
+ $(INSTALL) -d $(DESTDIR)$(docdir)
+ $(INSTALL) -d $(DESTDIR)$(docdir)/sample/logo
+ $(INSTALL) -d $(DESTDIR)$(docdir)/sample/ringtone
+@@ -78,10 +79,10 @@
+ $(INSTALL) $(GNOKII1_MAN) $(DESTDIR)$(man1dir)
+ $(INSTALL) $(GNOKII8_MAN) $(DESTDIR)$(man8dir)
if [ "x$(HAVE_XGNOKII)" = "xyes" ]; then \
-- $(INSTALL) -d $(DESTDIR)/$(xmandir); \
-- $(INSTALL) $(XGNOKII_MAN) $(DESTDIR)/$(xmandir); \
+- $(INSTALL) -d $(DESTDIR)$(xmandir); \
+- $(INSTALL) $(XGNOKII_MAN) $(DESTDIR)$(xmandir); \
+ $(INSTALL) $(XGNOKII_MAN) $(DESTDIR)/$(xmandir)/xgnokii.1; \
fi
@echo "done"
++endif
+ clean:
+ $(RM) *~
diff --git a/comms/gnokii/files/patch-Makefile.global.in b/comms/gnokii/files/patch-Makefile.global.in
index 5680ed4a0a1f..008f1472e53f 100644
--- a/comms/gnokii/files/patch-Makefile.global.in
+++ b/comms/gnokii/files/patch-Makefile.global.in
@@ -1,6 +1,6 @@
---- Makefile.global.in.orig Mon Aug 5 18:21:20 2002
-+++ Makefile.global.in Thu Aug 8 23:39:06 2002
-@@ -22,13 +22,13 @@
+--- Makefile.global.in.orig Tue May 20 20:34:17 2003
++++ Makefile.global.in Tue May 20 20:37:15 2003
+@@ -22,14 +22,14 @@
bindir = @bindir@
sbindir = @sbindir@
@@ -9,6 +9,7 @@
libdir = @libdir@
-xgnokii_libdir = @XGNOKIIDIR@/share/@XPACKAGE@
+xgnokii_libdir = ${prefix}/share/@XPACKAGE@
+ includedir = @includedir@
man1dir = @mandir@/man1/
man8dir = @mandir@/man8/
-xmandir = @XGNOKIIDIR@/man/man1/
diff --git a/comms/gnokii/files/patch-common-Makefile b/comms/gnokii/files/patch-common-Makefile
new file mode 100644
index 000000000000..cae242f53a05
--- /dev/null
+++ b/comms/gnokii/files/patch-common-Makefile
@@ -0,0 +1,41 @@
+--- common/Makefile.orig Tue May 20 21:04:08 2003
++++ common/Makefile Tue May 20 21:21:55 2003
+@@ -41,15 +41,12 @@
+ misc.o \
+ snprintf.o
+
+-ifdef NO_SHARED
+-GNOKII_LIB=libgnokii.a
+-else
++GNOKII_LIBNOSHARED =libgnokii.a
+ GNOKII_LIB =libgnokii.so
+ GNOKII_LIBM =$(GNOKII_LIB).$(MAJOR_NUMBER)
+ GNOKII_LIBMM=$(GNOKII_LIBM).$(MINOR_NUMBER)
+-endif
+
+-all: $(GNOKII_LIB)
++all: $(GNOKII_LIB) $(GNOKII_LIBNOSHARED)
+
+ phones/PHONES.o:
+ $(MAKE) -C phones PHONES.o
+@@ -64,8 +61,7 @@
+ $(CC) -o gnokii-debug $(OBJS) phones/PHONES.o links/LINKS.o devices/DEVICES.o ../gnokii/gnokii.o
+
+ libgnokii.so: $(OBJS) phones/PHONES.o links/LINKS.o devices/DEVICES.o
+- $(CC) -shared -Wl,-soname,$(GNOKII_LIBM) -o $(GNOKII_LIBMM) $(OBJS) phones/PHONES.o links/LINKS.o devices/DEVICES.o
+- ln -sf $(GNOKII_LIBMM) $(GNOKII_LIBM)
++ $(CC) -shared -Wl,-soname,$(GNOKII_LIBM) -o $(GNOKII_LIBM) $(OBJS) phones/PHONES.o links/LINKS.o devices/DEVICES.o
+ ln -sf $(GNOKII_LIBM) $(GNOKII_LIB)
+
+ libgnokii.a: $(OBJS) phones/PHONES.o links/LINKS.o devices/DEVICES.o
+@@ -84,8 +80,8 @@
+
+ install:
+ $(INSTALL) -d $(DESTDIR)$(libdir)
+- $(INSTALL) $(GNOKII_LIBMM) $(DESTDIR)$(libdir)
+- cd $(DESTDIR)$(libdir) && ln -sf $(GNOKII_LIBMM) $(GNOKII_LIBM)
++ $(INSTALL) $(GNOKII_LIBM) $(DESTDIR)$(libdir)
++ $(INSTALL) $(GNOKII_LIBNOSHARED) $(DESTDIR)$(libdir)
+ cd $(DESTDIR)$(libdir) && ln -sf $(GNOKII_LIBM) $(GNOKII_LIB)
+ $(INSTALL) -d $(DESTDIR)$(libdir)/pkgconfig
+ $(INSTALL) gnokii.pc $(DESTDIR)$(libdir)/pkgconfig
diff --git a/comms/gnokii/files/patch-configure b/comms/gnokii/files/patch-configure
index 715ecb972263..d816fd14e3d0 100644
--- a/comms/gnokii/files/patch-configure
+++ b/comms/gnokii/files/patch-configure
@@ -1,13 +1,13 @@
---- configure.orig Thu Aug 8 23:11:28 2002
-+++ configure Thu Aug 8 23:12:05 2002
-@@ -1973,8 +1973,8 @@
- if eval "test \"`echo '$ac_cv_lib_'$ac_lib_var`\" = yes"; then
- echo "$ac_t""yes" 1>&6
-
+--- configure.orig Tue May 20 20:29:43 2003
++++ configure Tue May 20 20:30:35 2003
+@@ -6407,8 +6407,8 @@
+ echo "${ECHO_T}$ac_cv_lib_c_r_pthread_attr_init" >&6
+ if test $ac_cv_lib_c_r_pthread_attr_init = yes; then
+
- PTHREAD_CFLAGS="$PTHREAD_CFLAGS -D_THREAD_SAFE"
-- PTHREAD_LIBS="-pthread"
+- PTHREAD_LIBS="-pthread"
+ PTHREAD_CFLAGS="$PTHREAD_CFLAGS %%PTHREAD_CFLAGS%%"
+ PTHREAD_LIBS="%%PTHREAD_LIBS%%"
- else
- echo "$ac_t""no" 1>&6
+ fi
+
fi
diff --git a/comms/gnokii/files/patch-gnokii-Makefile b/comms/gnokii/files/patch-gnokii-Makefile
deleted file mode 100644
index 5cab81797031..000000000000
--- a/comms/gnokii/files/patch-gnokii-Makefile
+++ /dev/null
@@ -1,16 +0,0 @@
---- gnokii/Makefile.orig Mon Aug 5 18:21:20 2002
-+++ gnokii/Makefile Thu Aug 8 23:26:03 2002
-@@ -25,12 +25,10 @@
- GNOKII_LIB=libgnokii.so
- endif
-
--LDLIBS += -L$(TOPDIR)/common -lgnokii
--
- all: gnokii
-
- gnokii: $(OBJS) $(TOPDIR)/common/gsm-filetypes.o $(TOPDIR)/common/$(GNOKII_LIB)
-- $(CC) $(LDFLAGS) $(OBJS) $(TOPDIR)/common/gsm-filetypes.o $(LDLIBS) -o $@
-+ $(CC) $(LDFLAGS) $(OBJS) $(TOPDIR)/common/gsm-filetypes.o -L$(TOPDIR)/common -lgnokii $(LDLIBS) -o $@
-
- $(TOPDIR)/getopt/libgetopt.a:
- $(MAKE) -C $(TOPDIR)/getopt
diff --git a/comms/gnokii/files/patch-gnokiirc b/comms/gnokii/files/patch-gnokiirc
index f11b412b40f3..0f38b9603175 100644
--- a/comms/gnokii/files/patch-gnokiirc
+++ b/comms/gnokii/files/patch-gnokiirc
@@ -1,19 +1,24 @@
---- Docs/sample/gnokiirc.orig Fri May 10 00:31:47 2002
-+++ Docs/sample/gnokiirc Thu May 23 02:07:50 2002
-@@ -5,10 +5,10 @@
- [global]
+--- Docs/sample/gnokiirc.orig Tue May 20 20:31:08 2003
++++ Docs/sample/gnokiirc Tue May 20 20:32:23 2003
+@@ -6,7 +6,7 @@
- # Set port to the physical serial port used to connect to your phone
+ # Set port to the physical serial port used to connect to your phone.
+ # Linux version is:
-port = /dev/ttyS0
+port = /dev/cuaa0
-
+ # For MacOSX you will need something like:
+ # port = /dev/cu.USA28X1P1.1
+ #
+@@ -14,7 +14,7 @@
+ # port = aa:bb:cc:dd:ee:ff
+
# Set model to the model number of your phone
-model = 6110
+model = 6210
# Initlength controls the number of characters sent to the
# phone during initialisation. You can either set it to
-@@ -38,7 +38,7 @@
+@@ -50,7 +50,7 @@
# port software (eg. minicom). If you have wrong permissions for the
# directory, a warning will be generated. If you don't want a lockfile, set
# it to 'no'.
@@ -22,12 +27,3 @@
# Baudrate to use on serial port connections.
# Currently used only by models AT and BIP/CIMD. Defaults to 19200.
-@@ -58,7 +58,7 @@
-
- # If defined (not commented out by '#') it will quit Gnokii anytime
- # when DCD line will drop.
--require_dcd = 1
-+#require_dcd = 1
-
- # Run the specified script(s) right after opening and initializing the device
- # and before any communucation (right before closing for disconnect_script).
diff --git a/comms/gnokii/files/patch-po-Makefile.in.in b/comms/gnokii/files/patch-po-Makefile.in.in
new file mode 100644
index 000000000000..79af0f06f158
--- /dev/null
+++ b/comms/gnokii/files/patch-po-Makefile.in.in
@@ -0,0 +1,12 @@
+--- po/Makefile.in.in.orig Tue May 20 23:06:48 2003
++++ po/Makefile.in.in Tue May 20 23:09:16 2003
+@@ -209,6 +209,9 @@
+ done; \
+ done
+
++install-suid: install
++ @echo
++
+ # Define this as empty until I found a useful application.
+ installcheck:
+