aboutsummaryrefslogtreecommitdiffstats
path: root/comms/gnuradio
diff options
context:
space:
mode:
authorDiane Bruce <db@FreeBSD.org>2019-04-16 22:19:46 +0800
committerDiane Bruce <db@FreeBSD.org>2019-04-16 22:19:46 +0800
commit3bd9e9378207f9acef0e7bdd04a0c6329c0d44d2 (patch)
treec7841ae78e4996edbf415b1cc912f589d1cc32f8 /comms/gnuradio
parentf441c474ff98e78504f3a7fbb2d6cefb72ff849e (diff)
downloadfreebsd-ports-gnome-3bd9e9378207f9acef0e7bdd04a0c6329c0d44d2.tar.gz
freebsd-ports-gnome-3bd9e9378207f9acef0e7bdd04a0c6329c0d44d2.tar.zst
freebsd-ports-gnome-3bd9e9378207f9acef0e7bdd04a0c6329c0d44d2.zip
Unbreak gnuradio due to boost 1.70
Remove patch needed for cpu affinity which is now not needed
Diffstat (limited to 'comms/gnuradio')
-rw-r--r--comms/gnuradio/Makefile3
-rw-r--r--comms/gnuradio/files/patch-gnuradio-runtime_lib_thread_thread.cc34
-rw-r--r--comms/gnuradio/files/patch-gr-blocks_lib_socket__pdu__impl.cc16
3 files changed, 17 insertions, 36 deletions
diff --git a/comms/gnuradio/Makefile b/comms/gnuradio/Makefile
index 44a39c92c4ce..2a1584650fe5 100644
--- a/comms/gnuradio/Makefile
+++ b/comms/gnuradio/Makefile
@@ -4,7 +4,7 @@ PORTNAME= gnuradio
#MASTER_SITES= http://gnuradio.org/releases/gnuradio/
# Temporary git version
DISTVERSION= 3.8.g20190309
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= comms astro hamradio
MAINTAINER= hamradio@FreeBSD.org
@@ -12,7 +12,6 @@ COMMENT= Amateur Radio Software defined radio
LICENSE= GPLv3
-BROKEN= fails to build with boost 1.70, see bug 236601
BROKEN_aarch64= fails to compile: /usr/lib/clang/5.0.0/include/mmintrin.h:47:5: use of undeclared identifier '__builtin_ia32_emms'; did you mean '__builtin_isless'?
BROKEN_armv6= fails to compile: /usr/lib/clang/5.0.0/include/mmintrin.h:47:5: use of undeclared identifier '__builtin_ia32_emms'; did you mean '__builtin_isless'?
BROKEN_armv7= fails to compile: /usr/lib/clang/5.0.0/include/mmintrin.h:47:5: use of undeclared identifier '__builtin_ia32_emms'; did you mean '__builtin_isless'?
diff --git a/comms/gnuradio/files/patch-gnuradio-runtime_lib_thread_thread.cc b/comms/gnuradio/files/patch-gnuradio-runtime_lib_thread_thread.cc
deleted file mode 100644
index abd76428f008..000000000000
--- a/comms/gnuradio/files/patch-gnuradio-runtime_lib_thread_thread.cc
+++ /dev/null
@@ -1,34 +0,0 @@
---- gnuradio-runtime/lib/thread/thread.cc.orig 2016-09-02 04:16:12 UTC
-+++ gnuradio-runtime/lib/thread/thread.cc
-@@ -284,6 +284,7 @@ namespace gr {
- void
- thread_bind_to_processor(gr_thread_t thread, const std::vector<int> &mask)
- {
-+#ifdef _GNU_SOURCE
- cpu_set_t set;
- size_t len = sizeof(cpu_set_t);
- std::vector<int> _mask = mask;
-@@ -299,6 +300,7 @@ namespace gr {
- s << "thread_bind_to_processor failed with error: " << ret << std::endl;
- throw std::runtime_error(s.str());
- }
-+#endif
- }
-
- void
-@@ -310,6 +312,7 @@ namespace gr {
- void
- thread_unbind(gr_thread_t thread)
- {
-+#ifdef _GNU_SOURCE
- cpu_set_t set;
- size_t len = sizeof(cpu_set_t);
-
-@@ -325,6 +328,7 @@ namespace gr {
- s << "thread_unbind failed with error: " << ret << std::endl;
- throw std::runtime_error(s.str());
- }
-+#endif
- }
-
- int
diff --git a/comms/gnuradio/files/patch-gr-blocks_lib_socket__pdu__impl.cc b/comms/gnuradio/files/patch-gr-blocks_lib_socket__pdu__impl.cc
new file mode 100644
index 000000000000..fda2556e3f65
--- /dev/null
+++ b/comms/gnuradio/files/patch-gr-blocks_lib_socket__pdu__impl.cc
@@ -0,0 +1,16 @@
+--- gr-blocks/lib/socket_pdu_impl.cc.orig 2019-04-16 13:45:00 UTC
++++ gr-blocks/lib/socket_pdu_impl.cc
+@@ -165,8 +165,11 @@ namespace gr {
+ void
+ socket_pdu_impl::start_tcp_accept()
+ {
+- tcp_connection::sptr new_connection = tcp_connection::make(d_acceptor_tcp->get_io_service(), d_rxbuf.size(), d_tcp_no_delay);
+-
++#if (BOOST_VERSION >= 107000)
++ tcp_connection::sptr new_connection = tcp_connection::make(d_io_service, d_rxbuf.size(), d_tcp_no_delay);
++#else
++ tcp_connection::sptr new_connection = tcp_connection::make(d_acceptor_tcp->get_io_service(), d_rxbuf.size(), d_tcp_no_delay);
++#endif
+ d_acceptor_tcp->async_accept(new_connection->socket(),
+ boost::bind(&socket_pdu_impl::handle_tcp_accept, this,
+ new_connection, boost::asio::placeholders::error));