aboutsummaryrefslogtreecommitdiffstats
path: root/comms/hylafax/Makefile
diff options
context:
space:
mode:
authorjhs <jhs@FreeBSD.org>1995-05-22 06:37:50 +0800
committerjhs <jhs@FreeBSD.org>1995-05-22 06:37:50 +0800
commit3e7eaf7b5cada71bc0c7c62b94543273bbd65d0d (patch)
treea8eb9d7836b3afda491078099e1eecc4187ea3ae /comms/hylafax/Makefile
parent57f2e4b3746bb096d9e3b3734a795639c983b35b (diff)
downloadfreebsd-ports-gnome-3e7eaf7b5cada71bc0c7c62b94543273bbd65d0d.tar.gz
freebsd-ports-gnome-3e7eaf7b5cada71bc0c7c62b94543273bbd65d0d.tar.zst
freebsd-ports-gnome-3e7eaf7b5cada71bc0c7c62b94543273bbd65d0d.zip
Reviewed by: Earlier draft reviewed by Satoshi (Thanks)
A new import based on Sam Leffler's Hylafax V3.0pl0. Flexfax is now obsolete. Import includes & applies the base patch Sam posted on the flexfax mail list (mail list is still called flexfax, though the package is called Hylafax). Sam declared our ports/comms/flexfax to be obsolete (over a year old). Sometime after the CD release, I will post a proposal to remove ports/comms/flexfax. I will maintain ports/comms/hylafax as I need fax capability. Thanks to Asami Satoshi for suggested improvements, I leave him to `bless' this port by adding the final comms/Makefile: SUBDIR += hylafax Until he does that, any mistakes I may have made shouldnt break any makes :-) I've undoubtedly screwed something up, somewhere, its a big port (30M inc bins),please test, Oh... and "Share & Enjoy" :-) --- Julian Stacey <jhs@freebsd.org> Tel. +49 89 268616. Fax Modem: 2608126 http://www.regent.e-technik.tu-muenchen.de/people/jhs.html
Diffstat (limited to 'comms/hylafax/Makefile')
-rw-r--r--comms/hylafax/Makefile162
1 files changed, 162 insertions, 0 deletions
diff --git a/comms/hylafax/Makefile b/comms/hylafax/Makefile
new file mode 100644
index 000000000000..ee21b428e586
--- /dev/null
+++ b/comms/hylafax/Makefile
@@ -0,0 +1,162 @@
+# ports collection makefile for: hylafax
+# Version required: v3.0pl0
+# Date created: 16 May 1995
+# Whom: Julian Stacey <jhs@freebsd.org>
+# To Replace: flexfax v2.3beta038special
+# Name changed from flexfax to hylafax by author of both: Sam Leffler.
+
+MAINTAINER= jhs@FreeBSD.org
+DISTNAME= hylafax-v3.0pl0
+PKGNAME= hylafax-3.0.0
+MASTER_SITES= ftp://ftp.sgi.com:sgi/fax/source/
+CATEGORIES+= comms
+KEYWORDS+= "fax modem"
+KEYWORDS+= facsimile
+KEYWORDS+= fax
+KEYWORDS+= fax2ps
+KEYWORDS+= faxalter
+KEYWORDS+= faxcover
+KEYWORDS+= faxd
+KEYWORDS+= faxgetty
+KEYWORDS+= faxmail
+KEYWORDS+= faxrm
+KEYWORDS+= faxstat
+KEYWORDS+= sendfax
+HAS_CONFIGURE= yes
+
+INSTALL= "sh port/install.sh"
+# By default, FreeBSD make of ports sets INSTALL=install,
+# <bsd.port.mk> says make wont allow variables to be unset.
+# Hylafax ${WRKSRC}/configure needs a special (supplied) install
+# (To quote ${WRKSRC}/config.site:
+# Beware of changing the INSTALL definition; you *must* have an
+# install script that emulates the Silicon Graphics install program!
+# ) which it assumes you dont want if you set INSTALL.
+# I would prefer to unset the INSTALL from the FreeBSD ports mechanism,
+# but instead I reset it to what Hylafax wants.
+# As this is still insufficient, See also patches/patch-ad.
+
+.if !exists(patches/patch-ab)
+IS_INTERACTIVE= yes
+# patches/patch-ab makes this BATCH compilable,
+# ( If you need interactive config, mv patch-ab patch-ab.mv )
+.endif
+
+# EXEC_DEPENDS?= ghostview:${PORTSDIR}/print/ghostview
+# For viewing faxes, not essential for compiling.
+
+EXEC_DEPENDS+= gs:${PORTSDIR}/print/ghostscript
+# ghostscript is called by faxcover & sendfax.
+# FreeBSD ports does not come with ghostscript-3 (the license is
+# restrictive), FreeBSD ports comes with ghostscript-2.6.2, which
+# is what I'm currently using. Sam Leffler wrote:
+# Ghostscript versions since 3.12 have had a working tiffg32d
+# driver, but beware of versions before 3.12 that have a
+# tiffg32d driver; those drivers generate invalid 2D-encoded data.
+
+# Someone with more time & less space than me can investigate merging these.
+# LIB_DEPENDS= something:${PORTSDIR}/graphics/tiff
+# ./libtiff has 2M, & may be duplicates of what is in ${PORTSDIR}/graphics/tiff
+# LIB_DEPENDS= something:${PORTSDIR}/print/afm
+# ./afm/ has 536K of fonts, that perhaps could be merged.
+
+FAXCOVER?= /etc/faxcover.ps
+# Default location to check for an optional over-riding host specific
+# customised faxcover that will be installed in these sources,
+# & end up where Hylafax installs all its stuff by default:
+# /var/spool/fax/etc/....
+# Note dont make FAXCOVER use a variable (such as ${PREFIX}),
+# as that wont work in `exists' below.
+
+# ------------------------------------------------------------------------------
+
+pre-fetch:
+ @# Ref. ${DISTNAME} ...
+ @echo "Warning - Original distribution is:"
+ @echo " ftp://ftp.sgi.com/sgi/fax/source/hylafax-v3.0pl0-tar.gz"
+ @echo "but /usr/share/mk/bsd.port*mk expects something.tar.gz, and "
+ @echo "will not allow something-tar.gz, "
+ @# Perhaps asami@freebsd.org can be persuaded to investigate ?
+ @echo -n "so until someone enhances"
+ @echo "FreeBSD make macros, do this:"
+ @echo -n " cd /usr/ports/distfiles ; "
+ @echo "ln -s hylafax-v3.0pl0-tar.gz hylafax-v3.0pl0.tar.gz"
+
+post-configure:
+.if exists(${FAXCOVER})
+ @echo I see you have ${FAXCOVER},
+ @echo which I will use to install a system default from.
+ @# When I suggested to Sam (in the flexfax mailing list) merging
+ @# in the distribution util/cover.templ & faxcover/faxcover.ps
+ @# ( as they are virtually identical) Sam said they're for
+ @# different things, & wouldn't do it. I don't know what the
+ @# different purposes are, & I Do succesfully use the same file.
+ -cd ${WRKSRC} ; mv faxcover/faxcover.ps faxcover/faxcover.ps.mv
+ -cd ${WRKSRC} ; mv util/cover.templ util/cover.templ.mv
+ -cd ${WRKSRC} ; ln -s ../cover.ps faxcover/faxcover.ps
+ -cd ${WRKSRC} ; ln -s ../cover.ps util/cover.templ
+ -cd ${WRKSRC} ; ln -s ${FAXCOVER} cover.ps
+.endif
+.if exists(patches/patch-ab)
+ @echo "patches/patch-ab has supressed interactive configuration."
+ @# If you need interactive config, mv patch-ab patch-ab.mv
+.endif
+
+post-install:
+ cd ${PREFIX}/bin ; strip \
+ fax2ps faxalter faxcover faxmail faxrm faxstat sendfax sendpage
+ cd ${PREFIX}/sbin ; strip faxd.recv faxgetty faxq
+ @echo "Hylafax by default only does this sete[gu]id 0 stuff:"
+ @echo " -u uucp -m 4755 faxq faxgetty"
+ @echo "If you, like I, think it needs more, run 'make suid'"
+ @echo "Now consider running faxaddmodem"
+
+SUID_EXES= /usr/local/sbin/faxgetty
+SUID_EXES+= /usr/local/sbin/faxq
+SUID_EXES+= /usr/local/bin/faxrm
+SUID_EXES+= /usr/local/bin/faxalter
+suid:
+ @# This does too much, & may perhaps cause security loopholes,
+ @# but default Hylafax doesnt do enough, eg faxrm wont work,
+ @# & even worse, I have received a faxes that then silent failed
+ @# to write to recvq.
+ @# Only fax modem users who test their hypotheses may change this !
+ @# (Imagine losing an important incoming fax, if recvq is unwritable.)
+ chown uucp ${SUID_EXES}
+ chgrp dialer ${SUID_EXES}
+ chmod 6555 ${SUID_EXES}
+ find /var/spool/fax -print | xargs chown uucp
+ find /var/spool/fax -print | xargs chgrp dialer
+ find /var/spool/fax -print | xargs chmod g+w
+ find /var/spool/fax -print | xargs chmod g+r
+ find /var/spool/fax -type d -print | xargs chmod g+x
+ # now remove some x bits that get set by mistake.
+ -cd /var/spool/fax ; chmod g-x FIFO* log/* status/* recvq/* sendq/*
+ @echo "Now nonsider doing somethink like this:"
+ @echo " sh"
+ @echo " n=1"
+ @echo ' all="ttyd$$n ttyid$$n ttyld$$n cua0$$n cuai0$$n cual0$$n"'
+ @echo ' chown uucp $$all; chgrp dialer $$all; chmod 660 $$all'
+
+post-clean:
+ rm -f \
+ fax2ps/fax2ps \
+ faxalter/faxalter \
+ faxcover/faxcover \
+ faxd/faxd \
+ faxgetty/faxgetty \
+ faxmail/faxmail \
+ faxq/faxq \
+ faxrm/faxrm \
+ faxstat/faxstat \
+ recvfax/recvfax \
+ sendfax/sendfax \
+ sendpage/sendpage \
+ sgi2fax/sgi2fax
+ @# Sam Leffler (author of Hylafax) has a non standard view of
+ @# `make clean': he leaves binaries intact - deliberately !
+ @# One cannot use /usr/share/mk/bsd.port.mk re-clean: to invoke
+ @# `make clobber' before `make clean'
+ @# as it results in `"rules", ... Could not find Makedepend'
+
+.include <bsd.port.mk>
a href='/~lantw44/cgit/cgit.cgi/freebsd-ports-gnome/commit/lang?id=dc11a75b0fa30633ab47efa29c46458e3ff1ab86'>Disable BROKEN for armv6.linimon2016-10-171-1/+4 * Fix build on FreeBSD<11romain2016-10-161-0/+5 * lang/nim: update 0.11.2 -> 0.15.0robak2016-10-159-270/+527 * Update to the 20161013 snapshot of GCC 6.gerald2016-10-152-4/+4 * lang/fsharp: add missing patch filesdbn2016-10-142-0/+19 * lang/fsharp: fix build, add test support.dbn2016-10-142-3/+68 * lang/referenceassemblies-pcl: add new portdbn2016-10-146-0/+1103 * lang/pypy3: update to 5.5.0dbn2016-10-149-97/+38 * Update to the 20161011 snapshot of GCC 5.4.1.gerald2016-10-142-4/+4 * Update Erlang 19 ports to version 19.1.4.olgeni2016-10-148-14/+26 * Update Perl 5.22.3 & 5.24.1 to -RC4.mat2016-10-144-8/+8 * Update to version 5.7.2pawel2016-10-132-3/+4 * Update Erlang 19 ports to version 19.1.3.olgeni2016-10-128-14/+22 * Mark broken on aarch64: fails to link.linimon2016-10-121-0/+1 * Broken on aarch64 as well.linimon2016-10-121-0/+1 * Mark as broken on aarch64.linimon2016-10-121-1/+1 * Mark as broken on armv6 after recent runs.linimon2016-10-121-0/+2 * Update to the 20161009 development snapshot of GCC 7.gerald2016-10-112-5/+4 * Update lang/abcl to version 1.4.0.olgeni2016-10-112-3/+4 * - Unconditionally verbosify build as per PHBamdmi32016-10-111-2/+0 * Update to v5.25.5-76-g91dca83.mat2016-10-102-4/+4 * Update lang/elixir to version 1.3.4.olgeni2016-10-103-18/+18 * devel/nspr, security/nss: drop version from SONAMEjbeich2016-10-094-4/+4 * Mark BROKEN: fails to packageantoine2016-10-091-0/+2 * Update to the 20161006 snapshot of GCC 6.gerald2016-10-082-4/+4 * Update to the 20161004 snapshot of GCC 5.4.1.gerald2016-10-082-4/+4 * Update Erlang 19 ports to version 19.1.2.olgeni2016-10-078-12/+28 * lang/tcl87: update to fossil checkin faa78e6080f9033fgahr2016-10-073-5/+6 * Fix sysctl(3) call in mono_process_list() where the MIB length argument was ...tj2016-10-064-2/+22 * lang/pypy: IGNORE when building with libresslmarino2016-10-051-2/+6 * lang/phantomjs: Remove PROJECTHOST, a relic from when this was hosted on Goog...feld2016-10-041-1/+0 * lang/phantomjs: Do not enable X11 support by defaultfeld2016-10-041-2/+5 * Support for Java (both the GCJ front end and libgcj) has been removedgerald2016-10-044-83/+5 * lang/seed7: update to 05_20161002gahr2016-10-032-4/+4 * Update to v5.25.5-64-g1c56654.mat2016-10-032-4/+4 * - Update to 0.7.7ashish2016-10-033-4/+13 * Update to the 20161002 development snapshot of GCC 7.gerald2016-10-032-4/+4 * Update Erlang 19 ports to version 19.1.1.olgeni2016-10-028-12/+29 * Update to the 20160929 snapshot of GCC 6.gerald2016-10-022-4/+4 * lang/rust: Update distinfo.x86_64 for DragonFly support for v1.12marino2016-10-021-5/+5 * Update to upstream release 1.12.0riggs2016-10-018-59/+45 * - Convert sparc64 BROKEN to helperamdmi32016-10-011-7/+4 * Remove expired ports:rene2016-10-019-274/+0 * Update to version 16.1pawel2016-10-012-7/+9 * Update to the 20160927 snapshot of GCC 5.4.1.gerald2016-09-302-4/+4 * - Update devel/doxygen to 1.8.12antoine2016-09-283-129/+129 * Update to the 20160925 development snapshot of GCC 7.gerald2016-09-272-4/+4 * Only depend on XSLoader if perl < 5.24.1.adamw2016-09-261-11/+11 * Update to v5.25.5-24-g98fce2a.mat2016-09-264-5/+7 * - Update to 0.416lth2016-09-262-5/+7 * lang/fpc-units: Set VLC unit as a non-default optionmarino2016-09-251-2/+5 * - Update devel/icu to 57.1.tijl2016-09-245-5/+5 * Update to the 20160922 snapshot of GCC 6.gerald2016-09-242-4/+4 * Disable building Java on powerpc64 (option JAVA) by default. It isgerald2016-09-241-1/+0 * Put back the mail-header patch.mat2016-09-231-0/+2 * lang/php56: Update from 5.6.25 to 5.6.26tz2016-09-232-7/+5 * Fix obvious braino.linimon2016-09-231-4/+4 * Remove redundant WX_UNICODE from Erlang runtime ports..olgeni2016-09-224-4/+0 * Update Erlang ports to 19.1.olgeni2016-09-229-188/+46 * Update to the 20160920 snapshot of GCC 5.4.1.gerald2016-09-222-4/+4 * Update to the 20160918 development snapshot of GCC 7.gerald2016-09-222-4/+4 * lang/php70: Update from 7.0.10 to 7.0.11tz2016-09-212-5/+5 * Update lang/alchemist.el to version 1.8.1.olgeni2016-09-213-3/+10 * lang/phantomjs: Remove hack for FreeBSD 9 and use compiler:c++11-langfeld2016-09-201-6/+1 * Update to v5.25.4-177-g1608ed2.mat2016-09-192-4/+4 * Mark as broken on sparc64.linimon2016-09-191-0/+2 * Mark as broken on various tier-2 archs.linimon2016-09-191-0/+4 * Mark as broken on various tier-2 archs.linimon2016-09-191-0/+5 * Update to the 20160915 snapshot of GCC 6.gerald2016-09-192-4/+4 * Update lang/elixir to version 1.3.3.olgeni2016-09-193-18/+21 * Mark as broken on sparc64.linimon2016-09-181-0/+1 * lang/phantomjs: Fix build on 9.3 and 11.0feld2016-09-173-17/+43 * Update the Qt5 ports to 5.6.1.rakuco2016-09-173-24/+44 * Add USES+=ssl to 3 of 8 graphics/libGL/Makefile.common consumersmarino2016-09-161-0/+1 * lang/ypsilon: Update sources and fix buildsrobak2016-09-153-7/+12 * Update to the 20160913 snapshot of GCC 5.4.1.gerald2016-09-152-4/+4 * Unmark broken on powerpc64swills2016-09-151-2/+0 * Drop spark-related ports for removal after 30 Septmarino2016-09-151-2/+2 * Release some of my ports back to the heapmarino2016-09-151-1/+1 * GOOGLE_CODE has gone away.mat2016-09-146-0/+12 * Replace the short lived Erlang 19.0.6 with 19.0.7.olgeni2016-09-148-14/+26 * Update Erlang ports to version 19.0.6.olgeni2016-09-148-28/+28 * Update to v5.25.4-111-g92b69f6.mat2016-09-132-4/+4 * Update to GNU awk 4.1.4johans2016-09-133-4/+6 * Update to the 20160911 development snapshot of GCC 7.gerald2016-09-122-4/+4 * Add cilkplus: A set of compiler extensions from Intel for parallel computingriggs2016-09-126-0/+99