aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authortj <tj@FreeBSD.org>2016-10-06 01:46:10 +0800
committertj <tj@FreeBSD.org>2016-10-06 01:46:10 +0800
commit382f2440010011eb461e177e80763427435e138a (patch)
tree6381829ec824c28b6ec8e1f47b833d01e482f12a /lang
parentda0f60b8a06b2ea6087d338f29c0a24ce5207449 (diff)
downloadfreebsd-ports-gnome-382f2440010011eb461e177e80763427435e138a.tar.gz
freebsd-ports-gnome-382f2440010011eb461e177e80763427435e138a.tar.zst
freebsd-ports-gnome-382f2440010011eb461e177e80763427435e138a.zip
Fix sysctl(3) call in mono_process_list() where the MIB length argument was incorrectly passed to sysctl(3)
PR: 174216 Submitted by: tj Approved by: maintainer timeout
Diffstat (limited to 'lang')
-rw-r--r--lang/mono/Makefile1
-rw-r--r--lang/mono/files/patch-eglib_src_gfile-posix.c2
-rw-r--r--lang/mono/files/patch-mono_metadata_socket-io.c2
-rw-r--r--lang/mono/files/patch-mono_utils_patch-mono__utils__mono-proclib.c19
4 files changed, 22 insertions, 2 deletions
diff --git a/lang/mono/Makefile b/lang/mono/Makefile
index c9695bbd12da..1130c881dad2 100644
--- a/lang/mono/Makefile
+++ b/lang/mono/Makefile
@@ -3,6 +3,7 @@
PORTNAME= mono
PORTVERSION= 4.4.2.11
+PORTREVISION= 1
CATEGORIES= lang
MASTER_SITES= http://download.mono-project.com/sources/${PORTNAME}/
diff --git a/lang/mono/files/patch-eglib_src_gfile-posix.c b/lang/mono/files/patch-eglib_src_gfile-posix.c
index 3d06b6ca670a..d8fcb0836d4c 100644
--- a/lang/mono/files/patch-eglib_src_gfile-posix.c
+++ b/lang/mono/files/patch-eglib_src_gfile-posix.c
@@ -1,4 +1,4 @@
---- eglib/src/gfile-posix.c.orig 2015-09-24 09:36:09 UTC
+--- eglib/src/gfile-posix.c.orig 2016-07-29 09:10:29 UTC
+++ eglib/src/gfile-posix.c
@@ -170,7 +170,7 @@ g_get_current_dir (void)
do {
diff --git a/lang/mono/files/patch-mono_metadata_socket-io.c b/lang/mono/files/patch-mono_metadata_socket-io.c
index b153fc45d99e..6282a2b5e045 100644
--- a/lang/mono/files/patch-mono_metadata_socket-io.c
+++ b/lang/mono/files/patch-mono_metadata_socket-io.c
@@ -1,7 +1,7 @@
Fix build on FreeBSD 8
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=198404#c6
---- mono/metadata/socket-io.c.orig 2015-11-12 09:00:29 UTC
+--- mono/metadata/socket-io.c.orig 2016-07-29 09:10:33 UTC
+++ mono/metadata/socket-io.c
@@ -26,6 +26,7 @@
#ifdef HOST_WIN32
diff --git a/lang/mono/files/patch-mono_utils_patch-mono__utils__mono-proclib.c b/lang/mono/files/patch-mono_utils_patch-mono__utils__mono-proclib.c
new file mode 100644
index 000000000000..906199b6a1fc
--- /dev/null
+++ b/lang/mono/files/patch-mono_utils_patch-mono__utils__mono-proclib.c
@@ -0,0 +1,19 @@
+--- mono/utils/patch-mono_utils_mono-proclib.c.orig 2016-10-05 17:28:38 UTC
++++ mono/utils/patch-mono_utils_mono-proclib.c
+@@ -0,0 +1,16 @@
++--- mono/utils/mono-proclib.c.orig 2016-07-29 09:10:33 UTC
+++++ mono/utils/mono-proclib.c
++@@ -107,11 +107,11 @@ mono_process_list (int *size)
++ mib [2] = KERN_PROC_ALL;
++ mib [3] = 0;
++
++- res = sysctl (mib, 4, NULL, &data_len, NULL, 0);
+++ res = sysctl (mib, 3, NULL, &data_len, NULL, 0);
++ if (res)
++ return NULL;
++ processes = (struct kinfo_proc *) malloc (data_len);
++- res = sysctl (mib, 4, processes, &data_len, NULL, 0);
+++ res = sysctl (mib, 3, processes, &data_len, NULL, 0);
++ if (res < 0) {
++ free (processes);
++ if (errno != ENOMEM)