aboutsummaryrefslogtreecommitdiffstats
path: root/comms/hylafax/Makefile
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2007-09-09 19:38:35 +0800
committeredwin <edwin@FreeBSD.org>2007-09-09 19:38:35 +0800
commit97ccc6ae6132b110e781c30f52c4fdf4a011df10 (patch)
treeb28423a1d7a9d5abb546ed8b7cac2ff205cad4ca /comms/hylafax/Makefile
parent11ab3e282b8988fc24f060eff01e96ed8d324af4 (diff)
downloadfreebsd-ports-gnome-97ccc6ae6132b110e781c30f52c4fdf4a011df10.tar.gz
freebsd-ports-gnome-97ccc6ae6132b110e781c30f52c4fdf4a011df10.tar.zst
freebsd-ports-gnome-97ccc6ae6132b110e781c30f52c4fdf4a011df10.zip
comms/hylafax: update to 4.3.3
1. Update to hylafax 4.3.3 2. Enable JBIG send (receive has to wait for an updated graphics/tiff) 3. Add GHOSTSCRIPT dependency 4. Make portlint a little happier 5. Change "cuaa1" to "cuad1" in pkg-message.in (sigh) 6. Add some @dirrmtry lines to pkg-plist upgrade of the comms/hylafax from 4.3.3 to 4.3.4 This is an patch to upgrade Hylafax 4.3.3 to 4.3.4 PR: ports/111786, ports/112667 Submitted by: "Eric P. Scott" <eps+pbug0704@ana.com>, Willem Jaap Zwart<W.J.Zwart@NescioLudens.nl> Approved by: maintainer timeout, maintainer
Diffstat (limited to 'comms/hylafax/Makefile')
-rw-r--r--comms/hylafax/Makefile17
1 files changed, 8 insertions, 9 deletions
diff --git a/comms/hylafax/Makefile b/comms/hylafax/Makefile
index c5b4d70d2444..1b7af1aeaacb 100644
--- a/comms/hylafax/Makefile
+++ b/comms/hylafax/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= hylafax
-PORTVERSION= 4.3.2
+PORTVERSION= 4.3.4
CATEGORIES= comms
MASTER_SITES= ftp://ftp.hylafax.org/source/
@@ -14,20 +14,18 @@ MAINTAINER= W.J.Zwart@NescioLudens.nl
COMMENT= Fax software
BUILD_DEPENDS= ${LOCALBASE}/lib/afm/Courier:${PORTSDIR}/print/afm
-
-# no dependency on ghostscript because we don't know which
-# version the user prefers
LIB_DEPENDS= tiff:${PORTSDIR}/graphics/tiff \
- jpeg:${PORTSDIR}/graphics/jpeg
+ jpeg:${PORTSDIR}/graphics/jpeg \
+ jbig.1:${PORTSDIR}/graphics/jbigkit
-DIST_SUBDIR= hylafax
+USE_GHOSTSCRIPT=yes
CONFIGURE_ARGS= --with-INSTALL="" \
--with-LIBTIFF="-L${LOCALBASE}/lib -ltiff -ljpeg" \
- --with-ZLIB=no --with-LIBZ=-lz --with-ZLIBINC=none \
+ --with-ZLIB=no --with-LIBZ=-lz \
--with-TIFFINC="${LOCALBASE}/include" \
--with-GCOPTS=" " --with-GCXXOPTS=" " \
- --with-REGEX=no --with-LIBREGEX='' --with-REGEXINC=none \
+ --with-REGEX=no --with-LIBREGEX='' --with-REGEXINC=/usr/include \
--with-DIR_HTML="${DOCSDIR}"
SUB_FILES= pkg-message hylafax.sh.sample
@@ -56,7 +54,7 @@ CONFIGURE_ARGS+=--nointeractive
.if defined(WITH_GAWK)
BUILD_DEPENDS+= gawk:${PORTSDIR}/lang/gawk
-RUN_DEPENDS= gawk:${PORTSDIR}/lang/gawk
+RUN_DEPENDS+= gawk:${PORTSDIR}/lang/gawk
CONFIGURE_ARGS+=--with-AWK="${LOCALBASE}/bin/gawk"
.endif
@@ -97,6 +95,7 @@ pre-extract:
post-patch:
${REINPLACE_CMD} \
-e 's,/usr/local,${LOCALBASE},g' \
+ -e 's,-ljbig,-L${LOCALBASE}/lib &,' \
${WRKSRC}/configure
${REINPLACE_CMD} -e 's,-O hfaxd.conf,-O hfaxd.conf-dist,' \
${WRKSRC}/hfaxd/Makefile.in