aboutsummaryrefslogtreecommitdiffstats
path: root/comms/hylafax
diff options
context:
space:
mode:
authorglewis <glewis@FreeBSD.org>2002-08-13 07:16:00 +0800
committerglewis <glewis@FreeBSD.org>2002-08-13 07:16:00 +0800
commitcc8d86b3e383423bd76451b00eb0e1c9d3d32b2b (patch)
treee1dc2accaaea6a994bc953fc720f468da491a4a0 /comms/hylafax
parenta47386a36d95bc12e52fb543460ca374810eaee9 (diff)
downloadfreebsd-ports-gnome-cc8d86b3e383423bd76451b00eb0e1c9d3d32b2b.tar.gz
freebsd-ports-gnome-cc8d86b3e383423bd76451b00eb0e1c9d3d32b2b.tar.zst
freebsd-ports-gnome-cc8d86b3e383423bd76451b00eb0e1c9d3d32b2b.zip
. Remove dependencies on bash, HylaFAX builds and (reportedly) runs
fine with /bin/sh. . Add a knob (PAGESIZE to correspond to the HylaFAX configure variable) so one can choose a paper size other than US Letter. . Use noninteractive configure when building in BATCH mode. The PR also suggests adding an option to install hfaxd setuid so it can be run from inetd. This seems bogus though as inetd.conf allows one to specify the user to start the process as. PR: 31684
Diffstat (limited to 'comms/hylafax')
-rw-r--r--comms/hylafax/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/comms/hylafax/Makefile b/comms/hylafax/Makefile
index 9b6aee5955dd..1e04c0f0f99c 100644
--- a/comms/hylafax/Makefile
+++ b/comms/hylafax/Makefile
@@ -12,11 +12,9 @@ MASTER_SITES= ftp://ftp.hylafax.org/source/
MAINTAINER= ports@FreeBSD.org
-BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash2 \
- ${LOCALBASE}/lib/afm/Courier:${PORTSDIR}/print/afm
+BUILD_DEPENDS= ${LOCALBASE}/lib/afm/Courier:${PORTSDIR}/print/afm
# no dependency on ghostscript because we don't know which
# version the user prefers
-RUN_DEPENDS= bash:${PORTSDIR}/shells/bash2
LIB_DEPENDS= tiff.4:${PORTSDIR}/graphics/tiff \
jpeg.9:${PORTSDIR}/graphics/jpeg
@@ -28,7 +26,11 @@ CONFIGURE_ARGS= --with-INSTALL="" \
--with-TIFFINC="${LOCALBASE}/include" \
--with-GCOPTS=" " --with-GCXXOPTS=" " \
--with-REGEX=no --with-LIBREGEX='' --with-REGEXINC=none
-.ifdef PACKAGE_BUILDING
+# Defaults to "North American Letter". Use "ISO A4" for A4.
+.ifdef PAGESIZE
+CONFIGURE_ARGS+=--with-PAGESIZE="${PAGESIZE}"
+.endif
+.if defined(PACKAGE_BUILDING) || defined(BATCH)
CONFIGURE_ARGS+=--nointeractive
.endif
MAKE_ARGS+= OPTIMIZER="" -EOPTIMIZER