aboutsummaryrefslogtreecommitdiffstats
path: root/comms/ncid
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2015-08-19 21:29:59 +0800
committerMathieu Arnold <mat@FreeBSD.org>2015-08-19 21:29:59 +0800
commitbb271f0bf7b513a23a31da4ec8819b113ebf4587 (patch)
treeac5a462edc3d85d5f0b20a594802ce4b12f0bf9f /comms/ncid
parent29879aded766da253313579a3503ff5e15026355 (diff)
downloadfreebsd-ports-gnome-bb271f0bf7b513a23a31da4ec8819b113ebf4587.tar.gz
freebsd-ports-gnome-bb271f0bf7b513a23a31da4ec8819b113ebf4587.tar.zst
freebsd-ports-gnome-bb271f0bf7b513a23a31da4ec8819b113ebf4587.zip
Convert ports to use the options helpers in categories [abc]*, and minor fixes.
Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D3412?
Diffstat (limited to 'comms/ncid')
-rw-r--r--comms/ncid/Makefile13
1 files changed, 5 insertions, 8 deletions
diff --git a/comms/ncid/Makefile b/comms/ncid/Makefile
index 0090419894c4..27d7b62a4cef 100644
--- a/comms/ncid/Makefile
+++ b/comms/ncid/Makefile
@@ -31,8 +31,6 @@ PORTDOCS= CHANGES CONTRIBUTORS.md Devices.md Documentation.md FAQ.md Gateways.md
NCID-API.odt NCID-SDK.md NCID_Documentation.md README.docdir ReleaseNotes.md \
TODO.md Verbose.md mk-epub ncid-1.jpg
-.include <bsd.port.options.mk>
-
post-extract:
cd ${WRKSRC}/FreeBSD;for i in *.rc; do \
x=`echo $$i | cut -f 1 -d .`; ${CP} $$i $$x; done
@@ -74,15 +72,14 @@ ncid-alert ncid-yac ncid-initmodem ncid-notify ncid-wakeup
ncid-page ncid-samba ncid-speak ncid-yac ncid-initmodem
${INSTALL_DATA} ${WRKSRC}/FreeBSD/${i} ${STAGEDIR}${PREFIX}/etc/rc.d
.endfor
-.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${STAGEDIR}${DOCSDIR}
-.for j in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/doc/${j} ${STAGEDIR}${DOCSDIR}
-.endfor
-.endif
${INSTALL_MAN} ${WRKSRC}/man/*.1 ${STAGEDIR}${MAN1PREFIX}/man/man1
${INSTALL_MAN} ${WRKSRC}/man/*.5 ${STAGEDIR}${MAN5PREFIX}/man/man5
${INSTALL_MAN} ${WRKSRC}/man/*.7 ${STAGEDIR}${MAN7PREFIX}/man/man7
${INSTALL_MAN} ${WRKSRC}/man/*.8 ${STAGEDIR}${MAN8PREFIX}/man/man8
+do-install-DOCS-on:
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+.for j in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/doc/${j} ${STAGEDIR}${DOCSDIR}
+.endfor
.include <bsd.port.mk>