aboutsummaryrefslogtreecommitdiffstats
path: root/comms/openobex/Makefile
diff options
context:
space:
mode:
authormadpilot <madpilot@FreeBSD.org>2013-03-11 05:05:12 +0800
committermadpilot <madpilot@FreeBSD.org>2013-03-11 05:05:12 +0800
commitc20127830433d42c9d599afd41a797f504f5d702 (patch)
tree9e15be5ed018098ffa20b7d667c530d14d420368 /comms/openobex/Makefile
parent283a10ff7581dbc3394c085b25a2195edcb2de64 (diff)
downloadfreebsd-ports-gnome-c20127830433d42c9d599afd41a797f504f5d702.tar.gz
freebsd-ports-gnome-c20127830433d42c9d599afd41a797f504f5d702.tar.zst
freebsd-ports-gnome-c20127830433d42c9d599afd41a797f504f5d702.zip
- Fix plist when DOXYGEN option is enabled but DOCS is not
- Enable DOXYGEN option by default - Bump PORTREVISION Reported/Requested by: makc
Diffstat (limited to 'comms/openobex/Makefile')
-rw-r--r--comms/openobex/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/comms/openobex/Makefile b/comms/openobex/Makefile
index 3ef225194a6f..5143b8480326 100644
--- a/comms/openobex/Makefile
+++ b/comms/openobex/Makefile
@@ -2,6 +2,7 @@
PORTNAME= openobex
PORTVERSION= 1.7
+PORTREVISION= 1
CATEGORIES= comms net
MASTER_SITES= http://www.hendrik-sattler.de/downloads/${PORTNAME}/${PORTVERSION}/
DISTNAME= ${PORTNAME}-${PORTVERSION}-Source
@@ -17,14 +18,16 @@ USE_DOS2UNIX= CMakeLists.txt
CMAKE_ARGS+= -DPKGCONFIG_INSTALL_DIR:STRING="${PREFIX}/libdata/pkgconfig"
OPTIONS_DEFINE= DOXYGEN
+OPTIONS_DEFAULT= DOXYGEN
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MDOXYGEN}
BUILD_DEPENDS+= doxygen:${PORTSDIR}/devel/doxygen
-PORTDOCS= *
+PLIST_SUB+= DOXYGEN=""
.else
CMAKE_ARGS+= -DBUILD_DOCUMENTATION=OFF
+PLIST_SUB+= DOXYGEN="@comment "
.endif
.include <bsd.port.mk>