aboutsummaryrefslogtreecommitdiffstats
path: root/comms/predict/Makefile
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-06-26 05:52:16 +0800
committerpav <pav@FreeBSD.org>2004-06-26 05:52:16 +0800
commit840852507cbf49a6e7028d0b4ff53e4748da0a5e (patch)
treed6e48ca3e4a0bd28170f14f97429dcc5c3d3673f /comms/predict/Makefile
parente508df3eab7988b7754d8735252a26d1dc858979 (diff)
downloadfreebsd-ports-gnome-840852507cbf49a6e7028d0b4ff53e4748da0a5e.tar.gz
freebsd-ports-gnome-840852507cbf49a6e7028d0b4ff53e4748da0a5e.tar.zst
freebsd-ports-gnome-840852507cbf49a6e7028d0b4ff53e4748da0a5e.zip
Add predict, a ncurses application to predict and track positions of amateur
radio satellites. PR: ports/68283 Submitted by: Diane Bruce <db@db.net>
Diffstat (limited to 'comms/predict/Makefile')
-rw-r--r--comms/predict/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/comms/predict/Makefile b/comms/predict/Makefile
new file mode 100644
index 000000000000..71e4e974f2ca
--- /dev/null
+++ b/comms/predict/Makefile
@@ -0,0 +1,26 @@
+# ports collection makefile for: predict
+# Date created: 11 February 2004
+# Whom: db
+#
+# $FreeBSD$
+#
+
+PORTNAME= predict
+PORTVERSION= 2.2.2
+CATEGORIES= comms
+MASTER_SITES= ftp://ftp.amsat.org/amsat/software/Linux/
+
+MAINTAINER= db@db.net
+COMMENT= Satellite tracking program for amateur radio satellites
+
+INSTALL_TARGET= install install.man
+
+MAN1= predict.1
+PLIST_FILES= bin/predict
+MAKE_ENV= LIBS="${PTHREAD_LIBS}"
+
+post-patch:
+ ${SED} -e 's|%%PREFIX%%|${PREFIX}|g' ${FILESDIR}/predict.h > ${WRKSRC}/predict.h
+ ${CP} ${FILESDIR}/Makefile ${WRKSRC}
+
+.include <bsd.port.mk>