aboutsummaryrefslogtreecommitdiffstats
path: root/comms/rxtx
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2014-11-12 07:06:39 +0800
committerantoine <antoine@FreeBSD.org>2014-11-12 07:06:39 +0800
commit7c646ae586ae6e14c551575a626f11582e2f18f4 (patch)
tree9e59da46b06460ba17cedf1091c0bc922f8f1725 /comms/rxtx
parent54e51eaad3317ccf5f08baf8a97cb71dc4efc23f (diff)
downloadfreebsd-ports-gnome-7c646ae586ae6e14c551575a626f11582e2f18f4.tar.gz
freebsd-ports-gnome-7c646ae586ae6e14c551575a626f11582e2f18f4.tar.zst
freebsd-ports-gnome-7c646ae586ae6e14c551575a626f11582e2f18f4.zip
- Don't use a strange prefix
- Strip shared libraries
Diffstat (limited to 'comms/rxtx')
-rw-r--r--comms/rxtx/Makefile11
-rw-r--r--comms/rxtx/pkg-plist10
2 files changed, 10 insertions, 11 deletions
diff --git a/comms/rxtx/Makefile b/comms/rxtx/Makefile
index 8db4dbd310c4..d7ca392700bc 100644
--- a/comms/rxtx/Makefile
+++ b/comms/rxtx/Makefile
@@ -3,7 +3,7 @@
PORTNAME= rxtx
PORTVERSION= 2.2p2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= comms java
MASTER_SITES= http://rxtx.qbang.org/pub/rxtx/ \
ftp://jarvi.dsl.frii.com/pub/rxtx/
@@ -13,17 +13,16 @@ DISTNAME= ${PORTNAME}-${PORTVERSION:S/p/pre/}
MAINTAINER= mirror176@cox.net
COMMENT= Native interface to serial ports in Java
-USES= gmake zip libtool
+USES= gmake libtool zip
USE_JAVA= yes
JAVA_VERSION= 1.6+
JAVA_OS= native
GNU_CONFIGURE= yes
+CONFIGURE_ENV= JAVA_HOME=${JAVA_HOME}
+INSTALL_TARGET= install-strip
USE_LDCONFIG= yes
-CONFIGURE_ENV= JAVA_HOME=${JAVA_HOME}
-PREFIX= ${JAVA_HOME}/jre
-NO_MTREE= yes
-PLIST_SUB= ARCH=${ARCH}
+PLIST_SUB= ARCH=${ARCH} JAVA_HOME=${JAVA_HOME:S,^${PREFIX}/,,}
.include <bsd.port.mk>
diff --git a/comms/rxtx/pkg-plist b/comms/rxtx/pkg-plist
index b77522182748..326db6bf4fb4 100644
--- a/comms/rxtx/pkg-plist
+++ b/comms/rxtx/pkg-plist
@@ -1,5 +1,5 @@
-lib/ext/RXTXcomm.jar
-lib/%%ARCH%%/librxtxParallel.so
-lib/%%ARCH%%/librxtxParallel-2.2pre1.so
-lib/%%ARCH%%/librxtxSerial.so
-lib/%%ARCH%%/librxtxSerial-2.2pre1.so
+%%JAVA_HOME%%/jre/lib/ext/RXTXcomm.jar
+%%JAVA_HOME%%/jre/lib/%%ARCH%%/librxtxParallel.so
+%%JAVA_HOME%%/jre/lib/%%ARCH%%/librxtxParallel-2.2pre1.so
+%%JAVA_HOME%%/jre/lib/%%ARCH%%/librxtxSerial.so
+%%JAVA_HOME%%/jre/lib/%%ARCH%%/librxtxSerial-2.2pre1.so