aboutsummaryrefslogtreecommitdiffstats
path: root/comms/thebridge
diff options
context:
space:
mode:
authordb <db@FreeBSD.org>2013-01-07 22:28:10 +0800
committerdb <db@FreeBSD.org>2013-01-07 22:28:10 +0800
commit585cb8e7334748266d6b7207ca9fe280c98b3efa (patch)
tree8cfa9aa0562026c4aa85ccd694afbba3aafdf0c9 /comms/thebridge
parenta765bc55727a3238e78b44fd8c6ae25140eaefb3 (diff)
downloadfreebsd-ports-gnome-585cb8e7334748266d6b7207ca9fe280c98b3efa.tar.gz
freebsd-ports-gnome-585cb8e7334748266d6b7207ca9fe280c98b3efa.tar.zst
freebsd-ports-gnome-585cb8e7334748266d6b7207ca9fe280c98b3efa.zip
- Update to release 1.09 [1]
- Clean up header - Tidy up make patches - remove bash dependancy PR: ports/174931 [1] Submitted by: takefu@airport.fm
Diffstat (limited to 'comms/thebridge')
-rw-r--r--comms/thebridge/Makefile18
-rw-r--r--comms/thebridge/distinfo4
-rw-r--r--comms/thebridge/files/patch-Makefile.in18
-rw-r--r--comms/thebridge/files/patch-configure19
-rw-r--r--comms/thebridge/files/patch-configure.in9
-rw-r--r--comms/thebridge/files/patch-src_Makefile.in12
-rw-r--r--comms/thebridge/files/patch-src_conference.c11
-rw-r--r--comms/thebridge/files/patch-src_dirclient.c11
8 files changed, 56 insertions, 46 deletions
diff --git a/comms/thebridge/Makefile b/comms/thebridge/Makefile
index 796a201edb6b..98e473ec263d 100644
--- a/comms/thebridge/Makefile
+++ b/comms/thebridge/Makefile
@@ -1,13 +1,9 @@
-# ports collection makefile for: thebridge
-# Date created: 22 June 2004
-# Whom: db
-#
+# Created by: db
# $FreeBSD$
#
PORTNAME= thebridge
-PORTVERSION= 1.06
-PORTREVISION= 1
+PORTVERSION= 1.09
CATEGORIES= comms hamradio
MASTER_SITES= SF/cqinet/${PORTNAME}/${PORTNAME}-${PORTVERSION}
EXTRACT_SUFX= .tgz
@@ -15,23 +11,25 @@ EXTRACT_SUFX= .tgz
MAINTAINER= db@FreeBSD.org
COMMENT= Amateur Radio Echolink conference bridge
-RUN_DEPENDS= bash:${PORTSDIR}/shells/bash
-
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-GNU_CONFIGURE= yes
+GNU_CONFIGURE= yes
PORTDOCS= README
USE_RC_SUBR= tbd
+USE_AUTOTOOLS= autoconf
+CONFIGURE_ENV= AUTOMAKE=/usr/bin/true
MAKE_JOBS_SAFE= yes
+.include <bsd.port.options.mk>
+
post-patch:
@${REINPLACE_CMD} -e 's,%%LOCALBASE%%,${LOCALBASE},; \
s,%%PREFIX%%,${PREFIX},' \
${WRKSRC}/addons/usermgmt.cgi
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
.endif
diff --git a/comms/thebridge/distinfo b/comms/thebridge/distinfo
index 82f41810e731..380f55f5bf70 100644
--- a/comms/thebridge/distinfo
+++ b/comms/thebridge/distinfo
@@ -1,2 +1,2 @@
-SHA256 (thebridge-1.06.tgz) = 401646f336b052555abc776e40e94b3990b7c198f2a9ec65bf45ee45acbab6a2
-SIZE (thebridge-1.06.tgz) = 412875
+SHA256 (thebridge-1.09.tgz) = 0d7b068a78601c89f89cd1d920f2bfe1072ea27b54ed4949ee3278933a209334
+SIZE (thebridge-1.09.tgz) = 440359
diff --git a/comms/thebridge/files/patch-Makefile.in b/comms/thebridge/files/patch-Makefile.in
index 14ebf6a8f1b1..2f8eb846a4f0 100644
--- a/comms/thebridge/files/patch-Makefile.in
+++ b/comms/thebridge/files/patch-Makefile.in
@@ -1,11 +1,11 @@
---- Makefile.in.orig 2008-03-06 23:42:41.000000000 +0900
-+++ Makefile.in 2008-03-21 11:53:08.000000000 +0900
-@@ -201,7 +201,7 @@
- sharedstatedir = @sharedstatedir@
- sysconfdir = @sysconfdir@
- target_alias = @target_alias@
+--- Makefile.in.orig 2012-12-10 01:05:20.000000000 -0500
++++ Makefile.in 2013-01-03 20:39:17.000000000 -0500
+@@ -253,7 +253,7 @@
+ top_build_prefix = @top_build_prefix@
+ top_builddir = @top_builddir@
+ top_srcdir = @top_srcdir@
-SUBDIRS = common zlib src inc tbdcmd addons
+SUBDIRS = common src inc tbdcmd addons
- EXTRA_DIST = theBridge.dsp tbd.conf.sample README.txt FreeBSD RedHat SCRIPTING.txt
- sysconf_DATA = tbd.conf.sample
- all: config.h
+ EXTRA_DIST = theBridge.dsp tbd.conf.sample README.txt FreeBSD RedHat \
+ SCRIPTING.txt Debian
+
diff --git a/comms/thebridge/files/patch-configure b/comms/thebridge/files/patch-configure
deleted file mode 100644
index 1e893e365185..000000000000
--- a/comms/thebridge/files/patch-configure
+++ /dev/null
@@ -1,19 +0,0 @@
---- configure.orig 2008-03-06 23:42:42.000000000 +0900
-+++ configure 2008-03-21 11:54:15.000000000 +0900
-@@ -4886,7 +4886,7 @@
- _ACEOF
-
-
-- ac_config_files="$ac_config_files Makefile src/Makefile common/Makefile inc/Makefile tbdcmd/Makefile zlib/Makefile addons/Makefile"
-+ ac_config_files="$ac_config_files Makefile src/Makefile common/Makefile inc/Makefile tbdcmd/Makefile addons/Makefile"
- cat >confcache <<\_ACEOF
- # This file is a shell script that caches the results of configure
- # tests run on this system so they can be shared between configure
-@@ -5469,7 +5469,6 @@
- "common/Makefile" ) CONFIG_FILES="$CONFIG_FILES common/Makefile" ;;
- "inc/Makefile" ) CONFIG_FILES="$CONFIG_FILES inc/Makefile" ;;
- "tbdcmd/Makefile" ) CONFIG_FILES="$CONFIG_FILES tbdcmd/Makefile" ;;
-- "zlib/Makefile" ) CONFIG_FILES="$CONFIG_FILES zlib/Makefile" ;;
- "addons/Makefile" ) CONFIG_FILES="$CONFIG_FILES addons/Makefile" ;;
- "depfiles" ) CONFIG_COMMANDS="$CONFIG_COMMANDS depfiles" ;;
- "config.h" ) CONFIG_HEADERS="$CONFIG_HEADERS config.h" ;;
diff --git a/comms/thebridge/files/patch-configure.in b/comms/thebridge/files/patch-configure.in
new file mode 100644
index 000000000000..b3a017bec393
--- /dev/null
+++ b/comms/thebridge/files/patch-configure.in
@@ -0,0 +1,9 @@
+--- configure.in.orig 2013-01-03 19:17:41.000000000 -0500
++++ configure.in 2013-01-03 19:18:21.000000000 -0500
+@@ -84,5 +84,5 @@
+ [Set to a text string describing your operating system and hardware])
+
+ AC_OUTPUT(Makefile src/Makefile common/Makefile inc/Makefile tbdcmd/Makefile
+-zlib/Makefile addons/Makefile)
++ addons/Makefile)
+
diff --git a/comms/thebridge/files/patch-src_Makefile.in b/comms/thebridge/files/patch-src_Makefile.in
index d0724f483d01..709b47e50969 100644
--- a/comms/thebridge/files/patch-src_Makefile.in
+++ b/comms/thebridge/files/patch-src_Makefile.in
@@ -1,15 +1,15 @@
---- src/Makefile.in.orig 2008-09-15 02:08:08.000000000 +0900
-+++ src/Makefile.in 2008-11-05 20:19:18.000000000 +0900
-@@ -117,7 +117,7 @@
+--- src/Makefile.in.orig 2012-12-10 01:00:44.000000000 -0500
++++ src/Makefile.in 2013-01-03 18:54:09.000000000 -0500
+@@ -115,7 +115,7 @@
tbd_OBJECTS = $(am_tbd_OBJECTS)
am__DEPENDENCIES_1 =
@LINK_BOX_FALSE@tbd_DEPENDENCIES = $(top_builddir)/common/libcommon.a \
-@LINK_BOX_FALSE@ $(top_builddir)/zlib/libzlib.a \
+@LINK_BOX_FALSE@ -lz -lm \
@LINK_BOX_FALSE@ $(am__DEPENDENCIES_1)
- DEFAULT_INCLUDES = -I. -I$(srcdir) -I$(top_builddir)
+ DEFAULT_INCLUDES = -I.@am__isrc@ -I$(top_builddir)
depcomp = $(SHELL) $(top_srcdir)/config/depcomp
-@@ -226,12 +226,12 @@
+@@ -233,12 +233,12 @@
@LINK_BOX_TRUE@ dirclient.c dirclient.h thebridge.c users.c users.h \
@LINK_BOX_TRUE@ hostfile.c hostfile.h eventhook.c eventhook.h avrs.c avrs.h
@@ -24,7 +24,7 @@
@LINK_BOX_TRUE@ -DSYSCON_DIR=\"$(sysconfdir)\" $(am__append_1)
@LINK_BOX_FALSE@AM_CFLAGS = -Wall $(am__append_2)
@LINK_BOX_TRUE@AM_CFLAGS = -Wall $(am__append_2)
-@@ -239,7 +239,7 @@
+@@ -246,7 +246,7 @@
@LINK_BOX_FALSE@ dirclient.h thebridge.c users.c users.h hostfile.c hostfile.h \
@LINK_BOX_FALSE@ eventhook.c eventhook.h avrs.c avrs.h
diff --git a/comms/thebridge/files/patch-src_conference.c b/comms/thebridge/files/patch-src_conference.c
new file mode 100644
index 000000000000..d15b1de8547a
--- /dev/null
+++ b/comms/thebridge/files/patch-src_conference.c
@@ -0,0 +1,11 @@
+--- src/conference.c.orig 2013-01-03 21:44:25.000000000 -0500
++++ src/conference.c 2013-01-03 21:44:51.000000000 -0500
+@@ -784,7 +784,7 @@
+ #include "ilink.h"
+ #include "sf.h"
+ #include "hostfile.h"
+-#include "zlib.h"
++#include <zlib.h>
+ #include "tbd.h"
+
+ #if defined _WIN32GUI || defined _X11GUI
diff --git a/comms/thebridge/files/patch-src_dirclient.c b/comms/thebridge/files/patch-src_dirclient.c
new file mode 100644
index 000000000000..498eacac385a
--- /dev/null
+++ b/comms/thebridge/files/patch-src_dirclient.c
@@ -0,0 +1,11 @@
+--- src/dirclient.c.orig 2013-01-03 21:44:33.000000000 -0500
++++ src/dirclient.c 2013-01-03 21:45:03.000000000 -0500
+@@ -222,7 +222,7 @@
+ #include "dirclient.h"
+ #include "hostfile.h"
+ #include "eventhook.h"
+-#include "zlib.h"
++#include <zlib.h>
+ #include "sf.h"
+
+ #ifdef USE_DMALLOC