aboutsummaryrefslogtreecommitdiffstats
path: root/comms/wspr
diff options
context:
space:
mode:
authordb <db@FreeBSD.org>2015-07-28 00:37:12 +0800
committerdb <db@FreeBSD.org>2015-07-28 00:37:12 +0800
commit9ac586a6edb6c290c17a35c7f3bc8c8d0b99458a (patch)
treeb08be2a7f513f7896f4a3d52fa09a4565f29d0e0 /comms/wspr
parent997a7e168155b11610eb7cf8ad765ed2259d33b6 (diff)
downloadfreebsd-ports-gnome-9ac586a6edb6c290c17a35c7f3bc8c8d0b99458a.tar.gz
freebsd-ports-gnome-9ac586a6edb6c290c17a35c7f3bc8c8d0b99458a.tar.zst
freebsd-ports-gnome-9ac586a6edb6c290c17a35c7f3bc8c8d0b99458a.zip
Unbreak build
Portaudio cleanups remove obsolete USE_AUTOTOOLS= autoconf
Diffstat (limited to 'comms/wspr')
-rw-r--r--comms/wspr/Makefile7
-rw-r--r--comms/wspr/files/patch-Makefile.in45
-rw-r--r--comms/wspr/files/patch-WsprMode_specjt.py24
-rw-r--r--comms/wspr/files/patch-configure.ac44
-rw-r--r--comms/wspr/files/patch-wspr.py6
5 files changed, 61 insertions, 65 deletions
diff --git a/comms/wspr/Makefile b/comms/wspr/Makefile
index f42349cbfc9e..26a1e8af2515 100644
--- a/comms/wspr/Makefile
+++ b/comms/wspr/Makefile
@@ -2,7 +2,7 @@
PORTNAME= wspr
DISTVERSION= ${VERSION}.r${SVN_REV}
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= comms hamradio
MASTER_SITES= LOCAL/db
DISTNAME= wspr-r${SVN_REV}
@@ -21,9 +21,8 @@ LIB_DEPENDS= libhamlib.so:${PORTSDIR}/comms/hamlib \
libsamplerate.so:${PORTSDIR}/audio/libsamplerate \
libportaudio.so:${PORTSDIR}/audio/portaudio
-MAKE_JOBS_UNSAFE= yes
-USE_AUTOTOOLS= autoconf
-USES= fortran gmake libtool tar:bzip2 python:3.3 dos2unix
+DISABLE_MAKE_JOBS= yes
+USES= autoreconf dos2unix fortran gmake libtool python:3.3 tar:bzip2
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-gfortran=${FC} \
--with-f2py=f2py-${PYTHON_VER} \
diff --git a/comms/wspr/files/patch-Makefile.in b/comms/wspr/files/patch-Makefile.in
index 7f48f9175caa..ee7bd319d8ae 100644
--- a/comms/wspr/files/patch-Makefile.in
+++ b/comms/wspr/files/patch-Makefile.in
@@ -1,41 +1,42 @@
---- Makefile.in.orig 2014-06-20 18:58:03.000000000 -0400
-+++ Makefile.in 2014-07-24 16:14:06.000000000 -0400
-@@ -25,7 +25,7 @@
+--- Makefile.in.orig 2015-07-27 16:22:02 UTC
++++ Makefile.in
+@@ -25,7 +25,8 @@ SHELL := @SHELL@
MKDIR := @MKDIR@
# Install locations
-INATALL := install
+INSTALL := install
++PREFIX := @PREFIX@
BINDIR := @BINDIR@
DOCDIR := @DOCDIR@
HOMEDIR := @HOMEDIR@
-@@ -50,6 +50,8 @@
+@@ -45,7 +46,7 @@ F2PY := @F2PY@
+
+ # Libs and Flags
+ LIBS := @LIBS@
+-CPPFLAGS += ${DEFS}
++CPPFLAGS := @CPPFLAGS@
+ LDFLAGS += @LDFLAGS@
CFLAGS += @CFLAGS@
FFLAGS += @FFLAGS@
- FCOPT += @FCOPT@
-+PORTAUDIO_INCLUDE = @PORTAUDIO_INCLUDE@
-+PORTAUDIO_LIBDIR = @PORTAUDIO_LIBDIR@
-
- # Config Definitions
- DEFS := @DEFS@
-@@ -71,24 +73,24 @@
+@@ -71,24 +72,24 @@ all: libwspr.a thnix.o WsprMod/w.so fmte
# Default Rules
%.o: %.c
- ${CC} ${CPPFLAGS} ${CFLAGS} -c $<
-+ ${CC} ${PORTAUDIO_INCLUDE} ${CFLAGS} ${CPPFLAGS} -c $<
++ ${CC} ${CFLAGS} ${CPPFLAGS} ${DEFS} -c $<
%.o: %.f
- ${FC} ${FFLAGS} -c $<
-+ ${FC} ${PORTAUDIO_INCLUDE} ${CFLAGS} ${FFLAGS} -c $<
++ ${FC} ${DEFS} ${CFLAGS} ${FFLAGS} -c $<
%.o: %.F
- ${FC} ${FFLAGS} -c $<
-+ ${FC} ${PORTAUDIO_INCLUDE} ${CFLAGS} ${FFLAGS} -c $<
++ ${FC} ${DEFS} ${CFLAGS} ${FFLAGS} -c $<
%.o: %.f90
- ${FC} ${FFLAGS} -c $<
-+ ${FC} ${PORTAUDIO_INCLUDE} ${CFLAGS} ${FFLAGS} -c $<
++ ${FC} ${DEFS} ${CFLAGS} ${FFLAGS} -c $<
%.o: %.F90
- ${FC} ${FFLAGS} -c $<
-+ ${FC} ${PORTAUDIO_INCLUDE} ${CFLAGS} ${FFLAGS} -c $<
++ ${FC} ${DEFS} ${CFLAGS} ${FFLAGS} -c $<
# Objects
OBJS1 = wspr0.o wspr0init.o wspr0_rx.o wspr0_tx.o thnix_stub.o
@@ -50,7 +51,7 @@
OBJS3 = azdist.o ccf2.o chklevel.o db.o decode.o decode162.o deg2grid.o \
encode232.o fano232.o fchisq.o fil1.o flat3.o four2a.o\
-@@ -105,21 +107,22 @@
+@@ -105,21 +106,22 @@ OBJS3 = azdist.o ccf2.o chklevel.o db.o
# Build Library: libwspr.a
libwspr.a: ${OBJS3} acom1.f90 acom2.f90
@@ -78,7 +79,7 @@
# SRC for w.so
F2PYSRCS = wspr1.f90 getfile.f90 paterminate.f90 audiodev.f90
-@@ -127,7 +130,7 @@
+@@ -127,30 +129,34 @@ F2PYSRCS = wspr1.f90 getfile.f90 patermi
# Build W.SO & MV to WsprMod/
WsprMod/w.so: libwspr.a ${F2PYSRCS} acom1.f90
${F2PY} -c --quiet --fcompiler=${FCV} --f77exec=${FC} --f90exec=${FC} \
@@ -87,7 +88,11 @@
${MV} w*.so WsprMod/w.so
# Install target wspr
-@@ -137,20 +140,23 @@
+ install:
+- @clear
++# tput has no TERM under automated install
++# @clear
+ @echo '-----------------------------------'
@echo " Installing ${PROGRAM}"
@echo '-----------------------------------'
@echo ''
@@ -108,7 +113,7 @@
+ @${MKDIR} -p ${DESTDIR}${DOCDIR}/examples
+ @${MKDIR} -p ${DESTDIR}${SHARED}/save/Samples
+ @${MKDIR} -p ${DESTDIR}${WSPRLIB}/WsprMod
-+ @install -m 555 fmtest fcal fmeasure fmtave wspr0 wsprcode ${DESTDIR}${BINDIR}
++ @install -m 655 fmtest fcal fmeasure fmtave wspr0 wsprcode ${DESTDIR}${BINDIR}
+ @strip ${DESTDIR}${BINDIR}/fmtest ${DESTDIR}${BINDIR}/fcal \
+ ${DESTDIR}${BINDIR}/fmeasure ${DESTDIR}${BINDIR}/fmtave \
+ ${DESTDIR}${BINDIR}/wspr0 ${DESTDIR}${BINDIR}/wsprcode
diff --git a/comms/wspr/files/patch-WsprMode_specjt.py b/comms/wspr/files/patch-WsprMode_specjt.py
deleted file mode 100644
index bc7650c29904..000000000000
--- a/comms/wspr/files/patch-WsprMode_specjt.py
+++ /dev/null
@@ -1,24 +0,0 @@
---- WsprMod/specjt.py.orig 2014-12-15 21:51:30.000000000 -0500
-+++ WsprMod/specjt.py 2014-12-15 21:54:38.000000000 -0500
-@@ -34,10 +34,8 @@
- import tkinter.messagebox
- from . import w
-
--try:
-- from numpy.oldnumeric import zeros, multiarray
--except:
-- from Numeric import zeros, multiarray
-+from numpy import zeros
-+from numpy.core import multiarray
- import Image, ImageTk, ImageDraw
- from .palettes import colormapblue, colormapgray0, colormapHot, \
- colormapAFMHot, colormapgray1, colormapLinrad, Colormap2Palette
-@@ -94,7 +92,7 @@
- ttot=0.0
-
- c=Canvas()
--a=zeros(225000,'s')
-+##a=zeros(225000,'s')
- im=Image.new('P',(750,300))
- line0=Image.new('P',(750,1)) #Image fragment for top line of waterfall
- draw=ImageDraw.Draw(im)
diff --git a/comms/wspr/files/patch-configure.ac b/comms/wspr/files/patch-configure.ac
index 30083fff3d46..2378e1096adb 100644
--- a/comms/wspr/files/patch-configure.ac
+++ b/comms/wspr/files/patch-configure.ac
@@ -1,6 +1,6 @@
---- configure.ac.orig 2014-06-04 15:38:13.000000000 -0400
-+++ configure.ac 2014-09-26 15:03:51.000000000 -0400
-@@ -10,18 +10,33 @@
+--- configure.ac.orig 2015-07-27 16:22:02 UTC
++++ configure.ac
+@@ -10,18 +10,33 @@ dnl ------------------------------------
dnl path vars
dnl ----------------------------------------------------------------------------
@@ -40,7 +40,7 @@
dnl ----------------------------------------------------------------------------
dnl check compilers
-@@ -59,9 +74,17 @@
+@@ -59,9 +74,17 @@ AC_PATH_PROG([TR], [tr])
AC_SUBST([OS], ["$host_os"])
AC_SUBST([CPU], ["$host_cpu"])
@@ -60,7 +60,7 @@
AC_HEADER_STDC
AC_HEADER_DIRENT
AC_HEADER_TIME
-@@ -88,36 +111,36 @@
+@@ -88,36 +111,36 @@ dnl ------------------------------------
dnl add additional lib paths
dnl ----------------------------------------------------------------------------
if test -d "/usr/lib64"; then LDFLAGS="-L/usr/lib64 ${LDFLAGS}"; fi
@@ -108,7 +108,7 @@
AC_DEFINE([HAVE_PY3], [1])
AC_DEFINE_UNQUOTED([PY3_PATH], ["${PY3}"], [Path to Python3])
AC_SUBST([PYTHON], ["${PY3}"])
-@@ -128,6 +151,7 @@
+@@ -128,6 +151,7 @@ else
fi
# if not user supplied, check by calling python
@@ -116,7 +116,7 @@
if test "$HAVE_PY3" = "no"; then
AC_MSG_CHECKING([Python3 using: python])
-@@ -172,7 +196,7 @@
+@@ -172,7 +196,7 @@ dnl ------------------------------------
HAVE_F2PY=no
@@ -125,7 +125,7 @@
AC_MSG_CHECKING([F2PY --with-f2py])
AC_ARG_WITH([f2py], [ --with-f2py=PATH path to: ../f2py ../f2py3],
F2PY="$withval")
-@@ -244,13 +268,23 @@
+@@ -244,13 +268,23 @@ dnl ------------------------------------
dnl check gfortran
dnl ----------------------------------------------------------------------------
@@ -150,7 +150,23 @@
FCV=gnu95
FC_LIB_PATH=`${FC} -print-file-name=`
AC_DEFINE_UNQUOTED([FC_LIB_PATH], ["${FC_LIB_PATH}"], [Path to Gfortran libs.])
-@@ -279,7 +328,6 @@
+@@ -266,12 +300,14 @@ fi
+ dnl ----------------------------------------------------------------------------
+ dnl check portaudio
+ dnl ----------------------------------------------------------------------------
++#
+
+ AC_CHECK_LIB([portaudio], [Pa_Initialize], [], [])
+ if test "$ac_cv_lib_portaudio_Pa_Initialize" = "yes"; then
+- LIBS="-lportaudio ${LIBS}"
++ LIBS="-lportaudio ${LIBS}"
+ fi
+
++
+ # if headers and libs found, set define
+ if test "$ac_cv_header_portaudio_h" = "yes" -a "$ac_cv_lib_portaudio_Pa_Initialize" = "yes"; then
+ HAVE_PORTAUDIO=1
+@@ -279,7 +315,6 @@ if test "$ac_cv_header_portaudio_h" = "y
AC_DEFINE([HAVE_PORTAUDIO_LIB], [1], [Portaudio Lib])
fi
@@ -158,7 +174,7 @@
dnl ----------------------------------------------------------------------------
dnl check fftw3
dnl ----------------------------------------------------------------------------
-@@ -322,8 +370,10 @@
+@@ -322,8 +357,10 @@ dnl ------------------------------------
_LBU=$(echo "-lpthread $LIBS" |tr ' ' '\n'|sort -su |tr '\n' ' ')
LIBS="$_LBU"
@@ -171,7 +187,7 @@
_CPPU=$(echo "-I/usr/include -I/usr/local/include $CPPFLAGS" |tr ' ' '\n'|sort -su |tr '\n' ' ')
CPPFLAGS="$_CPPU"
-@@ -355,6 +405,10 @@
+@@ -355,6 +392,10 @@ case "${host_os}" in
FFLAGS="-O2 -m64 -Wall -fbounds-check -fno-second-underscore \
-Wno-conversion -Wno-character-truncation -fPIC"
;;
@@ -182,7 +198,7 @@
*)
AC_MSG_ERROR([Unsupported System: ${host_os}.])
;;
-@@ -377,10 +431,6 @@
+@@ -377,10 +418,6 @@ if test "$HAVE_PY3" = "no"; then
echo
echo 'Example:'
echo './configure --with-python3="/home/$USER/test/python3"'
@@ -193,7 +209,7 @@
fi
-@@ -502,7 +552,7 @@
+@@ -502,7 +539,7 @@ AC_SUBST([PREFIX], ["$prefix"])
AC_SUBST([PROGRAM], ["$PACKAGE_NAME"])
AC_SUBST([VERSION], ["$PACKAGE_VERSION"])
AC_SUBST([WEB], ["$PACKAGE_URL"])
@@ -202,7 +218,7 @@
AC_OUTPUT
-@@ -523,7 +573,7 @@
+@@ -523,7 +560,7 @@ fi
echo " Package: .........: ${PROGRAM} ${VERSION}"
echo " Python3: .........: ${PYTHON}"
echo " F2py: ............: ${F2PY}"
diff --git a/comms/wspr/files/patch-wspr.py b/comms/wspr/files/patch-wspr.py
index 1932d28ad5b2..e29b0856d8e0 100644
--- a/comms/wspr/files/patch-wspr.py
+++ b/comms/wspr/files/patch-wspr.py
@@ -1,6 +1,6 @@
---- wspr.py.orig 2014-12-14 19:16:10.079628932 -0500
-+++ wspr.py 2014-12-14 19:16:18.894628427 -0500
-@@ -50,7 +50,7 @@
+--- wspr.py.orig 2015-07-27 16:22:02 UTC
++++ wspr.py
+@@ -50,7 +50,7 @@ from WsprMod import g
import Pmw
from WsprMod import palettes
from math import log10