aboutsummaryrefslogtreecommitdiffstats
path: root/comms/yaps
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2013-11-18 08:37:15 +0800
committervanilla <vanilla@FreeBSD.org>2013-11-18 08:37:15 +0800
commit1982721df575ee1f38014d6c5416a3b73e0e17e9 (patch)
tree2b38c4ddded75d6142be0d45209292474f0596a8 /comms/yaps
parent4b45646c34d33875b29bb5e5a9b4ad4625f7049d (diff)
downloadfreebsd-ports-gnome-1982721df575ee1f38014d6c5416a3b73e0e17e9.tar.gz
freebsd-ports-gnome-1982721df575ee1f38014d6c5416a3b73e0e17e9.tar.zst
freebsd-ports-gnome-1982721df575ee1f38014d6c5416a3b73e0e17e9.zip
Support STAGEDIR.
Diffstat (limited to 'comms/yaps')
-rw-r--r--comms/yaps/Makefile18
-rw-r--r--comms/yaps/files/patch-Makefile21
-rw-r--r--comms/yaps/pkg-plist6
3 files changed, 31 insertions, 14 deletions
diff --git a/comms/yaps/Makefile b/comms/yaps/Makefile
index 34d08381427f..7944c8e07dfc 100644
--- a/comms/yaps/Makefile
+++ b/comms/yaps/Makefile
@@ -15,22 +15,12 @@ LICENSE= GPLv2
USES= gmake
-MAN1= yaps.1
-PLIST_FILES= bin/yaps etc/yaps.rc.sample
-PORTDOCS= yaps.doc yaps.html
-PORTDATA= *
-
OPTIONS_DEFINE= DOCS
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
post-install:
- ${INSTALL_DATA} ${WRKSRC}/yaps.rc ${PREFIX}/etc/yaps.rc.sample
- ${INSTALL_MAN} ${WRKSRC}/yaps.1 ${PREFIX}/man/man1
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/yaps.doc ${WRKSRC}/yaps.html ${DOCSDIR}
-.endif
+ ${INSTALL_DATA} ${WRKSRC}/yaps.rc ${STAGEDIR}${PREFIX}/etc/yaps.rc.sample
+ ${INSTALL_MAN} ${WRKSRC}/yaps.1 ${STAGEDIR}${PREFIX}/man/man1
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/yaps.doc ${WRKSRC}/yaps.html ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/comms/yaps/files/patch-Makefile b/comms/yaps/files/patch-Makefile
new file mode 100644
index 000000000000..58eb808e59ec
--- /dev/null
+++ b/comms/yaps/files/patch-Makefile
@@ -0,0 +1,21 @@
+--- Makefile.orig 2013-11-17 23:01:50.000000000 +0800
++++ Makefile 2013-11-17 23:04:00.000000000 +0800
+@@ -33,15 +33,15 @@ yaps.doc: yaps.html
+ lynx -cfg=/dev/null -nolist -dump $< > $@
+
+ install: $(DSTFLE) $(CFGFILE)
+- if [ ! -d $(YAPS_LIBDIR) ]; then \
+- install -d -m 755 -o $(YAPS_USER) -g $(YAPS_GROUP) $(YAPS_LIBDIR) ; \
++ if [ ! -d $(DESTDIR)$(YAPS_LIBDIR) ]; then \
++ install -d -m 755 -o $(YAPS_USER) -g $(YAPS_GROUP) $(DESTDIR)$(YAPS_LIBDIR) ; \
+ fi
+ @if [ -f contrib/Makefile ]; then \
+ $(MAKE) -C contrib install ; \
+ fi
+
+ $(DSTFLE): yaps
+- install -o $(YAPS_USER) -g $(YAPS_GROUP) -m $(YAPS_MODE) -s yaps $@
++ install -o $(YAPS_USER) -g $(YAPS_GROUP) -m $(YAPS_MODE) -s yaps $(DESTDIR)$@
+
+ $(CFGFILE): yaps.rc
+ @if [ ! -f $@ ]; then \
diff --git a/comms/yaps/pkg-plist b/comms/yaps/pkg-plist
new file mode 100644
index 000000000000..535d0b5fee38
--- /dev/null
+++ b/comms/yaps/pkg-plist
@@ -0,0 +1,6 @@
+bin/yaps
+etc/yaps.rc.sample
+man/man1/yaps.1.gz
+%%PORTDOCS%%%%DOCSDIR%%/yaps.doc
+%%PORTDOCS%%%%DOCSDIR%%/yaps.html
+%%PORTDOCS%%@dirrm %%DOCSDIR%%