aboutsummaryrefslogtreecommitdiffstats
path: root/comms
diff options
context:
space:
mode:
authorDiane Bruce <db@FreeBSD.org>2015-03-11 21:58:34 +0800
committerDiane Bruce <db@FreeBSD.org>2015-03-11 21:58:34 +0800
commit0d4a5f69401ff52e57531487fd1f1a6e8910e68b (patch)
tree31a6af2fab9ab65e6ddbb50d1b04beec253cc822 /comms
parentd209b7fbe2e644b03d6a703c4076414229c6fed4 (diff)
downloadfreebsd-ports-gnome-0d4a5f69401ff52e57531487fd1f1a6e8910e68b.tar.gz
freebsd-ports-gnome-0d4a5f69401ff52e57531487fd1f1a6e8910e68b.tar.zst
freebsd-ports-gnome-0d4a5f69401ff52e57531487fd1f1a6e8910e68b.zip
Finally unbreak the build by preloading GCC_DEFAULT libs paths.
It is complicated by the intermix of gcc and gfortran libs being intermixed with system libs. Especially by dynamically loaded modules into python being linked against gfortran or current gcc. I realise using GCC_DEFAULT lib paths is not a general solution.
Diffstat (limited to 'comms')
-rw-r--r--comms/gnuradio/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/comms/gnuradio/Makefile b/comms/gnuradio/Makefile
index fe6c9e0286c5..4521b2eb15cc 100644
--- a/comms/gnuradio/Makefile
+++ b/comms/gnuradio/Makefile
@@ -38,6 +38,7 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
USES= iconv cmake:outsource perl5 python:2.7 shebangfix
SHEBANG_FILES= grc/freedesktop/grc_setup_freedesktop.in
+CMAKE_ENV+= LD_PRELOAD="${GCC_LIBS}/libstdc++.so:${GCC_LIBS}/libgcc_s.so.1"
CMAKE_ARGS+= -DSWIG_EXECUTABLE:STRING="${LOCALBASE}/bin/swig2.0"
CMAKE_ARGS+= -DICONV_PREFIX:STRING="${ICONV_PREFIX}" \
-DICONV_LIB:STRING="X${ICONV_LIB}" \
@@ -62,6 +63,8 @@ USRP_DESC= Include USRP support (UHD) from Ettus
TESTING_DESC= Include testing support
PLIST_SUB+= PORTVERSION=${PORTVERSION}
+VP= ${GCC_DEFAULT:S/.//}
+GCC_LIBS= ${LOCALBASE}/lib/gcc${VP}
.include <bsd.port.pre.mk>