aboutsummaryrefslogtreecommitdiffstats
path: root/comms
diff options
context:
space:
mode:
authortcberner <tcberner@FreeBSD.org>2018-06-29 01:39:53 +0800
committertcberner <tcberner@FreeBSD.org>2018-06-29 01:39:53 +0800
commit2a8bcfc8ea71d4438b926a8adc477de360863145 (patch)
tree7b9785f1f0c244da1f5b69a2a610e3f37eb786a8 /comms
parent62341874a942de5989d54a3ba471cb8719d251ee (diff)
downloadfreebsd-ports-gnome-2a8bcfc8ea71d4438b926a8adc477de360863145.tar.gz
freebsd-ports-gnome-2a8bcfc8ea71d4438b926a8adc477de360863145.tar.zst
freebsd-ports-gnome-2a8bcfc8ea71d4438b926a8adc477de360863145.zip
Replace bsd.qt.mk by Uses/qt.mk and Uses/qt-dist.mk
From now on, ports that depend on Qt4 will have to set USES= qt:4 USE_QT= foo bar ports depending on Qt5 will use USES= qt:5 USE_QT= foo bar PR: 229225 Exp-run by: antoine Reviewed by: mat Approved by: portmgr (antoine) Differential Revision: →https://reviews.freebsd.org/D15540
Diffstat (limited to 'comms')
-rw-r--r--comms/cutecom/Makefile5
-rw-r--r--comms/dabstick-radio/Makefile4
-rw-r--r--comms/gnuradio/Makefile4
-rw-r--r--comms/gqrx/Makefile5
-rw-r--r--comms/hamfax/Makefile4
-rw-r--r--comms/inspectrum/Makefile4
-rw-r--r--comms/klog/Makefile4
-rw-r--r--comms/kremotecontrol-kde4/Makefile4
-rw-r--r--comms/libsdr-gui/Makefile4
-rw-r--r--comms/linpsk/Makefile4
-rw-r--r--comms/py-qt5-serialport/Makefile4
-rw-r--r--comms/qsstv/Makefile4
-rw-r--r--comms/qt5-connectivity/Makefile5
-rw-r--r--comms/qt5-sensors/Makefile5
-rw-r--r--comms/qt5-serialbus/Makefile5
-rw-r--r--comms/qt5-serialport/Makefile5
-rw-r--r--comms/qtel/Makefile3
-rw-r--r--comms/sdr-wspr/Makefile4
-rw-r--r--comms/svxlink/Makefile2
-rw-r--r--comms/wsjtx/Makefile6
-rw-r--r--comms/xcwcp/Makefile4
21 files changed, 44 insertions, 45 deletions
diff --git a/comms/cutecom/Makefile b/comms/cutecom/Makefile
index 15bf6964fcc8..0355408ee8eb 100644
--- a/comms/cutecom/Makefile
+++ b/comms/cutecom/Makefile
@@ -14,8 +14,9 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= lsz:comms/lrzsz
-USES= cmake
-USE_QT5= buildtools_build core gui qmake_build serialport widgets
+USE_QT= qt3support qmake_build moc_build rcc_build uic_build
+USES= cmake qt:5
+USE_QT= buildtools_build core gui qmake_build serialport widgets
USE_GITHUB= yes
GH_ACCOUNT= neundorf
GH_PROJECT= CuteCom
diff --git a/comms/dabstick-radio/Makefile b/comms/dabstick-radio/Makefile
index 537fff380976..6e5503578586 100644
--- a/comms/dabstick-radio/Makefile
+++ b/comms/dabstick-radio/Makefile
@@ -21,8 +21,8 @@ LIB_DEPENDS+= librtlsdr.so:comms/rtl-sdr \
libfftw3.so:math/fftw3 \
libfaad.so:audio/faad
-USES= tar:tgz
-USE_QT4= gui qt3support qmake_build moc_build rcc_build uic_build
+USES= qt:4 tar:tgz
+USE_QT= gui qt3support qmake_build moc_build rcc_build uic_build
PORTDOCS= *
PLIST_FILES+= bin/dabreceiver bin/fmreceiver bin/spectrum-viewer
diff --git a/comms/gnuradio/Makefile b/comms/gnuradio/Makefile
index 53583e2ad351..67e97329a43e 100644
--- a/comms/gnuradio/Makefile
+++ b/comms/gnuradio/Makefile
@@ -48,7 +48,7 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
# volk/lib/volk_cpu.c: In function 'i_can_has_3dnow':
# volk/lib/volk_cpu.c:62: error: can't find a register in class 'BREG' while reloading 'asm'
# volk/lib/volk_cpu.c:62: error: 'asm' operand has impossible constraints
-USES= cmake:outsource compiler:c11 fortran iconv perl5 pkgconfig pyqt:4 python:2.7 shebangfix
+USES= cmake:outsource compiler:c11 fortran iconv perl5 pkgconfig pyqt:4 python:2.7 qt:4 shebangfix
SHEBANG_FILES= grc/scripts/freedesktop/grc_setup_freedesktop.in \
gnuradio-runtime/python/gnuradio/ctrlport/gr-ctrlport-monitor \
gnuradio-runtime/python/gnuradio/ctrlport/gr-perf-monitorx
@@ -67,7 +67,7 @@ DOCSDIR= share/doc/${PORTNAME}-${PORTVERSION}
USE_GNOME= pygtk2
USE_PYQT= core gui opengl
USE_WX= 3.0+
-USE_QT4= corelib gui xml qmake moc_build rcc_build uic_build
+USE_QT= corelib gui xml qmake moc_build rcc_build uic_build
WX_COMPS= wx wx:build wx:run python:build python:run
USE_LDCONFIG= yes
PLIST_SUB+= MAJOR_VERSION="3"
diff --git a/comms/gqrx/Makefile b/comms/gqrx/Makefile
index 72d62ffdd105..74a49cf2c223 100644
--- a/comms/gqrx/Makefile
+++ b/comms/gqrx/Makefile
@@ -26,11 +26,12 @@ LIB_DEPENDS= libgnuradio-runtime.so:comms/gnuradio \
libboost_program_options.so:devel/boost-libs \
liblog4cpp.so:devel/log4cpp
-USES= pkgconfig qmake
+USES= pkgconfig qmake qt:5
+
USE_GITHUB= yes
GH_ACCOUNT= csete
USE_GL= gl
-USE_QT5= buildtools_build core gui svg network widgets
+USE_QT= buildtools_build core gui svg network widgets
OPTIONS_RADIO= AUDIO
AUDIO_DESC= Audio backend
diff --git a/comms/hamfax/Makefile b/comms/hamfax/Makefile
index 7c7589f4db65..3db5a1afb95e 100644
--- a/comms/hamfax/Makefile
+++ b/comms/hamfax/Makefile
@@ -12,10 +12,10 @@ COMMENT= QT application for sending and receiving facsimiles over radio
LIB_DEPENDS= libaudiofile.so:audio/libaudiofile
-USE_QT4= gui moc_build
+USE_QT= gui moc_build
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
-USES= gmake pkgconfig tar:bzip2
+USES= gmake pkgconfig qt:4 tar:bzip2
.include <bsd.port.mk>
diff --git a/comms/inspectrum/Makefile b/comms/inspectrum/Makefile
index 29cd46de3175..0fba1cc0ed41 100644
--- a/comms/inspectrum/Makefile
+++ b/comms/inspectrum/Makefile
@@ -22,8 +22,8 @@ USE_GITHUB= yes
GH_ACCOUNT= miek
GH_TAGNAME= 11853b64062bda4f81926613f15d1d9654c227c8
-USE_QT5= core buildtools_build concurrent widgets
-USES= cmake pkgconfig qmake
+USE_QT= core buildtools_build concurrent widgets
+USES= cmake pkgconfig qmake qt:5
USE_LDCONFIG= yes
.include <bsd.port.mk>
diff --git a/comms/klog/Makefile b/comms/klog/Makefile
index 9d95f51bf0ba..a03c1acff53d 100644
--- a/comms/klog/Makefile
+++ b/comms/klog/Makefile
@@ -11,8 +11,8 @@ COMMENT= Simple Qt-based amateur radio logger
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= qmake
-USE_QT5= buildtools_build core gui linguisttools_build multimedia network \
+USES= qmake qt:5
+USE_QT= buildtools_build core gui linguisttools_build multimedia network \
printsupport sql sql-sqlite3_run widgets
DESKTOP_ENTRIES= "KLog" "Simple Amateur Radio Logging Program" \
"" "klog" "Network;HamRadio;" \
diff --git a/comms/kremotecontrol-kde4/Makefile b/comms/kremotecontrol-kde4/Makefile
index 0e5066f8edb5..b7d340d123ba 100644
--- a/comms/kremotecontrol-kde4/Makefile
+++ b/comms/kremotecontrol-kde4/Makefile
@@ -10,9 +10,9 @@ COMMENT= KDE frontend for your remote controls
RUN_DEPENDS= lircd:comms/lirc
-USES= cmake:outsource kde:4 tar:xz
+USES= cmake:outsource kde:4 qt:4 tar:xz
USE_KDE= automoc4 kdelibs
-USE_QT4= corelib script xmlpatterns \
+USE_QT= corelib script xmlpatterns \
qmake_build moc_build rcc_build uic_build
USE_LDCONFIG= yes
diff --git a/comms/libsdr-gui/Makefile b/comms/libsdr-gui/Makefile
index eae58c112759..8302a50cdac4 100644
--- a/comms/libsdr-gui/Makefile
+++ b/comms/libsdr-gui/Makefile
@@ -19,8 +19,8 @@ LIB_DEPENDS= libfftw3.so:math/fftw3 \
USE_GITHUB= yes
GH_ACCOUNT= hmatuschek
-USE_QT5= core buildtools_build qmake widgets
-USES= cmake pkgconfig
+USE_QT= core buildtools_build qmake widgets
+USES= cmake pkgconfig qt:5
USE_LDCONFIG= yes
.include <bsd.port.mk>
diff --git a/comms/linpsk/Makefile b/comms/linpsk/Makefile
index 09d58e2b9a16..ad9a57ff479d 100644
--- a/comms/linpsk/Makefile
+++ b/comms/linpsk/Makefile
@@ -12,8 +12,8 @@ COMMENT= Simple Qt PSK31, RTTY, and MSK31 client
LIB_DEPENDS= libfftw3.so:math/fftw3 \
libasound.so:audio/alsa-lib
-USES= qmake tar:tgz
-USE_QT4= gui network corelib moc_build uic_build rcc_build qmake_build
+USES= qmake qt:4 tar:tgz
+USE_QT= gui network corelib moc_build uic_build rcc_build qmake_build
DESKTOP_ENTRIES="LinPsk" "${COMMENT}" \
"${DATADIR}/linpsk.png" "linpsk" "Audio;HamRadio;" \
false
diff --git a/comms/py-qt5-serialport/Makefile b/comms/py-qt5-serialport/Makefile
index af46f9911f15..8452318138ac 100644
--- a/comms/py-qt5-serialport/Makefile
+++ b/comms/py-qt5-serialport/Makefile
@@ -10,11 +10,11 @@ COMMENT= Python bindings for the Qt5 toolkit, QtSerialPort module
CONFIGURE_ARGS= --enable QtSerialPort
PYQT_DIST= yes
-USES= python pyqt:5
+USES= python pyqt:5 qt:5
USE_GL= gl
USE_PYQT= sip_build core_run
USE_PYTHON= flavors
-USE_QT5= core gui serialport qmake_build
+USE_QT= core gui serialport qmake_build
OPTIONS_DEFINE= API DEBUG
OPTIONS_DEFAULT=API
diff --git a/comms/qsstv/Makefile b/comms/qsstv/Makefile
index eeac7cc66b5f..977e78f5fa36 100644
--- a/comms/qsstv/Makefile
+++ b/comms/qsstv/Makefile
@@ -21,8 +21,8 @@ LIB_DEPENDS= libasound.so:audio/alsa-lib \
libv4l2.so:multimedia/libv4l
BUILD_DEPENDS= v4l_compat>=0:multimedia/v4l_compat
-USES= qmake pkgconfig
-USE_QT5= buildtools core gui network widgets xml
+USES= pkgconfig qmake qt:5
+USE_QT= buildtools core gui network widgets xml
USE_GL+= gl
OPTIONS_DEFINE= DOCS
diff --git a/comms/qt5-connectivity/Makefile b/comms/qt5-connectivity/Makefile
index 7248ec7112b9..42c2a88c5e4a 100644
--- a/comms/qt5-connectivity/Makefile
+++ b/comms/qt5-connectivity/Makefile
@@ -8,9 +8,8 @@ PKGNAMEPREFIX= qt5-
MAINTAINER= kde@FreeBSD.org
COMMENT= Qt connectivity (Bluetooth/NFC) module
-USE_QT5= concurrent core qml quick buildtools_build
-QT_DIST= ${PORTNAME}
-USES= qmake
+USE_QT= concurrent core qml quick buildtools_build
+USES= qmake qt-dist:5,connectivity
USE_LDCONFIG= ${PREFIX}/${QT_LIBDIR_REL}
diff --git a/comms/qt5-sensors/Makefile b/comms/qt5-sensors/Makefile
index 9b253262a828..28616607e7ae 100644
--- a/comms/qt5-sensors/Makefile
+++ b/comms/qt5-sensors/Makefile
@@ -8,9 +8,8 @@ PKGNAMEPREFIX= qt5-
MAINTAINER= kde@FreeBSD.org
COMMENT= Qt sensors module
-USE_QT5= core qml quick buildtools_build
-QT_DIST= ${PORTNAME}
-USES= qmake:norecursive
+USE_QT= core qml quick buildtools_build
+USES= qmake:norecursive qt-dist:5,sensors
USE_LDCONFIG= ${PREFIX}/${QT_LIBDIR_REL}
diff --git a/comms/qt5-serialbus/Makefile b/comms/qt5-serialbus/Makefile
index 7fc107800cc4..4d9f4f0b7cf5 100644
--- a/comms/qt5-serialbus/Makefile
+++ b/comms/qt5-serialbus/Makefile
@@ -8,9 +8,8 @@ PKGNAMEPREFIX= qt5-
MAINTAINER= kde@FreeBSD.org
COMMENT= Qt functions to access industrial bus systems
-USE_QT5= core network serialport buildtools_build
-QT_DIST= serialbus
-USES= compiler:c++11-lib qmake
+USE_QT= core network serialport buildtools_build
+USES= compiler:c++11-lib qmake qt-dist:5,serialbus
USE_LDCONFIG= ${PREFIX}/${QT_LIBDIR_REL}
.include <bsd.port.mk>
diff --git a/comms/qt5-serialport/Makefile b/comms/qt5-serialport/Makefile
index 55ba42ccafbd..54fdd7e8dfd3 100644
--- a/comms/qt5-serialport/Makefile
+++ b/comms/qt5-serialport/Makefile
@@ -8,9 +8,8 @@ PKGNAMEPREFIX= qt5-
MAINTAINER= kde@FreeBSD.org
COMMENT= Qt functions to access serial ports
-USE_QT5= core buildtools_build
-QT_DIST= serialport
-USES= qmake
+USE_QT= core buildtools_build
+USES= qmake qt-dist:5,serialport
USE_LDCONFIG= ${PREFIX}/${QT_LIBDIR_REL}
.include <bsd.port.mk>
diff --git a/comms/qtel/Makefile b/comms/qtel/Makefile
index d6ff9a949024..8847cd7465d5 100644
--- a/comms/qtel/Makefile
+++ b/comms/qtel/Makefile
@@ -14,7 +14,8 @@ LIB_DEPENDS= libecholib.so:comms/svxlink \
libgsm.so:audio/gsm
MASTERDIR= ${.CURDIR}/../svxlink
-USE_QT4= corelib gui network qmake_build linguist_build moc_build rcc_build uic_build
+USES= qt:4
+USE_QT= corelib gui network qmake_build linguist_build moc_build rcc_build uic_build
PKGDIR= ${.CURDIR}
CMAKE_ARGS+= -DUSE_QT:BOOL=YES \
-DQT_ONLY:BOOL=YES
diff --git a/comms/sdr-wspr/Makefile b/comms/sdr-wspr/Makefile
index dc2bf9770c78..08b71e4e4733 100644
--- a/comms/sdr-wspr/Makefile
+++ b/comms/sdr-wspr/Makefile
@@ -16,8 +16,8 @@ LIB_DEPENDS= libsdr-gui.so:comms/libsdr-gui
USE_GITHUB= yes
GH_ACCOUNT= hmatuschek
-USE_QT5= core buildtools_build qmake webkit widgets
-USES= cmake:outsource compiler:gcc-c++11-lib fortran pkgconfig
+USE_QT= core buildtools_build qmake webkit widgets
+USES= cmake:outsource compiler:gcc-c++11-lib fortran pkgconfig qt:5
PLIST_FILES= bin/sdr-wspr share/applications/sdr-wspr.desktop \
share/icons/sdr-wspr.svg
diff --git a/comms/svxlink/Makefile b/comms/svxlink/Makefile
index dbbb7cca32c5..772a4b0697a0 100644
--- a/comms/svxlink/Makefile
+++ b/comms/svxlink/Makefile
@@ -22,7 +22,7 @@ LIB_DEPENDS?= libgsm.so:audio/gsm \
BUILD_DEPENDS= pkg-config:devel/pkgconf \
${LOCALBASE}/include/linux/input.h:multimedia/v4l_compat
-USES= cmake compiler:c++11-lang tcl groff
+USES+= cmake compiler:c++11-lang tcl groff
USE_GITHUB= yes
GH_ACCOUNT= sm0svx
GH_PROJECT= svxlink
diff --git a/comms/wsjtx/Makefile b/comms/wsjtx/Makefile
index e8f0784d575b..054d80559f10 100644
--- a/comms/wsjtx/Makefile
+++ b/comms/wsjtx/Makefile
@@ -21,10 +21,10 @@ LIB_DEPENDS= libfftw3.so:math/fftw3 \
MAKE_JOBS_UNSAFE= yes
USES= cmake compiler:c++11-lib dos2unix fortran pkgconfig \
- readline tar:tgz
+ qt:5 readline tar:tgz
USE_GL= yes
-USE_QT5= core gui buildtools network qmake_build widgets \
- multimedia concurrent printsupport serialport
+USE_QT= core gui buildtools network qmake_build widgets \
+ multimedia concurrent printsupport serialport
CMAKE_ARGS+= -DPORT_BUILDING::STRING="ON" \
-DCMAKE_PREFIX_PATH+=${LOCALBASE}/wsjtx/lib \
-DLOCALBASE::STRING="${LOCALBASE}"
diff --git a/comms/xcwcp/Makefile b/comms/xcwcp/Makefile
index d502cd554279..c80dbb713994 100644
--- a/comms/xcwcp/Makefile
+++ b/comms/xcwcp/Makefile
@@ -12,8 +12,8 @@ LIB_DEPENDS= libcw.so:comms/unixcw
MASTERDIR= ${.CURDIR}/../unixcw
PLIST= ${.CURDIR}/pkg-plist
-USE_QT5= buildtools gui widgets qmake_build
-USES= gettext
+USE_QT= buildtools gui widgets qmake_build
+USES= gettext qt:5
# Qt from 5.7.0 on requires c++11.
USE_CXXSTD= c++11
GNU_CONFIGURE= yes