aboutsummaryrefslogtreecommitdiffstats
path: root/comms
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2018-06-11 09:44:15 +0800
committerlinimon <linimon@FreeBSD.org>2018-06-11 09:44:15 +0800
commit39e31de51fbf694ff20f162572dc22c61f7d1b9d (patch)
treed21fd4ee60da4c705d6bb2d4d0222a7e7af7ef7b /comms
parent1ddd46af14a4033deba9f651fa531f8aa83ea3f7 (diff)
downloadfreebsd-ports-gnome-39e31de51fbf694ff20f162572dc22c61f7d1b9d.tar.gz
freebsd-ports-gnome-39e31de51fbf694ff20f162572dc22c61f7d1b9d.tar.zst
freebsd-ports-gnome-39e31de51fbf694ff20f162572dc22c61f7d1b9d.zip
Fix port builds for architectures which remain on gcc as the default compiler.
This will primarily help powerpc64. For archs where clang is the default compiler, these changes will have no effect, as the base compiler already has these capabilities (primarily, but not exclusively, c++-11). Tested for no-harm on amd64. While here, pet portlint. Approved by: portmgr (tier-2 blanket)
Diffstat (limited to 'comms')
-rw-r--r--comms/svxlink/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/comms/svxlink/Makefile b/comms/svxlink/Makefile
index 50f170890da4..dbbb7cca32c5 100644
--- a/comms/svxlink/Makefile
+++ b/comms/svxlink/Makefile
@@ -22,11 +22,11 @@ LIB_DEPENDS?= libgsm.so:audio/gsm \
BUILD_DEPENDS= pkg-config:devel/pkgconf \
${LOCALBASE}/include/linux/input.h:multimedia/v4l_compat
+USES= cmake compiler:c++11-lang tcl groff
USE_GITHUB= yes
GH_ACCOUNT= sm0svx
GH_PROJECT= svxlink
-USES= cmake tcl groff
CMAKE_SOURCE_PATH= ${WRKSRC}/src
CMAKE_ARGS+= -DMAN_INSTALL_DIR:FILEPATH=${MANDIRS} \
-DLOCAL_STATE_DIR=/var