aboutsummaryrefslogtreecommitdiffstats
path: root/comms
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2015-07-17 04:53:28 +0800
committerkwm <kwm@FreeBSD.org>2015-07-17 04:53:28 +0800
commit4490d4bc75707dbdea79b297aac91b4ce174c25f (patch)
tree3fa9947d2b38c86d548ab0b4face968420a2825b /comms
parent929b8a6a2120516c63b8fecd8eba713ab5aafae2 (diff)
downloadfreebsd-ports-gnome-4490d4bc75707dbdea79b297aac91b4ce174c25f.tar.gz
freebsd-ports-gnome-4490d4bc75707dbdea79b297aac91b4ce174c25f.tar.zst
freebsd-ports-gnome-4490d4bc75707dbdea79b297aac91b4ce174c25f.zip
Convert code in bsd.port.mk for USE_GHOSTSCRIPT* to USES=ghostscript.
Add GHOSTSCRIPT_DEFAULT to bsd.default-versions.mk for easy version selection. Arguments supported: <empty>, build, run, nox11 and agpl PR: 201201 (exp-run) Approved by: portmgr (mat@) Exp run by: antione@ (previous patch) Differential Revision: https://reviews.freebsd.org/D2938
Diffstat (limited to 'comms')
-rw-r--r--comms/efax-gtk/Makefile3
-rw-r--r--comms/hylafax/Makefile3
-rw-r--r--comms/tkhylafax/Makefile3
3 files changed, 3 insertions, 6 deletions
diff --git a/comms/efax-gtk/Makefile b/comms/efax-gtk/Makefile
index 1eba2e78bc2a..0caeb75202b3 100644
--- a/comms/efax-gtk/Makefile
+++ b/comms/efax-gtk/Makefile
@@ -17,8 +17,7 @@ LIB_DEPENDS= libsigc-1.2.so:${PORTSDIR}/devel/libsigc++12 \
libcxx-gtk-utils-2-2.2.so:${PORTSDIR}/x11-toolkits/c++-gtk-utils
RUN_DEPENDS= ggv:${PORTSDIR}/print/ggv
-USES= compiler:c++11-lib pkgconfig
-USE_GHOSTSCRIPT_RUN=yes
+USES= compiler:c++11-lib ghostscript:run pkgconfig
USE_GNOME= gtk20
GNU_CONFIGURE= yes
diff --git a/comms/hylafax/Makefile b/comms/hylafax/Makefile
index 2865e4d65559..1d32fdcc2943 100644
--- a/comms/hylafax/Makefile
+++ b/comms/hylafax/Makefile
@@ -15,9 +15,8 @@ LIB_DEPENDS= libtiff.so:${PORTSDIR}/graphics/tiff \
libjbig.so:${PORTSDIR}/graphics/jbigkit
MAKE_JOBS_UNSAFE= yes
-USE_GHOSTSCRIPT=yes
HAS_CONFIGURE= yes
-USES= fakeroot jpeg
+USES= fakeroot ghostscript jpeg
CONFIGURE_ARGS= --with-INSTALL="" \
--with-LIBTIFF="-L${LOCALBASE}/lib -ltiff -ljpeg" \
diff --git a/comms/tkhylafax/Makefile b/comms/tkhylafax/Makefile
index 83066cceb90e..b83ad4c82f43 100644
--- a/comms/tkhylafax/Makefile
+++ b/comms/tkhylafax/Makefile
@@ -14,8 +14,7 @@ COMMENT= Tcl/tk interface to Sam Leffler's fax package
RUN_DEPENDS= sendfax:${PORTSDIR}/comms/hylafax \
gv:${PORTSDIR}/print/gv
-USE_GHOSTSCRIPT_RUN= yes
-USES+= tk:run
+USES+= ghostscript:run tk:run
WRKSRC= ${WRKDIR}/tkhylafax
MAKE_ARGS= STAGEDIR=${STAGEDIR} PREFIX=${STAGEDIR}${PREFIX} TCLSH=${TCLSH} WISH=${WISH}