aboutsummaryrefslogtreecommitdiffstats
path: root/comms
diff options
context:
space:
mode:
authortobik <tobik@FreeBSD.org>2019-01-13 23:17:23 +0800
committertobik <tobik@FreeBSD.org>2019-01-13 23:17:23 +0800
commit5f543fea519e4fb733e6ef807c4a8cb374198bd6 (patch)
tree18d6700d69915ffc476151fae25f92ff0906e745 /comms
parentd042d07730e9c385aba52e2f709e9c1036c9e7ec (diff)
downloadfreebsd-ports-gnome-5f543fea519e4fb733e6ef807c4a8cb374198bd6.tar.gz
freebsd-ports-gnome-5f543fea519e4fb733e6ef807c4a8cb374198bd6.tar.zst
freebsd-ports-gnome-5f543fea519e4fb733e6ef807c4a8cb374198bd6.zip
Use USES=pkgconfig where appropriate
Diffstat (limited to 'comms')
-rw-r--r--comms/libconcord/Makefile3
-rw-r--r--comms/svxlink/Makefile5
2 files changed, 3 insertions, 5 deletions
diff --git a/comms/libconcord/Makefile b/comms/libconcord/Makefile
index 9a637a47c8d8..7e8d631227ae 100644
--- a/comms/libconcord/Makefile
+++ b/comms/libconcord/Makefile
@@ -13,12 +13,11 @@ COMMENT= Logitech Harmony configuration library
LICENSE= GPLv2
-BUILD_DEPENDS= pkg-config:devel/pkgconf
LIB_DEPENDS= libhidapi.so:comms/hidapi \
libzip.so:archivers/libzip
USE_LDCONFIG= yes
-USES= tar:bzip2 libtool shared-mime-info
+USES= tar:bzip2 libtool pkgconfig shared-mime-info
WRKSRC_SUBDIR= libconcord
GNU_CONFIGURE= yes
CFLAGS+= -I${LOCALBASE}/include
diff --git a/comms/svxlink/Makefile b/comms/svxlink/Makefile
index 82dc25805538..61a43a32e9d1 100644
--- a/comms/svxlink/Makefile
+++ b/comms/svxlink/Makefile
@@ -19,10 +19,9 @@ LIB_DEPENDS?= libgsm.so:audio/gsm \
libpopt.so:devel/popt \
libopus.so:audio/opus \
librtlsdr.so:comms/rtl-sdr
-BUILD_DEPENDS= pkg-config:devel/pkgconf \
- ${LOCALBASE}/include/linux/input.h:devel/evdev-proto
+BUILD_DEPENDS= ${LOCALBASE}/include/linux/input.h:devel/evdev-proto
-USES+= cmake compiler:c++11-lang tcl groff
+USES+= cmake compiler:c++11-lang groff pkgconfig tcl
USE_GITHUB= yes
GH_ACCOUNT= sm0svx
GH_PROJECT= svxlink