aboutsummaryrefslogtreecommitdiffstats
path: root/comms
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-12-26 04:25:39 +0800
committerTobias C. Berner <tcberner@FreeBSD.org>2018-12-26 04:25:39 +0800
commit707c6bf295fc3955c86c9244533c1524bb7dea15 (patch)
tree5754f0a521127b72390a51a263bc6e84b5177927 /comms
parente3b5edc5e789bcd6057c4a01e4c618dbb1509756 (diff)
downloadfreebsd-ports-gnome-707c6bf295fc3955c86c9244533c1524bb7dea15.tar.gz
freebsd-ports-gnome-707c6bf295fc3955c86c9244533c1524bb7dea15.tar.zst
freebsd-ports-gnome-707c6bf295fc3955c86c9244533c1524bb7dea15.zip
Change cmake default behaviour to outsource.
Ports that build out of source now simply can use "USES=cmake" instead of "USES=cmake:outsource". Ports that fail to build out of source now need to specify "USES=cmake:insource". I tried to only set insource where explictely needed. PR: 232038 Exp-run by: antoine
Diffstat (limited to 'comms')
-rw-r--r--comms/airspy/Makefile2
-rw-r--r--comms/freedv/Makefile2
-rw-r--r--comms/gammu/Makefile2
-rw-r--r--comms/gnuradio/Makefile2
-rw-r--r--comms/hackrf/Makefile2
-rw-r--r--comms/kremotecontrol-kde4/Makefile2
-rw-r--r--comms/libbtbb/Makefile2
-rw-r--r--comms/multimon-ng/Makefile2
-rw-r--r--comms/openobex/Makefile2
-rw-r--r--comms/sdr-wspr/Makefile2
-rw-r--r--comms/ubertooth/Makefile2
-rw-r--r--comms/uhd/Makefile2
12 files changed, 12 insertions, 12 deletions
diff --git a/comms/airspy/Makefile b/comms/airspy/Makefile
index 525048e7cb6e..57e78d275861 100644
--- a/comms/airspy/Makefile
+++ b/comms/airspy/Makefile
@@ -16,7 +16,7 @@ LICENSE_FILE= ${WRKSRC}/airspy-tools/LICENSE.md
BROKEN_aarch64= fails to compile: invalid conversion between vector type '__m64' and integer type 'int'
BROKEN_powerpc64= fails to build: iqconverter_float.c:45:23: error: immintrin.h: No such file or directory
-USES= cmake:outsource pkgconfig
+USES= cmake pkgconfig
USE_GITHUB= yes
GH_PROJECT= airspyone_host
USE_LDCONFIG= yes
diff --git a/comms/freedv/Makefile b/comms/freedv/Makefile
index 3e6f224442a7..291ec1f3c36d 100644
--- a/comms/freedv/Makefile
+++ b/comms/freedv/Makefile
@@ -20,7 +20,7 @@ LIB_DEPENDS= libcodec2.so:audio/codec2 \
libspeex.so:audio/speex \
libspeexdsp.so:audio/speexdsp
-USES= cmake:outsource compiler:c++11-lib tar:xz
+USES= cmake compiler:c++11-lib tar:xz
USE_WX= 3.0+
CMAKE_ARGS+= -DCODEC2_INCLUDE_DIRS=${LOCALBASE}/include/codec2 \
-DCODEC2_LIBRARY=${LOCALBASE}/lib/libcodec2.so \
diff --git a/comms/gammu/Makefile b/comms/gammu/Makefile
index ff12d1072096..6029153a9dc9 100644
--- a/comms/gammu/Makefile
+++ b/comms/gammu/Makefile
@@ -18,7 +18,7 @@ LIB_DEPENDS= libcurl.so:ftp/curl
CMAKE_ARGS= -DINSTALL_LIBDATA_DIR:PATH=${PREFIX}/libdata \
-DINSTALL_MAN_DIR:PATH=${PREFIX}/man
-USES= cmake:outsource compiler:c++11-lang gettext iconv pkgconfig shebangfix tar:xz
+USES= cmake compiler:c++11-lang gettext iconv pkgconfig shebangfix tar:xz
SHEBANG_FILES= utils/jadmaker utils/gammu-config
bash_CMD= /bin/sh
USE_GNOME= glib20
diff --git a/comms/gnuradio/Makefile b/comms/gnuradio/Makefile
index 60e6fa2de11a..83feccfc73ba 100644
--- a/comms/gnuradio/Makefile
+++ b/comms/gnuradio/Makefile
@@ -51,7 +51,7 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
# volk/lib/volk_cpu.c: In function 'i_can_has_3dnow':
# volk/lib/volk_cpu.c:62: error: can't find a register in class 'BREG' while reloading 'asm'
# volk/lib/volk_cpu.c:62: error: 'asm' operand has impossible constraints
-USES= cmake:outsource compiler:c11 fortran iconv perl5 pkgconfig pyqt:4 python:2.7 qt:4 shebangfix
+USES= cmake compiler:c11 fortran iconv perl5 pkgconfig pyqt:4 python:2.7 qt:4 shebangfix
SHEBANG_FILES= grc/scripts/freedesktop/grc_setup_freedesktop.in \
gnuradio-runtime/python/gnuradio/ctrlport/gr-ctrlport-monitor \
gnuradio-runtime/python/gnuradio/ctrlport/gr-perf-monitorx
diff --git a/comms/hackrf/Makefile b/comms/hackrf/Makefile
index 75ea8aedf473..c473befa075a 100644
--- a/comms/hackrf/Makefile
+++ b/comms/hackrf/Makefile
@@ -14,7 +14,7 @@ USE_GITHUB= YES
GH_ACCOUNT= mossmann
GH_TAGNAME= 31a37bd
-USES= cmake:outsource
+USES= cmake
CMAKE_SOURCE_PATH= ${WRKSRC}/host
CMAKE_ARGS= -DLIBUSB_LIBRARIES=/usr/lib/libusb.so
diff --git a/comms/kremotecontrol-kde4/Makefile b/comms/kremotecontrol-kde4/Makefile
index 33d48bc2cc0b..57765eab18d1 100644
--- a/comms/kremotecontrol-kde4/Makefile
+++ b/comms/kremotecontrol-kde4/Makefile
@@ -13,7 +13,7 @@ EXPIRATION_DATE= 2018-12-31
RUN_DEPENDS= lircd:comms/lirc
-USES= cmake:outsource kde:4 qt:4 tar:xz
+USES= cmake kde:4 qt:4 tar:xz
USE_KDE= automoc4 kdelibs
USE_QT= corelib script xmlpatterns \
qmake_build moc_build rcc_build uic_build
diff --git a/comms/libbtbb/Makefile b/comms/libbtbb/Makefile
index 17313fa31c7d..beb08c62f7b0 100644
--- a/comms/libbtbb/Makefile
+++ b/comms/libbtbb/Makefile
@@ -14,7 +14,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= ${PYNUMPY}
-USES= cmake:outsource \
+USES= cmake \
python:2.7,build
USE_GITHUB= yes
diff --git a/comms/multimon-ng/Makefile b/comms/multimon-ng/Makefile
index 3e531564a22a..9c4ccc2678ed 100644
--- a/comms/multimon-ng/Makefile
+++ b/comms/multimon-ng/Makefile
@@ -13,7 +13,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
USE_GITHUB= yes
GH_ACCOUNT= EliasOenal
-USES= cmake
+USES= cmake:insource
OPTIONS_DEFINE= PULSEAUDIO X11
diff --git a/comms/openobex/Makefile b/comms/openobex/Makefile
index d6541812ed9b..b9efced8f964 100644
--- a/comms/openobex/Makefile
+++ b/comms/openobex/Makefile
@@ -10,7 +10,7 @@ MAINTAINER= madpilot@FreeBSD.org
COMMENT= Open source implementation of the OBEX protocol
USE_LDCONFIG= yes
-USES= cmake dos2unix
+USES= cmake:insource dos2unix
DOS2UNIX_FILES= CMakeLists.txt
CMAKE_ARGS+= -DPKGCONFIG_INSTALL_DIR:STRING="${PREFIX}/libdata/pkgconfig"
diff --git a/comms/sdr-wspr/Makefile b/comms/sdr-wspr/Makefile
index 07a73c112d73..243b4e3758f6 100644
--- a/comms/sdr-wspr/Makefile
+++ b/comms/sdr-wspr/Makefile
@@ -17,7 +17,7 @@ LIB_DEPENDS= libsdr-gui.so:comms/libsdr-gui
USE_GITHUB= yes
GH_ACCOUNT= hmatuschek
USE_QT= core buildtools_build qmake webkit widgets
-USES= cmake:outsource compiler:gcc-c++11-lib fortran pkgconfig qt:5
+USES= cmake compiler:gcc-c++11-lib fortran pkgconfig qt:5
PLIST_FILES= bin/sdr-wspr share/applications/sdr-wspr.desktop \
share/icons/sdr-wspr.svg
diff --git a/comms/ubertooth/Makefile b/comms/ubertooth/Makefile
index 7296efa5e531..bc1ab7dfd6e4 100644
--- a/comms/ubertooth/Makefile
+++ b/comms/ubertooth/Makefile
@@ -17,7 +17,7 @@ LIB_DEPENDS= libpyside-python2.7.so:devel/pyside \
BUILD_DEPENDS= ${PYNUMPY}
-USES= cmake:outsource \
+USES= cmake \
python
USE_GITHUB= yes
diff --git a/comms/uhd/Makefile b/comms/uhd/Makefile
index 73df45c02d23..3415799f0a99 100644
--- a/comms/uhd/Makefile
+++ b/comms/uhd/Makefile
@@ -33,7 +33,7 @@ BROKEN_FreeBSD_13_armv6= fails to configure: Could not find standard set_new_han
BROKEN_FreeBSD_13_armv7= fails to configure: Could not find standard set_new_handler function
BROKEN_powerpc64= fails to link: undefined reference to boost function
-USES= compiler:c++11-lib cmake:outsource ncurses pkgconfig \
+USES= compiler:c++11-lib cmake ncurses pkgconfig \
dos2unix python:2.7 shebangfix
USE_LDCONFIG= yes
CMAKE_SOURCE_PATH= ${WRKSRC}/host