aboutsummaryrefslogtreecommitdiffstats
path: root/comms
diff options
context:
space:
mode:
authormr <mr@FreeBSD.org>2016-09-14 16:52:36 +0800
committermr <mr@FreeBSD.org>2016-09-14 16:52:36 +0800
commit983eece3f90e24571bab266d4f1136018f616229 (patch)
treee12e751867f3ec6e1af57e53ece2723d12d42e6e /comms
parent02176491fc6763a4a015bb2b9e748c058c10b23e (diff)
downloadfreebsd-ports-gnome-983eece3f90e24571bab266d4f1136018f616229.tar.gz
freebsd-ports-gnome-983eece3f90e24571bab266d4f1136018f616229.tar.zst
freebsd-ports-gnome-983eece3f90e24571bab266d4f1136018f616229.zip
Some fixes for better ports compatibility suggested my Mathieu.
Submitted by: mat@
Diffstat (limited to 'comms')
-rw-r--r--comms/uhd/Makefile17
-rw-r--r--comms/uhd/files/patch-CMakeLists.txt9
-rw-r--r--comms/uhd/pkg-plist1
3 files changed, 4 insertions, 23 deletions
diff --git a/comms/uhd/Makefile b/comms/uhd/Makefile
index dd168c7f381e..5ec0771ba41e 100644
--- a/comms/uhd/Makefile
+++ b/comms/uhd/Makefile
@@ -7,16 +7,13 @@ CATEGORIES= comms hamradio
MASTER_SITES= http://files.ettus.com/binaries/images/
DISTFILES= ${IMAGE_FILE}
DIST_SUBDIR= ${PORTNAME}
-EXTRACT_ONLY= ${DISTFILES}
MAINTAINER= mr@FreeBSD.org
COMMENT= Ettus Research UHD driver framework
USE_GITHUB= yes
GH_ACCOUNT= EttusResearch
-GH_TAGNAME= ${UHD_COMMIT}
-
-UHD_COMMIT= 32951af2f3e7b1ddb56486c9f15b2e1033605bd6
+GH_TAGNAME= 32951af2f3e7b1ddb56486c9f15b2e1033605bd6
CONFLICTS= usrp-[0-9]*
@@ -27,26 +24,20 @@ BUILD_DEPENDS= ${LOCALBASE}/include/boost/tuple/tuple.hpp:${PORTSDIR}/devel/boos
orcc:${PORTSDIR}/devel/orc \
${PYTHON_PKGNAMEPREFIX}mako>0:${PORTSDIR}/textproc/py-mako
-USES= compiler:c++0x cmake:outsource gmake pkgconfig dos2unix python:2.7
-COMPILER_FEATURES= libc++
+USES= compiler:c++0x cmake:outsource gmake pkgconfig dos2unix python:2.7 pathfix
USE_LDCONFIG= yes
CMAKE_SOURCE_PATH= ${WRKSRC}/host
-MAKE_JOBS_UNSAFE= yes
+#MAKE_JOBS_UNSAFE= yes
CMAKE_ARGS+= -DPKG_LIB_DIR:STRING="share/uhd" -DUHD_TXRX_DEBUG_PRINTS="yes"
# for excruciating debug use this -db
#CMAKE_ARGS+= --debug-output --trace
-DOCSDIR= share/doc/uhd
IMAGE_FILE= uhd-images_003.009.005-release.zip
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 800000
-IGNORE= needs libusb 1.0
-.endif
-
-.if ${PORT_OPTIONS:MDOCS}
+.if ${PORT_OPTIONS:MDOXYGEN}
BUILD_DEPENDS+= doxygen:${PORTSDIR}/devel/doxygen
CMAKE_ARGS+= -DENABLE_DOXYGEN:STRING="ON"
HAVEDOCS= YES
diff --git a/comms/uhd/files/patch-CMakeLists.txt b/comms/uhd/files/patch-CMakeLists.txt
deleted file mode 100644
index c4acae6ff9dd..000000000000
--- a/comms/uhd/files/patch-CMakeLists.txt
+++ /dev/null
@@ -1,9 +0,0 @@
---- host/CMakeLists.txt.orig 2015-11-14 16:31:04.552639000 +0000
-+++ host/CMakeLists.txt 2015-11-14 17:26:43.452033000 +0000
-@@ -350,5 +350,5 @@
- UHD_INSTALL(
- FILES ${CMAKE_CURRENT_BINARY_DIR}/uhd.pc
-- DESTINATION ${LIBRARY_DIR}/pkgconfig
-+ DESTINATION libdata/pkgconfig
- COMPONENT "devel"
- )
diff --git a/comms/uhd/pkg-plist b/comms/uhd/pkg-plist
index 65f82b0675ab..26698ff47c51 100644
--- a/comms/uhd/pkg-plist
+++ b/comms/uhd/pkg-plist
@@ -108,7 +108,6 @@ lib/cmake/uhd/UHDConfigVersion.cmake
lib/libuhd.so
lib/libuhd.so.003
lib/libuhd.so.003.009
-libdata/pkgconfig/uhd.pc
%%PORTDOCS%%%%DOCSDIR%%/LICENSE
%%PORTDOCS%%%%DOCSDIR%%/README.md
%%PORTDOCS%%%%DOCSDIR%%/doxygen/html/Ettus_Logo.png