aboutsummaryrefslogtreecommitdiffstats
path: root/comms
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2014-08-11 03:50:23 +0800
committertijl <tijl@FreeBSD.org>2014-08-11 03:50:23 +0800
commita4d6c8291df773152db305fb1b6fb73ff46ce5d0 (patch)
treec05d182f965de6bace293ed87ece71bd45e7c422 /comms
parentfe632b08e93ba1c874edd2ac8a8dd74b2a8db908 (diff)
downloadfreebsd-ports-gnome-a4d6c8291df773152db305fb1b6fb73ff46ce5d0.tar.gz
freebsd-ports-gnome-a4d6c8291df773152db305fb1b6fb73ff46ce5d0.tar.zst
freebsd-ports-gnome-a4d6c8291df773152db305fb1b6fb73ff46ce5d0.zip
Fix problems with missing libs when the linker enforces explicit linking
(a* to d* categories) PR: 192062
Diffstat (limited to 'comms')
-rw-r--r--comms/libimobiledevice/Makefile12
-rw-r--r--comms/libimobiledevice/files/patch-configure10
-rw-r--r--comms/usrp/files/patch-host_examples_CMakeLists.txt10
3 files changed, 16 insertions, 16 deletions
diff --git a/comms/libimobiledevice/Makefile b/comms/libimobiledevice/Makefile
index 4b399ec74af7..0c30addf90f3 100644
--- a/comms/libimobiledevice/Makefile
+++ b/comms/libimobiledevice/Makefile
@@ -13,11 +13,13 @@ LICENSE?= LGPL21
SLAVE_PORT?= no
-USES= pkgconfig tar:bzip2
+USES= pathfix pkgconfig tar:bzip2
+USE_OPENSSL= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= openssl_LIBS=-lssl
-CFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ARGS= openssl_CFLAGS="-I${OPENSSLINC}" \
+ openssl_LIBS="-L${OPENSSLLIB} -lssl -lcrypto"
+CPPFLAGS+= -I${LOCALBASE}/include
+LIBS+= -L${LOCALBASE}/lib
.if ${SLAVE_PORT} == "no"
@@ -36,8 +38,6 @@ OPTIONS_DEFINE= DOCS
post-patch:
@${REINPLACE_CMD} -e 's, *@ssl_requires@,,' \
${WRKSRC}/${PORTNAME}*.pc.in
- @${REINPLACE_CMD} -e 's,$$(libdir)/pkgconfig,${PREFIX}/libdata/pkgconfig,g' \
- ${WRKSRC}/Makefile.in
post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
diff --git a/comms/libimobiledevice/files/patch-configure b/comms/libimobiledevice/files/patch-configure
deleted file mode 100644
index c286b6f000ac..000000000000
--- a/comms/libimobiledevice/files/patch-configure
+++ /dev/null
@@ -1,10 +0,0 @@
---- ./configure.orig 2013-03-18 10:28:26.000000000 +0100
-+++ ./configure 2013-04-30 14:56:00.356777062 +0200
-@@ -17262,6 +17262,7 @@
- $as_echo "yes" >&6; }
- have_openssl=yes
- fi
-+have_openssl=yes
- if test "x$have_openssl" = "xyes"; then
- if test "x$use_openssl" != "xyes"; then
- enable_openssl=no
diff --git a/comms/usrp/files/patch-host_examples_CMakeLists.txt b/comms/usrp/files/patch-host_examples_CMakeLists.txt
new file mode 100644
index 000000000000..edb9accee47d
--- /dev/null
+++ b/comms/usrp/files/patch-host_examples_CMakeLists.txt
@@ -0,0 +1,10 @@
+--- host/examples/CMakeLists.txt.orig
++++ host/examples/CMakeLists.txt
+@@ -41,6 +41,7 @@
+ TARGET_LINK_LIBRARIES(${example_name} uhd)
+ INSTALL(TARGETS ${example_name} RUNTIME DESTINATION ${PKG_LIB_DIR}/examples COMPONENT examples)
+ ENDFOREACH(example_source)
++TARGET_LINK_LIBRARIES(network_relay -pthread)
+
+ ########################################################################
+ # ASCII Art DFT - requires curses, so this part is optional