aboutsummaryrefslogtreecommitdiffstats
path: root/comms
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2015-10-16 15:25:39 +0800
committermarino <marino@FreeBSD.org>2015-10-16 15:25:39 +0800
commitb222753066047c1f87ab877061ba8e3fff2782b3 (patch)
tree5f81abfbd381b28422991b133378bbb2193b4a11 /comms
parent871269f3ef532e12388b4d8c4f4e0990fbc47ae7 (diff)
downloadfreebsd-ports-gnome-b222753066047c1f87ab877061ba8e3fff2782b3.tar.gz
freebsd-ports-gnome-b222753066047c1f87ab877061ba8e3fff2782b3.tar.zst
freebsd-ports-gnome-b222753066047c1f87ab877061ba8e3fff2782b3.zip
comms/nmealib is not jobs safe
nmealib reproducibly fails even with -j2. The build tries to link libnmea before its is built. While here, vertically align a couple of standard definitions.
Diffstat (limited to 'comms')
-rw-r--r--comms/nmealib/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/comms/nmealib/Makefile b/comms/nmealib/Makefile
index 4f879975ea14..342d1bde3731 100644
--- a/comms/nmealib/Makefile
+++ b/comms/nmealib/Makefile
@@ -11,13 +11,15 @@ COMMENT= Library for working with the NMEA protocol
LICENSE= LGPL21
-WRKSRC= ${WRKDIR}/${PORTNAME}
+WRKSRC= ${WRKDIR}/${PORTNAME}
-USES= gmake zip
+USES= gmake zip
INCLUDES= config.h context.h generate.h generator.h gmath.h info.h nmea.h \
parse.h parser.h sentence.h time.h tok.h units.h
+MAKE_JOBS_UNSAFE= yes
+
do-install:
${INSTALL_DATA} ${WRKSRC}/lib/libnmea.a ${STAGEDIR}${PREFIX}/lib
@${MKDIR} ${STAGEDIR}${PREFIX}/include/nmea