aboutsummaryrefslogtreecommitdiffstats
path: root/comms
diff options
context:
space:
mode:
authorshurd <shurd@FreeBSD.org>2016-04-08 15:31:44 +0800
committershurd <shurd@FreeBSD.org>2016-04-08 15:31:44 +0800
commitcf24073c0adf504adc5a1b102b3f81711b241da4 (patch)
tree28bbe0dbd6ab6b5052a92e33e1d8e143900dd01b /comms
parente7ca6eebabb8186ddeaec26f44cb334c235fc3cb (diff)
downloadfreebsd-ports-gnome-cf24073c0adf504adc5a1b102b3f81711b241da4.tar.gz
freebsd-ports-gnome-cf24073c0adf504adc5a1b102b3f81711b241da4.tar.zst
freebsd-ports-gnome-cf24073c0adf504adc5a1b102b3f81711b241da4.zip
Fix Make fails with a 32bit architecture.
Also, add strip. PR: 200042 Submitted by: takefu@airport.fm
Diffstat (limited to 'comms')
-rw-r--r--comms/wspr/Makefile2
-rw-r--r--comms/wspr/files/patch-configure.ac4
2 files changed, 4 insertions, 2 deletions
diff --git a/comms/wspr/Makefile b/comms/wspr/Makefile
index 56bca2115d98..7de376becaa5 100644
--- a/comms/wspr/Makefile
+++ b/comms/wspr/Makefile
@@ -39,6 +39,8 @@ do-build:
(cd ${WRKSRC};${GMAKE})
post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/wspr/WsprMod/w.so
+
.if defined(BOOTSTRAP)
#portlint freaks over this but it's only for dev ignore.
SVN_REV!= svn info svn://svn.code.sf.net/p/wsjt/wsjt/branches/wspr | ${GREP} Revision | cut -d' ' -f2
diff --git a/comms/wspr/files/patch-configure.ac b/comms/wspr/files/patch-configure.ac
index 2378e1096adb..8246f6b87920 100644
--- a/comms/wspr/files/patch-configure.ac
+++ b/comms/wspr/files/patch-configure.ac
@@ -1,4 +1,4 @@
---- configure.ac.orig 2015-07-27 16:22:02 UTC
+--- configure.ac.orig 2016-04-08 05:56:23 UTC
+++ configure.ac
@@ -10,18 +10,33 @@ dnl ------------------------------------
dnl path vars
@@ -193,7 +193,7 @@
;;
+ *freebsd* )
+ CFLAGS="${CFLAGS} -fpic"
-+ FFLAGS="-O2 -m64 -Wall -fbounds-check -fno-second-underscore \
++ FFLAGS="-O2 -m"$(/usr/bin/getconf LONG_BIT)" -Wall -fbounds-check -fno-second-underscore \
+-Wno-conversion -Wno-character-truncation -fPIC" ;;
*)
AC_MSG_ERROR([Unsupported System: ${host_os}.])