aboutsummaryrefslogtreecommitdiffstats
path: root/comms
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2016-09-10 06:22:43 +0800
committermarino <marino@FreeBSD.org>2016-09-10 06:22:43 +0800
commitdf56d2a1f69a58da34e185b0b862105841f61482 (patch)
tree4cf92ff18ed67d7d28a6bf4d987617a1e0457d1b /comms
parent33c2adc94672f0f0b1e5fa68a48e5a01a1be919c (diff)
downloadfreebsd-ports-gnome-df56d2a1f69a58da34e185b0b862105841f61482.tar.gz
freebsd-ports-gnome-df56d2a1f69a58da34e185b0b862105841f61482.tar.zst
freebsd-ports-gnome-df56d2a1f69a58da34e185b0b862105841f61482.zip
comms/libimobiledevice: Handle missing SSLv3 case
Approved by: SSL blanket
Diffstat (limited to 'comms')
-rw-r--r--comms/libimobiledevice/Makefile3
-rw-r--r--comms/libimobiledevice/files/patch-src_idevice.c11
2 files changed, 12 insertions, 2 deletions
diff --git a/comms/libimobiledevice/Makefile b/comms/libimobiledevice/Makefile
index eb6a7b3e6a89..d92ec6e07519 100644
--- a/comms/libimobiledevice/Makefile
+++ b/comms/libimobiledevice/Makefile
@@ -13,8 +13,7 @@ LICENSE?= LGPL21
SLAVE_PORT?= no
-USES+= cpe libtool pathfix pkgconfig tar:bzip2
-USE_OPENSSL= yes
+USES+= cpe libtool pathfix pkgconfig ssl tar:bzip2
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=openssl_CFLAGS="-I${OPENSSLINC}" \
openssl_LIBS="-L${OPENSSLLIB} -lssl -lcrypto"
diff --git a/comms/libimobiledevice/files/patch-src_idevice.c b/comms/libimobiledevice/files/patch-src_idevice.c
new file mode 100644
index 000000000000..33254cc20d84
--- /dev/null
+++ b/comms/libimobiledevice/files/patch-src_idevice.c
@@ -0,0 +1,11 @@
+--- src/idevice.c.orig 2015-01-28 01:10:32 UTC
++++ src/idevice.c
+@@ -678,7 +678,7 @@ LIBIMOBILEDEVICE_API idevice_error_t ide
+ }
+ BIO_set_fd(ssl_bio, (int)(long)connection->data, BIO_NOCLOSE);
+
+- SSL_CTX *ssl_ctx = SSL_CTX_new(SSLv3_method());
++ SSL_CTX *ssl_ctx = SSL_CTX_new(SSLv23_method());
+ if (ssl_ctx == NULL) {
+ debug_info("ERROR: Could not create SSL context.");
+ BIO_free(ssl_bio);