aboutsummaryrefslogtreecommitdiffstats
path: root/comms
diff options
context:
space:
mode:
authorgahr <gahr@FreeBSD.org>2008-08-28 20:09:58 +0800
committergahr <gahr@FreeBSD.org>2008-08-28 20:09:58 +0800
commite1f423074857203f65054cdcdf6b3d2423973761 (patch)
tree5593deff81b726c8b29734a4f883c2532d210a4d /comms
parent50083cb310720ee3a70538e28e92170e05c89262 (diff)
downloadfreebsd-ports-gnome-e1f423074857203f65054cdcdf6b3d2423973761.tar.gz
freebsd-ports-gnome-e1f423074857203f65054cdcdf6b3d2423973761.tar.zst
freebsd-ports-gnome-e1f423074857203f65054cdcdf6b3d2423973761.zip
- Fix build
Reported by: QA Tindie
Diffstat (limited to 'comms')
-rw-r--r--comms/xmorse/Makefile2
-rw-r--r--comms/xmorse/files/patch-m.fl11
2 files changed, 12 insertions, 1 deletions
diff --git a/comms/xmorse/Makefile b/comms/xmorse/Makefile
index 894a1d1b9ce0..997aa4211ac4 100644
--- a/comms/xmorse/Makefile
+++ b/comms/xmorse/Makefile
@@ -19,7 +19,7 @@ EXTRACT_SUFX= .tgz
MAINTAINER= sunrychen@gmail.com
COMMENT= A fully automatic Morse code teaching machine
-BUILD_DEPENDS= fluid:${PORTSDIR}/x11-toolkits/fltk
+LIB_DEPENDS= fltk.1:${PORTSDIR}/x11-toolkits/fltk
USE_DISPLAY= yes
USE_SDL= sdl
diff --git a/comms/xmorse/files/patch-m.fl b/comms/xmorse/files/patch-m.fl
new file mode 100644
index 000000000000..f36daa6f0a19
--- /dev/null
+++ b/comms/xmorse/files/patch-m.fl
@@ -0,0 +1,11 @@
+--- m.fl.orig 2008-08-28 14:00:49.000000000 +0200
++++ m.fl 2008-08-28 14:00:58.000000000 +0200
+@@ -231,7 +231,7 @@
+ }
+ }
+ }
+- code {w->show(argc, argv);
++ //code {w->show(argc, argv);
+ while (1) {
+ int c = Lesson->select(); // Select random letter
+ bool pass = Teacher->teach(c);// Teach/test student