aboutsummaryrefslogtreecommitdiffstats
path: root/comms
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2002-10-08 19:16:04 +0800
committerknu <knu@FreeBSD.org>2002-10-08 19:16:04 +0800
commite2ec724e949f67699715ff611cb79752d2b3c1ce (patch)
tree7ba7a9a8bd9e2e05164532770a152ed81bdc1019 /comms
parent51685ad2c912ee5293d84b780d123f095204b973 (diff)
downloadfreebsd-ports-gnome-e2ec724e949f67699715ff611cb79752d2b3c1ce.tar.gz
freebsd-ports-gnome-e2ec724e949f67699715ff611cb79752d2b3c1ce.tar.zst
freebsd-ports-gnome-e2ec724e949f67699715ff611cb79752d2b3c1ce.zip
Update to 0.9.1. (PORTEPOCH bumped)
Diffstat (limited to 'comms')
-rw-r--r--comms/ruby-termios/Makefile25
-rw-r--r--comms/ruby-termios/distinfo2
-rw-r--r--comms/ruby-termios/pkg-plist10
3 files changed, 25 insertions, 12 deletions
diff --git a/comms/ruby-termios/Makefile b/comms/ruby-termios/Makefile
index eb828ac93039..7f100e500577 100644
--- a/comms/ruby-termios/Makefile
+++ b/comms/ruby-termios/Makefile
@@ -6,30 +6,41 @@
#
PORTNAME= termios
-PORTVERSION= 20001115
-PORTREVISION= 1
+PORTVERSION= 0.9.1
+PORTEPOCH= 1
CATEGORIES= comms ruby
-MASTER_SITES= http://arika.org/pub/Tools/Ruby/
+MASTER_SITES= http://arika.org/archive/
PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
-DISTNAME= ${PORTNAME}
+DISTNAME= ruby-${PORTNAME}-${PORTVERSION}
DIST_SUBDIR= ruby
MAINTAINER= knu@FreeBSD.org
USE_RUBY= yes
USE_RUBY_EXTCONF= yes
+USE_RUBY_RDTOOL= yes
INSTALL_TARGET= site-install
+DOCS= ChangeLog README termios.html termios.rd
+
post-patch:
- ${RUBY} -i -pe 'gsub /ttyS\d/, "cuaa0"' ${WRKSRC}/test/*.rb
+ ${RUBY} -i -pe 'gsub(/ttyS\d/, "cuaa0")' ${WRKSRC}/examples/*.rb
+ ${RUBY} -i -pe 'gsub(/\.c_/, ".")' ${WRKSRC}/examples/*.rb
+
+post-build:
+.if !defined(NOPORTDOCS)
+ cd ${WRKSRC}; ${RUBY_RD2} termios.rd > termios.html
+.endif
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${RUBY_MODEXAMPLESDIR}
- ${CP} -R ${WRKSRC}/test/*.rb ${RUBY_MODEXAMPLESDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/examples/*.rb ${RUBY_MODEXAMPLESDIR}/
${MKDIR} ${RUBY_MODDOCDIR}
- ${INSTALL_DATA} ${WRKSRC}/ChangeLog ${RUBY_MODDOCDIR}/
+.for f in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODDOCDIR}/
+.endfor
.endif
.include <bsd.port.mk>
diff --git a/comms/ruby-termios/distinfo b/comms/ruby-termios/distinfo
index 2f30d035106a..f97c5e92750d 100644
--- a/comms/ruby-termios/distinfo
+++ b/comms/ruby-termios/distinfo
@@ -1 +1 @@
-MD5 (ruby/termios.tar.gz) = 7de192eb6f6b16cd17cb6e87df3ef333
+MD5 (ruby/ruby-termios-0.9.1.tar.gz) = 5e530b1a1c252f166c5fe8b9d7346d36
diff --git a/comms/ruby-termios/pkg-plist b/comms/ruby-termios/pkg-plist
index 5799f2747685..975945d78b02 100644
--- a/comms/ruby-termios/pkg-plist
+++ b/comms/ruby-termios/pkg-plist
@@ -1,8 +1,10 @@
%%RUBY_SITEARCHLIBDIR%%/termios.so
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ChangeLog
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/README
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/termios.html
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/termios.rd
%%PORTDOCS%%@dirrm %%RUBY_MODDOCDIR%%
-%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/test0.rb
-%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/test1.rb
-%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/test2.rb
-%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/test3.rb
+%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/modem_check.rb
+%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/secret_input1.rb
+%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/secret_input2.rb
%%PORTDOCS%%@dirrm %%RUBY_MODEXAMPLESDIR%%