aboutsummaryrefslogtreecommitdiffstats
path: root/comms
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-04-23 14:34:47 +0800
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-04-23 14:34:47 +0800
commite2eefe54727fdc19d777faed8f31182080be79c7 (patch)
treeb30102687ef5c1ab28ebc1ef135357c7ae631a39 /comms
parent6ee4f3c0edb78d03dd3593708882d63a840d5fbd (diff)
downloadfreebsd-ports-gnome-e2eefe54727fdc19d777faed8f31182080be79c7.tar.gz
freebsd-ports-gnome-e2eefe54727fdc19d777faed8f31182080be79c7.tar.zst
freebsd-ports-gnome-e2eefe54727fdc19d777faed8f31182080be79c7.zip
Convert all c categories to USE=pkgconfig
Diffstat (limited to 'comms')
-rw-r--r--comms/cwdaemon/Makefile8
-rw-r--r--comms/deforaos-phone/Makefile2
-rw-r--r--comms/efax-gtk/Makefile2
-rw-r--r--comms/fldigi/Makefile2
-rw-r--r--comms/libticables2/Makefile3
-rw-r--r--comms/libticalcs2/Makefile3
-rw-r--r--comms/qtel/Makefile2
-rw-r--r--comms/rtl-sdr/Makefile2
-rw-r--r--comms/tilp2/Makefile2
9 files changed, 10 insertions, 16 deletions
diff --git a/comms/cwdaemon/Makefile b/comms/cwdaemon/Makefile
index 6bd588051f7a..7c6f1f8db50a 100644
--- a/comms/cwdaemon/Makefile
+++ b/comms/cwdaemon/Makefile
@@ -1,9 +1,5 @@
-# ports collection makefile for: cwdaemon
-# Date created: 17 Mar 2005
-# Whom: Diane Bruce <db@db.net>
-#
+# Created by: Diane Bruce <db@db.net>
# $FreeBSD$
-#
PORTNAME= cwdaemon
PORTVERSION= 0.9.4
@@ -19,7 +15,7 @@ LIB_DEPENDS= cw:${PORTSDIR}/comms/unixcw
INSTALL_TARGET= install-exec
GNU_CONFIGURE= yes
-USE_PKGCONFIG= yes
+USES= pkgconfig
CONFIGURE_ARGS+= --datadir=${PREFIX}/share/doc
MAN8= cwdaemon.8
diff --git a/comms/deforaos-phone/Makefile b/comms/deforaos-phone/Makefile
index 2fa3cce8f97b..6f2dc2cf6223 100644
--- a/comms/deforaos-phone/Makefile
+++ b/comms/deforaos-phone/Makefile
@@ -22,8 +22,8 @@ LIB_DEPENDS= System:${PORTSDIR}/devel/deforaos-libsystem \
BUILD_DEPENDS= locker:${PORTSDIR}/x11/deforaos-locker \
${LOCALBASE}/include/linux/videodev2.h:${PORTSDIR}/multimedia/v4l_compat
+USES= pkgconfig
USE_GNOME= gtk20 desktopfileutils
-USE_PKGCONFIG= build
USE_GETTEXT= yes
INSTALLS_ICONS= yes
MAKE_ARGS+= PREFIX=${PREFIX}
diff --git a/comms/efax-gtk/Makefile b/comms/efax-gtk/Makefile
index b1fb7817e049..d524cda6fdc3 100644
--- a/comms/efax-gtk/Makefile
+++ b/comms/efax-gtk/Makefile
@@ -27,11 +27,11 @@ LIB_DEPENDS= pthread-stubs:${PORTSDIR}/devel/libpthread-stubs \
xcb:${PORTSDIR}/x11/libxcb
RUN_DEPENDS= ggv:${PORTSDIR}/print/ggv
+USES= pkgconfig
USE_ICONV= yes
USE_GHOSTSCRIPT_RUN=yes
USE_GNOME= gdkpixbuf2 gtk20
GNU_CONFIGURE= yes
-USE_PKGCONFIG= build
USE_GCC= 4.4+
USE_XORG= pixman x11 xau xcomposite xcursor xdamage xdmcp xext xfixes \
xi xinerama xrandr xrender
diff --git a/comms/fldigi/Makefile b/comms/fldigi/Makefile
index a45d2d395739..c7ed7a0dda92 100644
--- a/comms/fldigi/Makefile
+++ b/comms/fldigi/Makefile
@@ -19,8 +19,8 @@ LIB_DEPENDS= samplerate:${PORTSDIR}/audio/libsamplerate\
fltk:${PORTSDIR}/x11-toolkits/fltk
GNU_CONFIGURE= yes
+USES= pkgconfig
USE_GMAKE= yes
-USE_PKGCONFIG= build
CONFIGURE_ENV= FLTK_CONFIG="${LOCALBASE}/bin/fltk-config"
MAN1= fldigi.1
diff --git a/comms/libticables2/Makefile b/comms/libticables2/Makefile
index cef175711bfc..5a5a898719d4 100644
--- a/comms/libticables2/Makefile
+++ b/comms/libticables2/Makefile
@@ -14,8 +14,7 @@ USE_BZIP2= yes
USE_GMAKE= yes
USE_GNOME= glib20
USE_LDCONFIG= yes
-USE_PKGCONFIG= build
-USES= pathfix
+USES= pathfix pkgconfig
OPTIONS_DEFINE= NLS
diff --git a/comms/libticalcs2/Makefile b/comms/libticalcs2/Makefile
index f42148ef158f..a3945f098788 100644
--- a/comms/libticalcs2/Makefile
+++ b/comms/libticalcs2/Makefile
@@ -18,8 +18,7 @@ USE_BZIP2= yes
USE_GMAKE= yes
USE_GNOME= glib20
USE_LDCONFIG= yes
-USE_PKGCONFIG= build
-USES= pathfix
+USES= pathfix pkgconfig
OPTIONS_DEFINE= NLS
diff --git a/comms/qtel/Makefile b/comms/qtel/Makefile
index fe40c589d064..bb757cc38bf4 100644
--- a/comms/qtel/Makefile
+++ b/comms/qtel/Makefile
@@ -35,10 +35,10 @@ MAN5= svxlink.conf.5 \
ModuleSelCallEnc.conf.5 \
remotetrx.conf.5
MANCOMPRESSED= yes
+USES= pkgconfig
USE_GMAKE= yes
USE_QT_VER= 3
USE_TCL= yes
-USE_PKGCONFIG= yes
USE_RC_SUBR= svxlink remotetrx
USE_LDCONFIG= ${LOCALBASE}/lib ${LOCALBASE}/lib/svxlink
diff --git a/comms/rtl-sdr/Makefile b/comms/rtl-sdr/Makefile
index b745456647f2..a46ee8390ca3 100644
--- a/comms/rtl-sdr/Makefile
+++ b/comms/rtl-sdr/Makefile
@@ -13,7 +13,7 @@ COMMENT= Commandline tool that performs SDR with RTL2832-based USB sticks
LICENSE= GPLv2
-USE_PKGCONFIG= yes
+USES= pkgconfig
USE_AUTOTOOLS= autoconf:env aclocal:env automake:env libtool
USE_GMAKE= yes
GNU_CONFIGURE= yes
diff --git a/comms/tilp2/Makefile b/comms/tilp2/Makefile
index 8047429bb9d3..8f997629f710 100644
--- a/comms/tilp2/Makefile
+++ b/comms/tilp2/Makefile
@@ -15,10 +15,10 @@ LIB_DEPENDS= ticables2:${PORTSDIR}/comms/libticables2 \
ticalcs2:${PORTSDIR}/comms/libticalcs2 \
ticonv:${PORTSDIR}/converters/libticonv
+USES= pkgconfig
USE_BZIP2= yes
USE_GMAKE= yes
USE_GNOME= gtk20
-USE_PKGCONFIG= build
OPTIONS_DEFINE= NLS