aboutsummaryrefslogtreecommitdiffstats
path: root/comms
diff options
context:
space:
mode:
authordb <db@FreeBSD.org>2014-06-09 09:19:32 +0800
committerdb <db@FreeBSD.org>2014-06-09 09:19:32 +0800
commitf6351e97f6824edabdbe3ab80a0bfc8f2c1f558a (patch)
tree67a68f31fead847c7bc39ec8aa9092f3a66583f0 /comms
parentcf5b9b87b284893bcc8e9143f0964fe1091ae066 (diff)
downloadfreebsd-ports-gnome-f6351e97f6824edabdbe3ab80a0bfc8f2c1f558a.tar.gz
freebsd-ports-gnome-f6351e97f6824edabdbe3ab80a0bfc8f2c1f558a.tar.zst
freebsd-ports-gnome-f6351e97f6824edabdbe3ab80a0bfc8f2c1f558a.zip
- Simple fix to unbreak this port
Diffstat (limited to 'comms')
-rw-r--r--comms/aldo/Makefile2
-rw-r--r--comms/aldo/files/patch-src_audioworkspace.cc16
2 files changed, 13 insertions, 5 deletions
diff --git a/comms/aldo/Makefile b/comms/aldo/Makefile
index afa1b56d5e59..a3bf0ac7c82b 100644
--- a/comms/aldo/Makefile
+++ b/comms/aldo/Makefile
@@ -11,8 +11,6 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= lambert@lambertfam.org
COMMENT= Morse code training program
-BROKEN= Does not build with modern compilers
-
LIB_DEPENDS= libao.so:${PORTSDIR}/audio/libao
GNU_CONFIGURE= yes
diff --git a/comms/aldo/files/patch-src_audioworkspace.cc b/comms/aldo/files/patch-src_audioworkspace.cc
index 8dc79addc8da..e5ea35090c2a 100644
--- a/comms/aldo/files/patch-src_audioworkspace.cc
+++ b/comms/aldo/files/patch-src_audioworkspace.cc
@@ -1,6 +1,16 @@
---- src/audioworkspace.cc.orig 2010-06-06 14:43:58.000000000 +0200
-+++ src/audioworkspace.cc 2010-06-06 14:44:27.000000000 +0200
-@@ -104,6 +104,7 @@ oastream AudioWorkSpace::create_output_s
+--- src/audioworkspace.cc.orig 2007-11-05 03:58:46.000000000 -0500
++++ src/audioworkspace.cc 2014-06-08 20:17:26.477449983 -0400
+@@ -31,7 +31,8 @@
+ #include <cmath>
+ #include <iostream>
+ #include <limits>
+-
++#include <string.h>
++
+ using namespace std;
+ using namespace libaudiostream;
+
+@@ -104,6 +105,7 @@
{
ao_sample_format format;