aboutsummaryrefslogtreecommitdiffstats
path: root/converters/ascii2binary/Makefile
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2006-03-05 16:29:04 +0800
committerthierry <thierry@FreeBSD.org>2006-03-05 16:29:04 +0800
commit242b166756b3383a3c3294f3bc08591a39cfc10f (patch)
tree65fa2dff63381767d964876c5ac8303669dfea7e /converters/ascii2binary/Makefile
parentf9753aaca244b8255afd36b7a2ed3ff267ca6aa6 (diff)
downloadfreebsd-ports-gnome-242b166756b3383a3c3294f3bc08591a39cfc10f.tar.gz
freebsd-ports-gnome-242b166756b3383a3c3294f3bc08591a39cfc10f.tar.zst
freebsd-ports-gnome-242b166756b3383a3c3294f3bc08591a39cfc10f.zip
Upgrade to 2.9 to make fetchable again.
Changelog at <http://billposer.org/Software/a2b.html#changelog>. Approved by: portmgr (linimon)
Diffstat (limited to 'converters/ascii2binary/Makefile')
-rw-r--r--converters/ascii2binary/Makefile30
1 files changed, 6 insertions, 24 deletions
diff --git a/converters/ascii2binary/Makefile b/converters/ascii2binary/Makefile
index 66ff43f3a6a9..bc8d31cd3ff7 100644
--- a/converters/ascii2binary/Makefile
+++ b/converters/ascii2binary/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= ascii2binary
-PORTVERSION= 2.8.1
+PORTVERSION= 2.9
CATEGORIES= converters
MASTER_SITES= http://billposer.org/Software/Downloads/
DISTNAME= ${PORTNAME}
@@ -16,33 +16,15 @@ DIST_SUBDIR= ${PORTNAME}-${PORTVERSION}
MAINTAINER= thierry@FreeBSD.org
COMMENT= Convert between textual representations of numbers and binary
-HAS_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
- LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib" \
- LIBS="-lintl"
-MAKE_ENV= CPPFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
- LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib" \
- LIBS="-lintl"
-USE_GETTEXT= yes
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:R}
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-PLIST_FILES= bin/ascii2binary bin/binary2ascii \
- %%NLS%%share/locale/fr/LC_MESSAGES/ascii2binary.mo
+PLIST_FILES= bin/ascii2binary bin/binary2ascii
MAN1= ascii2binary.1 binary2ascii.1
-.if defined(WITHOUT_NLS)
-PLIST_SUB= NLS="@comment "
-.else
-PLIST_SUB= NLS=""
-.endif
-
pre-configure:
-.if defined(WITHOUT_NLS)
- ${REINPLACE_CMD} -e 's|cp -r locale|#cp -r locale|' ${WRKSRC}/Makefile
-.endif
-
-post-install:
- @${FIND} ${PREFIX}/share/locale -name ascii2binary.po -delete
+ ${REINPLACE_CMD} -e "s|/usr/local|${LOCALBASE}|" ${WRKSRC}/Makefile.in
.include <bsd.port.mk>