aboutsummaryrefslogtreecommitdiffstats
path: root/converters/kdesupport2
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2001-03-25 06:15:59 +0800
committerwill <will@FreeBSD.org>2001-03-25 06:15:59 +0800
commit63e44ba845351114773cc3c18846cac95bc4be15 (patch)
tree87c0cdd041f295f742326ff15825dbec8b7ace9b /converters/kdesupport2
parent8e2927fc3c616d1f4d0dbbeb505045d2273dfcfb (diff)
downloadfreebsd-ports-gnome-63e44ba845351114773cc3c18846cac95bc4be15.tar.gz
freebsd-ports-gnome-63e44ba845351114773cc3c18846cac95bc4be15.tar.zst
freebsd-ports-gnome-63e44ba845351114773cc3c18846cac95bc4be15.zip
Bring in my fixes for KDE2 for users of XFree86 4.0.x. Basically, what
this involves is this: Cull GL from Qt by default, but still provide a Qt+GL library that may or may not have threads. Then also provide a Qt library that has threads but not GL. This allows us to make KDE2 depend on a library that will *not* have threads, ever. Threads will be revisited at a later date. Ports that require GL support need to be updated to use the hacked library, libqtgl.so.4. The net result is that we bloat our qt2 package by 1.5-2.5MB for compatability. Also, static qt will not have GL support. Introduce bsd.kde.mk, which will be tested on bento before becoming fully activated. Replace qt22-static with qt2-static, since it's just a proxy. Update qt-designer to depend on qt23. Also make the old hack to package the correct lib obsolete by using PLIST_SUB instead. Miscellaneous changes: remove LIBQTFILE from CONFIGURE_ENV, it's not used anymore. Solve namespace pollution problems with the devel/pth and devel/libgnugetopt ports. Hopefully. Suggested by: ade, asami, sobomax (bsd.kde.mk) Repocopied by: asami (qt22-static --> qt2-static)
Diffstat (limited to 'converters/kdesupport2')
-rw-r--r--converters/kdesupport2/Makefile36
-rw-r--r--converters/kdesupport2/files/patch-ae11
2 files changed, 6 insertions, 41 deletions
diff --git a/converters/kdesupport2/Makefile b/converters/kdesupport2/Makefile
index 2cbfda0eb7e6..1d4896ca12c8 100644
--- a/converters/kdesupport2/Makefile
+++ b/converters/kdesupport2/Makefile
@@ -17,46 +17,22 @@ LIB_DEPENDS= png.4:${PORTSDIR}/graphics/png \
jpeg.9:${PORTSDIR}/graphics/jpeg
USE_QT2= yes
-MOC= ${X11BASE}/bin/moc2
+MOC?= ${X11BASE}/bin/moc2
USE_BZIP2= yes
USE_NEWGCC= yes
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
-
-.include <bsd.port.pre.mk>
-
-# Hack to make pthread support work correctly. Even if we have a
-# libqt2-mt, it may not be wise to build with it if we don't have
-# a threads stub for X.
-.if exists(${X11BASE}/lib/libqt2-mt.so)
-.if exists(${X11BASE}/lib/libXThrStub.so)
-QTNAME= "qt2-mt"
-.if ${OSVERSION} >= 500016
-PTHREAD_CFLAGS= ""
-PTHREAD_LIBS= "-lc_r"
-.else
-PTHREAD_CFLAGS= "-D_THREAD_SAFE"
-PTHREAD_LIBS= "-pthread"
-.endif
-.else
-QTNAME= "qt2"
-PTHREAD_CFLAGS= ""
-PTHREAD_LIBS= ""
-.endif
-.endif
+USE_GMAKE= yes
CONFIGURE_ARGS+=--with-qt-includes=${X11BASE}/include/qt2 \
--with-qt-libraries=${X11BASE}/lib \
--with-extra-libs=${LOCALBASE}/lib \
--without-audiofile
-CONFIGURE_ENV+= LIBQT="-l${QTNAME}" MOC="${MOC}" LIBQTFILE="lib${QTNAME}" \
- CPPFLAGS="-I${LOCALBASE}/include -D_GETOPT_H ${PTHREAD_CFLAGS}" \
- LIBS="-Wl,-export-dynamic -L${LOCALBASE}/lib -ljpeg -lstdc++ -lgcc ${PTHREAD_LIBS}"
-USE_GMAKE= yes
+CONFIGURE_ENV+= LIBQT="-lqt2" MOC="${MOC}" \
+ CPPFLAGS="-I${LOCALBASE}/include -D_GETOPT_H" \
+ LIBS="-Wl,-export-dynamic -L${LOCALBASE}/lib -ljpeg -lstdc++ -lgcc"
pre-configure:
- ${PERL} -pi -e "s@TOPSUBDIRS libaps@TOPSUBDIRS@g ; \
- s@odbc libaps@odbc@g" ${WRKSRC}/configure
${PERL} -pi -e "s@-version-info 1:1@-version-info 3:0@g" ${WRKSRC}/mimelib/Makefile.in
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/converters/kdesupport2/files/patch-ae b/converters/kdesupport2/files/patch-ae
deleted file mode 100644
index 5694a2ed4dc1..000000000000
--- a/converters/kdesupport2/files/patch-ae
+++ /dev/null
@@ -1,11 +0,0 @@
---- mimelib/Makefile.in Tue May 9 19:33:18 2000
-+++ mimelib/Makefile.in.new Tue May 16 18:32:11 2000
-@@ -233,7 +233,7 @@
-
- DEFS = -D$(LIBVERSION) @DEFS@
-
--libmimelib_la_LDFLAGS = -version-info 1:1
-+libmimelib_la_LDFLAGS = -version-info 3:0
- mkinstalldirs = $(SHELL) $(top_srcdir)/admin/mkinstalldirs
- CONFIG_HEADER = ../config.h
- CONFIG_CLEAN_FILES =