aboutsummaryrefslogtreecommitdiffstats
path: root/converters/trans
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2013-09-07 02:02:19 +0800
committerdanfe <danfe@FreeBSD.org>2013-09-07 02:02:19 +0800
commit9cad8126328ec7e40fe8a6c73307e7ae830b4e2a (patch)
treeaebf46b264b2f2188447034b9dda8e84ba40cdca /converters/trans
parent3a670fd576d40ac28d44b8bd43bc2ea54e917cd8 (diff)
downloadfreebsd-ports-gnome-9cad8126328ec7e40fe8a6c73307e7ae830b4e2a.tar.gz
freebsd-ports-gnome-9cad8126328ec7e40fe8a6c73307e7ae830b4e2a.tar.zst
freebsd-ports-gnome-9cad8126328ec7e40fe8a6c73307e7ae830b4e2a.zip
Fix -jX builds; cleanup Makefile and pkg-descr; sort pkg-plist; pet portlint(1).
Diffstat (limited to 'converters/trans')
-rw-r--r--converters/trans/Makefile47
-rw-r--r--converters/trans/pkg-descr14
-rw-r--r--converters/trans/pkg-plist80
3 files changed, 70 insertions, 71 deletions
diff --git a/converters/trans/Makefile b/converters/trans/Makefile
index bd97511ae900..b33caeebffc6 100644
--- a/converters/trans/Makefile
+++ b/converters/trans/Makefile
@@ -1,41 +1,46 @@
-# Created by: ache
+# Created by: Andrey A. Chernov <ache@FreeBSD.org>
# $FreeBSD$
PORTNAME= trans
PORTVERSION= 1.20
-CATEGORIES= converters russian
+CATEGORIES= converters
MASTER_SITES= http://www.kostis.net/freeware/
-DISTNAME= trans120
+DISTNAME= ${PORTNAME}${PORTVERSION:S/.//}
MAINTAINER= ports@FreeBSD.org
-COMMENT= Character Encoding Converter Generator Package
-
-MAKE_JOBS_UNSAFE= yes
+COMMENT= Character encoding converter generator
LIBDIR= ${PREFIX}/lib/trans
-ALL= transhtm transiso transce8 transtab checkiso checkuni
+MAN1= transhtm.1 transiso.1 transce8.1 transtab.1 checkiso.1 \
+ checkuni.1
+
+post-patch:
+# Fix the build against arbitrary make(1) implementation
+ @${REINPLACE_CMD} -e 's/cd src ; make/$$(MAKE) -C src/' \
+ ${WRKSRC}/Makefile
+# Unbreak parallel builds (-jX): fix targets' dependencies
+ @${REINPLACE_CMD} -e 's/loadtab\$$(OBJ)$$/$$(OBJLIB)/' \
+ ${WRKSRC}/src/Makefile
do-install:
- cd ${WRKSRC}/src && $(INSTALL_PROGRAM) $(ALL) ${PREFIX}/bin
- cd ${WRKSRC}/src && \
- for i in $(ALL); do \
- $(INSTALL_MAN) $$i.man ${PREFIX}/man/cat1/$$i.1; \
- done
- install -d -o ${BINOWN} -g ${BINGRP} -m 755 \
- ${LIBDIR}/cedf ${LIBDIR}/xlt ${LIBDIR}/doc ${LIBDIR}/bin \
+ cd ${WRKSRC}/src && ${INSTALL_PROGRAM} ${MAN1:R} ${PREFIX}/bin
+.for m in ${MAN1}
+ ${INSTALL_MAN} ${WRKSRC}/src/${m:R}.man ${MANPREFIX}/man/man1/${m}
+.endfor
+ @${MKDIR} ${LIBDIR}/cedf ${LIBDIR}/xlt ${LIBDIR}/doc ${LIBDIR}/bin \
${LIBDIR}/src
cd ${WRKSRC}/src && \
- $(INSTALL_SCRIPT) checkall chkuni mkhtml mklist mkxlt \
+ ${INSTALL_SCRIPT} checkall chkuni mkhtml mklist mkxlt \
${LIBDIR}/src
cd ${WRKSRC} && \
- $(INSTALL_DATA) README encoding.lis ${LIBDIR}
+ ${INSTALL_DATA} README encoding.lis ${LIBDIR}
cd ${WRKSRC}/src && \
- $(INSTALL_DATA) datatype.h ${LIBDIR}/src
+ ${INSTALL_DATA} datatype.h ${LIBDIR}/src
cd ${WRKSRC}/bin && \
- $(INSTALL_DATA) one trans.[ch] trans.man utimbuf.h utf.[ch] \
+ ${INSTALL_DATA} one trans.[ch] trans.man utimbuf.h utf.[ch] \
${LIBDIR}/bin
- cd ${WRKSRC}/cedf && $(INSTALL_DATA) * ${LIBDIR}/cedf
- cd ${WRKSRC}/doc && $(INSTALL_DATA) * ${LIBDIR}/doc
- cd ${WRKSRC}/xlt && $(INSTALL_DATA) * ${LIBDIR}/xlt
+ ${INSTALL_DATA} ${WRKSRC}/cedf/* ${LIBDIR}/cedf
+ ${INSTALL_DATA} ${WRKSRC}/doc/* ${LIBDIR}/doc
+ ${INSTALL_DATA} ${WRKSRC}/xlt/* ${LIBDIR}/xlt
.include <bsd.port.mk>
diff --git a/converters/trans/pkg-descr b/converters/trans/pkg-descr
index 26ee922086fc..478634c0790b 100644
--- a/converters/trans/pkg-descr
+++ b/converters/trans/pkg-descr
@@ -1,10 +1,10 @@
-trans - Character Encoding Converter Generator Package
+This is a character encoding converter generator package.
-Currently there are 72 different Character Encoding Description Files
+Currently there are 72 different character encoding description files
supplied with this package, not counting the 13 *.net files, which are
-modified Character Encoding Description Files. All but 13 of the above
-mentioned files describe 8-bit Character Encodings/Sets.
+modified character encoding description files. All but 13 of the above
+mentioned files describe 8-bit character encodings/sets.
-It covers ISO 646, many IBM Codepages for MS-DOS, Microsoft Windows
-Codepages, ISO 8859-x, HP, Adobe, Apple Macintosh, Atari, NeXTSTEP
-Character Encodings, a few EBCDIC Encodings, koi8-r and a few more...
+It covers ISO 646, many IBM codepages for MS-DOS, Microsoft Windows
+codepages, ISO 8859-x, HP, Adobe, Apple Macintosh, Atari, NeXTSTEP
+character encodings, a few EBCDIC encodings, KOI8-R, and a few more.
diff --git a/converters/trans/pkg-plist b/converters/trans/pkg-plist
index ab6150fb18a0..2f497b4fb376 100644
--- a/converters/trans/pkg-plist
+++ b/converters/trans/pkg-plist
@@ -1,15 +1,17 @@
-bin/transtab
-bin/transiso
bin/checkiso
bin/checkuni
bin/transce8
bin/transhtm
-man/cat1/transtab.1
-man/cat1/transiso.1
-man/cat1/checkiso.1
-man/cat1/checkuni.1
-man/cat1/transce8.1
-man/cat1/transhtm.1
+bin/transiso
+bin/transtab
+lib/trans/README
+lib/trans/bin/one
+lib/trans/bin/trans.c
+lib/trans/bin/trans.h
+lib/trans/bin/trans.man
+lib/trans/bin/utf.c
+lib/trans/bin/utf.h
+lib/trans/bin/utimbuf.h
lib/trans/cedf/adobeiso
lib/trans/cedf/adobestd
lib/trans/cedf/adobesym
@@ -92,6 +94,33 @@ lib/trans/cedf/tex-dcr.in
lib/trans/cedf/tex-dcr.out
lib/trans/cedf/wingding
lib/trans/cedf/wingreek
+lib/trans/doc/adobe.inf
+lib/trans/doc/apple.inf
+lib/trans/doc/atari.inf
+lib/trans/doc/cpdos.inf
+lib/trans/doc/cpwin.inf
+lib/trans/doc/credits
+lib/trans/doc/dec.inf
+lib/trans/doc/ebcdic.inf
+lib/trans/doc/format
+lib/trans/doc/history
+lib/trans/doc/hp.inf
+lib/trans/doc/iso10646.inf
+lib/trans/doc/iso6429.inf
+lib/trans/doc/iso646.inf
+lib/trans/doc/iso8859.inf
+lib/trans/doc/nextstep.inf
+lib/trans/doc/other.inf
+lib/trans/doc/sources
+lib/trans/doc/todo
+lib/trans/doc/winother.inf
+lib/trans/encoding.lis
+lib/trans/src/checkall
+lib/trans/src/chkuni
+lib/trans/src/datatype.h
+lib/trans/src/mkhtml
+lib/trans/src/mklist
+lib/trans/src/mkxlt
lib/trans/xlt/adobeiso
lib/trans/xlt/adobestd
lib/trans/xlt/adobesym
@@ -171,41 +200,6 @@ lib/trans/xlt/tex-dcr.in
lib/trans/xlt/tex-dcr.out
lib/trans/xlt/wingding
lib/trans/xlt/wingreek
-lib/trans/doc/adobe.inf
-lib/trans/doc/apple.inf
-lib/trans/doc/atari.inf
-lib/trans/doc/cpdos.inf
-lib/trans/doc/cpwin.inf
-lib/trans/doc/credits
-lib/trans/doc/dec.inf
-lib/trans/doc/ebcdic.inf
-lib/trans/doc/format
-lib/trans/doc/history
-lib/trans/doc/hp.inf
-lib/trans/doc/iso10646.inf
-lib/trans/doc/iso6429.inf
-lib/trans/doc/iso646.inf
-lib/trans/doc/iso8859.inf
-lib/trans/doc/nextstep.inf
-lib/trans/doc/other.inf
-lib/trans/doc/sources
-lib/trans/doc/todo
-lib/trans/doc/winother.inf
-lib/trans/bin/one
-lib/trans/bin/trans.c
-lib/trans/bin/trans.h
-lib/trans/bin/trans.man
-lib/trans/bin/utimbuf.h
-lib/trans/bin/utf.c
-lib/trans/bin/utf.h
-lib/trans/src/checkall
-lib/trans/src/chkuni
-lib/trans/src/mkhtml
-lib/trans/src/mklist
-lib/trans/src/mkxlt
-lib/trans/src/datatype.h
-lib/trans/README
-lib/trans/encoding.lis
@dirrm lib/trans/bin
@dirrm lib/trans/cedf
@dirrm lib/trans/doc