aboutsummaryrefslogtreecommitdiffstats
path: root/converters
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2014-04-23 09:15:52 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2014-04-23 09:15:52 +0800
commit55a91f245adfc19ef7b45e993fc141b886dabe41 (patch)
tree637704a88c1fb101f226a0c75dbdb58ac589daa1 /converters
parent4051c34a154fe11b3cb09d1e8dc5ebc44ec5f7b6 (diff)
downloadfreebsd-ports-gnome-55a91f245adfc19ef7b45e993fc141b886dabe41.tar.gz
freebsd-ports-gnome-55a91f245adfc19ef7b45e993fc141b886dabe41.tar.zst
freebsd-ports-gnome-55a91f245adfc19ef7b45e993fc141b886dabe41.zip
- Minor port cleanup
- Add LICENSE - Fix error handling PR: 187757 Submitted by: KATO Tsuguru <tkato432@yahoo.com>
Diffstat (limited to 'converters')
-rw-r--r--converters/ytnef/Makefile17
-rw-r--r--converters/ytnef/files/patch-src__ytnef__main.c14
-rw-r--r--converters/ytnef/pkg-descr19
3 files changed, 33 insertions, 17 deletions
diff --git a/converters/ytnef/Makefile b/converters/ytnef/Makefile
index 517c0d4f8d59..53da92046743 100644
--- a/converters/ytnef/Makefile
+++ b/converters/ytnef/Makefile
@@ -3,31 +3,34 @@
PORTNAME= ytnef
PORTVERSION= 2.6
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= converters mail
MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
COMMENT= Unpack data in MS Outlook TNEF format
-OPTIONS_DEFINE= DOCS
+LICENSE= GPLv2
LIB_DEPENDS= libytnef.so:${PORTSDIR}/devel/libytnef
RUN_DEPENDS= p5-MIME-Tools>=0:${PORTSDIR}/mail/p5-MIME-Tools
-USES= perl5
+USES= perl5 shebangfix
+SHEBANG_FILES= src/ytnef/*.pl
USE_PERL5= run
GNU_CONFIGURE= yes
-CFLAGS+= -I${LOCALBASE}/include
+CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-PLIST_FILES= bin/ytnef bin/ytnefprocess.pl bin/ytnefprint
PORTDOCS= AUTHORS NEWS README
+PLIST_FILES= bin/ytnef bin/ytnefprint bin/ytnefprocess.pl
+
+OPTIONS_DEFINE= DOCS
post-patch:
- @${REINPLACE_CMD} -e 's|^#!/usr/bin/perl|#!${PERL}|' \
- ${WRKSRC}/src/ytnef/ytnefprocess.pl
+ @${REINPLACE_CMD} -e 's|/usr/local/share|${PREFIX}/share|' \
+ ${WRKSRC}/src/ytnef/*.pl
post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
diff --git a/converters/ytnef/files/patch-src__ytnef__main.c b/converters/ytnef/files/patch-src__ytnef__main.c
index b48b6b4a2904..f743542d9d18 100644
--- a/converters/ytnef/files/patch-src__ytnef__main.c
+++ b/converters/ytnef/files/patch-src__ytnef__main.c
@@ -9,3 +9,17 @@
case 'f': savefiles = 1;
filepath = argv[i+1];
i++;
+@@ -103,11 +103,12 @@
+ TNEF.Debug = verbose;
+ if (TNEFParseFile(argv[i], &TNEF) == -1) {
+ printf("ERROR processing file\n");
+- continue;
++ return 1;
+ }
+ ProcessTNEF(TNEF);
+ TNEFFree(&TNEF);
+ }
++ return 0;
+ }
+
+ void ProcessTNEF(TNEFStruct TNEF) {
diff --git a/converters/ytnef/pkg-descr b/converters/ytnef/pkg-descr
index 424fc02ae859..79ca18bd5228 100644
--- a/converters/ytnef/pkg-descr
+++ b/converters/ytnef/pkg-descr
@@ -1,15 +1,14 @@
-This program decodes those annoying application/ms-tnef MIME attachments that
-Microsoft mail servers helpfully use to encapsulate your already MIME encoded
-attachments.
+This program decodes those annoying application/ms-tnef MIME
+attachments that Microsoft mail servers helpfully use to encapsulate
+your already MIME encoded attachments.
-Due to the proliferation of Microsoft Outlook and Exchange mail servers,
-more and more mail is encapsulated into this format.
+Due to the proliferation of Microsoft Outlook and Exchange mail
+servers, more and more mail is encapsulated into this format.
-The YTNEF program allows one to unpack the attachments which were encapsulated
-into the YTNEF attachment. Thus alleviating the need to use Microsoft Outlook
-to view them.
+The YTNEF program allows one to unpack the attachments which were
+encapsulated into the YTNEF attachment. Thus alleviating the need to
+use Microsoft Outlook to view them.
Now supports winmail.dat Outlook files
-Author: Randall Hand <randall.hand@gmail.com>
-WWW: http://ytnef.sourceforge.net/
+WWW: http://ytnef.sourceforge.net/