aboutsummaryrefslogtreecommitdiffstats
path: root/converters
diff options
context:
space:
mode:
authorak <ak@FreeBSD.org>2012-06-19 03:25:44 +0800
committerak <ak@FreeBSD.org>2012-06-19 03:25:44 +0800
commitb78f8c80cc5a553e01d7ba4dbecbc1399d65c4d4 (patch)
tree6ae89896678cbb19e9f8f7ec2f689ee3b1ad3a65 /converters
parent2706fbb5b566b54dca865e24a50ab2ba5e1cce4c (diff)
downloadfreebsd-ports-gnome-b78f8c80cc5a553e01d7ba4dbecbc1399d65c4d4.tar.gz
freebsd-ports-gnome-b78f8c80cc5a553e01d7ba4dbecbc1399d65c4d4.tar.zst
freebsd-ports-gnome-b78f8c80cc5a553e01d7ba4dbecbc1399d65c4d4.zip
BibTeXConv is a BibTeX file converter which allows one to export
BibTeX entries to other formats, including customly defined text output. Furthermore, it provides the possibility to check URLs (including MD5, size and MIME type computations) and to verify ISBN and ISSN numbers. PR: ports/168627 Submitted by: Thomas Dreibholz <dreibh@iem.uni-due.de> Approved by: eadler, itetcu (mentors, implicit)
Diffstat (limited to 'converters')
-rw-r--r--converters/Makefile1
-rw-r--r--converters/bibtexconv/Makefile42
-rw-r--r--converters/bibtexconv/distinfo2
-rw-r--r--converters/bibtexconv/pkg-descr7
4 files changed, 52 insertions, 0 deletions
diff --git a/converters/Makefile b/converters/Makefile
index 74f5fa7aebd3..b9468594307d 100644
--- a/converters/Makefile
+++ b/converters/Makefile
@@ -9,6 +9,7 @@
SUBDIR += ascii2binary
SUBDIR += asr10
SUBDIR += base64
+ SUBDIR += bibtexconv
SUBDIR += bsdconv
SUBDIR += btoa
SUBDIR += chmview
diff --git a/converters/bibtexconv/Makefile b/converters/bibtexconv/Makefile
new file mode 100644
index 000000000000..acef489d5570
--- /dev/null
+++ b/converters/bibtexconv/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: bibtexconv
+# Date created: 2012-06-07
+# Whom: Thomas Dreibholz <dreibh@iem.uni-due.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= bibtexconv
+PORTVERSION= 0.8.20
+CATEGORIES= converters
+MASTER_SITES= http://www.iem.uni-due.de/~dreibh/bibtexconv/download/ \
+ http://www.exp-math.uni-essen.de/~dreibh/bibtexconv/download/
+
+MAINTAINER= dreibh@iem.uni-due.de
+COMMENT= BibTeX Converter
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= curl:${PORTSDIR}/ftp/curl
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+
+PLIST_FILES= bin/bibtexconv bin/bibtexconv-odt
+PORTEXAMPLES= ExampleReferences.bib ODT-Template.odt odt-example.export \
+ web-example.export text-example.export
+MAN1= bibtexconv.1 bibtexconv-odt.1
+
+pre-configure:
+ @${REINPLACE_CMD} -e 's|install-data-am: install-dist_examplesDATA|install-data-am:|' \
+ ${WRKSRC}/src/Makefile.in
+
+post-install:
+.if !defined(NOPORTEXAMPLES)
+ ${MKDIR} ${EXAMPLESDIR}
+.for f in ${PORTEXAMPLES}
+ ${INSTALL_DATA} ${WRKSRC}/src/${f} ${EXAMPLESDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/converters/bibtexconv/distinfo b/converters/bibtexconv/distinfo
new file mode 100644
index 000000000000..ea4a9fc9c6d6
--- /dev/null
+++ b/converters/bibtexconv/distinfo
@@ -0,0 +1,2 @@
+SHA256 (bibtexconv-0.8.20.tar.gz) = e15a31431b4f7a16bd21a7e87f500cf1f164539850c6546d8d80a1978cc9e891
+SIZE (bibtexconv-0.8.20.tar.gz) = 431972
diff --git a/converters/bibtexconv/pkg-descr b/converters/bibtexconv/pkg-descr
new file mode 100644
index 000000000000..59e5012714f9
--- /dev/null
+++ b/converters/bibtexconv/pkg-descr
@@ -0,0 +1,7 @@
+BibTeXConv is a BibTeX file converter which allows one to export
+BibTeX entries to other formats, including customly defined
+text output. Furthermore, it provides the possibility to
+check URLs (including MD5, size and MIME type computations)
+and to verify ISBN and ISSN numbers.
+
+WWW: http://www.iem.uni-due.de/~dreibh/bibtexconv/