aboutsummaryrefslogtreecommitdiffstats
path: root/databases/animenfo-client-gtk
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2006-11-03 04:35:48 +0800
committerdinoex <dinoex@FreeBSD.org>2006-11-03 04:35:48 +0800
commit020e0d19ade6bd00eaa532602994fa3671a0e5a6 (patch)
tree3c174540db883e6276fec02b8113530f47be309c /databases/animenfo-client-gtk
parent0490a5a6d2adf039351ad94b96dca4d99013585c (diff)
downloadfreebsd-ports-gnome-020e0d19ade6bd00eaa532602994fa3671a0e5a6.tar.gz
freebsd-ports-gnome-020e0d19ade6bd00eaa532602994fa3671a0e5a6.tar.zst
freebsd-ports-gnome-020e0d19ade6bd00eaa532602994fa3671a0e5a6.zip
The AnimeNfo client with GTK support.
configuration.txt contains the configuration for server and port. It will be read automatically by the program at beginning of execution, so you don't have to fill the server and port value every time manually. You can modify the configuration.txt file if necessary. In order for the configuration.txt to work, you have to put it in the same directory as the program.
Diffstat (limited to 'databases/animenfo-client-gtk')
-rw-r--r--databases/animenfo-client-gtk/Makefile30
-rw-r--r--databases/animenfo-client-gtk/distinfo3
-rw-r--r--databases/animenfo-client-gtk/files/patch-socket.c10
-rw-r--r--databases/animenfo-client-gtk/pkg-descr8
4 files changed, 51 insertions, 0 deletions
diff --git a/databases/animenfo-client-gtk/Makefile b/databases/animenfo-client-gtk/Makefile
new file mode 100644
index 000000000000..a738ce05262e
--- /dev/null
+++ b/databases/animenfo-client-gtk/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: animenfo-client
+# Date created: 3rd August 2001
+# Whom: dirk.meyer@dinoex.sub.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= animenfo
+PORTVERSION= 20020819
+CATEGORIES= databases
+MASTER_SITES= http://www.animenfo.com/extension/files/
+PKGNAMESUFFIX= -client-gui-gtk
+DISTNAME= ${PORTNAME}${PKGNAMESUFFIX}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= dinoex@FreeBSD.org
+COMMENT= AnimeNfo client with GTK support
+
+USE_GMAKE= yes
+USE_GETTEXT= yes
+USE_GNOME= gtk20
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= PATH_GTKCONFIG="${GTK_CONFIG}" CFLAGS="${CFLAGS}" \
+ CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+CPPFLAGS+= ${PTHREAD_CFLAGS} -I${LOCALBASE}/include
+CFLAGS+= ${CPPFLAGS}
+LDFLAGS+= -L${LOCALBASE}/lib
+PLIST_FILES= bin/animenfo-client-gtk
+
+.include <bsd.port.mk>
diff --git a/databases/animenfo-client-gtk/distinfo b/databases/animenfo-client-gtk/distinfo
new file mode 100644
index 000000000000..4d4456c5c0c9
--- /dev/null
+++ b/databases/animenfo-client-gtk/distinfo
@@ -0,0 +1,3 @@
+MD5 (animenfo-client-gui-gtk.tgz) = 8037fd21dd42e524ad47ef3442076d95
+SHA256 (animenfo-client-gui-gtk.tgz) = fba135678b1bf02392a4778608cc9407ae59b316c7b15a524a64be1a76137f67
+SIZE (animenfo-client-gui-gtk.tgz) = 62379
diff --git a/databases/animenfo-client-gtk/files/patch-socket.c b/databases/animenfo-client-gtk/files/patch-socket.c
new file mode 100644
index 000000000000..fb1c5d858e6a
--- /dev/null
+++ b/databases/animenfo-client-gtk/files/patch-socket.c
@@ -0,0 +1,10 @@
+--- src/socket.c.orig Fri Aug 16 03:54:46 2002
++++ src/socket.c Sun May 23 10:28:29 2004
+@@ -5,6 +5,7 @@
+ #include <sys/socket.h>
+ #include <errno.h>
+ #include <fcntl.h>
++#include <sys/time.h>
+
+ #include "socket.h"
+ #include "definition.h"
diff --git a/databases/animenfo-client-gtk/pkg-descr b/databases/animenfo-client-gtk/pkg-descr
new file mode 100644
index 000000000000..6ba898eaef3b
--- /dev/null
+++ b/databases/animenfo-client-gtk/pkg-descr
@@ -0,0 +1,8 @@
+The AnimeNfo client with GTK support.
+
+configuration.txt contains the configuration for server and port.
+It will be read automatically by the program at beginning of execution,
+so you don't have to fill the server and port value every time manually.
+You can modify the configuration.txt file if necessary.
+In order for the configuration.txt to work,
+you have to put it in the same directory as the program.