aboutsummaryrefslogtreecommitdiffstats
path: root/databases/db42/Makefile
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2000-09-23 00:48:51 +0800
committersobomax <sobomax@FreeBSD.org>2000-09-23 00:48:51 +0800
commit3b611480fb8fabd946b2e499b5654d481962ae2f (patch)
tree964b4f89876380f932305330e22493397c140e84 /databases/db42/Makefile
parent62feb31518186ced98b68058e2008e16c14d339e (diff)
downloadfreebsd-ports-gnome-3b611480fb8fabd946b2e499b5654d481962ae2f.tar.gz
freebsd-ports-gnome-3b611480fb8fabd946b2e499b5654d481962ae2f.tar.zst
freebsd-ports-gnome-3b611480fb8fabd946b2e499b5654d481962ae2f.zip
Several cleanups:
- properly install shared library (still needs more work); - use pthreads; - use libtool. PR: 21470 (partially) Submitted by: maintainer
Diffstat (limited to 'databases/db42/Makefile')
-rw-r--r--databases/db42/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/databases/db42/Makefile b/databases/db42/Makefile
index ec9f123c3f2a..72a85bd88964 100644
--- a/databases/db42/Makefile
+++ b/databases/db42/Makefile
@@ -19,13 +19,17 @@ MANUAL_PACKAGE_BUILD= incompatible with libc internal db calls
WRKSRC= ${WRKDIR}/${DISTNAME}/build_unix
INSTALLS_SHLIB= yes
-GNU_CONFIGURE= yes
+USE_LIBTOOL= yes
CONFIGURE_SCRIPT= ../dist/configure
+LIBTOOLFILES= ${CONFIGURE_SCRIPT}
CONFIGURE_ARGS= --enable-compat185 \
--enable-dump185 --enable-cxx \
--enable-dynamic \
--prefix=${PREFIX} \
- --includedir=${PREFIX}/include/db3
-CONFIGURE_TARGET= $(ARCH)-unknown-freebsd$(OSREL)
+ --includedir=${PREFIX}/include/db3 \
+ --target=$(ARCH)-unknown-freebsd$(OSREL)
+
+pre-patch:
+ @${PERL} -pi -e 's|-lpthread|-pthread|g' ${WRKSRC}/${CONFIGURE_SCRIPT}
.include <bsd.port.mk>