aboutsummaryrefslogtreecommitdiffstats
path: root/databases/emma/Makefile
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2006-12-03 03:41:38 +0800
committerpav <pav@FreeBSD.org>2006-12-03 03:41:38 +0800
commit2ce2947d9898f4497e10ff90f4859c0397efeb5e (patch)
treed6bee902b57fbbd768eb3aee02ae5547dbdc9450 /databases/emma/Makefile
parentfd5c7a1bb72b6e5ad4d3138c00fd71d5bc1c164a (diff)
downloadfreebsd-ports-gnome-2ce2947d9898f4497e10ff90f4859c0397efeb5e.tar.gz
freebsd-ports-gnome-2ce2947d9898f4497e10ff90f4859c0397efeb5e.tar.zst
freebsd-ports-gnome-2ce2947d9898f4497e10ff90f4859c0397efeb5e.zip
Emma is a graphical toolkit for MySQL database developers and administrators.
It provides dialogs to create or modify MySQL databases, tables and associated indexes. It has a built-in syntax highlighting SQL editor with table- and fieldname tab-completion and automatic SQL statement formatting. The results of an executed query are displayed in a resultset where the record- data can be edited by the user, if the SQL statement allows for it. The SQL editor and resultset-view are grouped in tabs. Results can be exported to CSV files. Multiple simultaneously opened MySQL connections are possible. WWW: http://www.fastflo.de/projects/emma PR: ports/106229 Submitted by: Junji NAKANISHI <jun-g@daemonfreaks.com>
Diffstat (limited to 'databases/emma/Makefile')
-rw-r--r--databases/emma/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/databases/emma/Makefile b/databases/emma/Makefile
new file mode 100644
index 000000000000..f3c444cb4a09
--- /dev/null
+++ b/databases/emma/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: emma
+# Date created: 2 December 2006
+# Whom: Junji NAKANISHI <jun-g@daemonfreaks.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= emma
+PORTVERSION= 0.6
+CATEGORIES= databases
+MASTER_SITES= http://www.fastflo.de/files/emma/downloads/python_src/
+
+MAINTAINER= jun-g@daemonfreaks.com
+COMMENT= Extendable MySQL managing assistant
+
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/MySQLdb/__init__.py:${PORTSDIR}/databases/py-MySQLdb
+
+USE_GNOME= pygtk2
+USE_PYTHON= yes
+USE_PYDISTUTILS=yes
+
+pre-patch:
+ @${REINPLACE_CMD} -e 's|python2.4|env python|' ${WRKSRC}/emma
+
+.include <bsd.port.mk>