aboutsummaryrefslogtreecommitdiffstats
path: root/databases/freetds
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2004-07-10 01:43:11 +0800
committermarcus <marcus@FreeBSD.org>2004-07-10 01:43:11 +0800
commit5cc9328814fb9b8e64ff3588af7e6031c1d3514b (patch)
treedf0b6bb8e4e84920da9881d421090dc67f70c629 /databases/freetds
parente058c31decaf84a24b7ab7306f65221b33ada080 (diff)
downloadfreebsd-ports-gnome-5cc9328814fb9b8e64ff3588af7e6031c1d3514b.tar.gz
freebsd-ports-gnome-5cc9328814fb9b8e64ff3588af7e6031c1d3514b.tar.zst
freebsd-ports-gnome-5cc9328814fb9b8e64ff3588af7e6031c1d3514b.zip
Apply a big libtool patch to allow porters to use the libtool installed by
the libtoolX ports instead of the one included with each port. Ports that set USE_LIBTOOL_VER=X will now use the ports version of libtool instead of the included version. To restore previous behavior, use the new macro, USE_INC_LIBTOOL_VER. Both macros accept the same argument: a libtool version. For example, to use the ports version of libtool-1.5, add the following to your Makefile: USE_LIBTOOL_VER= 15 To use the included version of libtool with extra hacks provided by libtool-1.5, add the following to your Makefile: USE_INC_LIBTOOL_VER= 15 With this change, ports that had to add additional libtool hacks to prevent .la files from being installed or to fix certain threading issues can now delete those hacks (after appropriate testing, of course). PR: 63944 Based on work by:eik and marcus Approved by: ade (autotools maintainer) Tested by: kris on pointyhat Bound to be hidden problems: You bet
Diffstat (limited to 'databases/freetds')
-rw-r--r--databases/freetds/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/databases/freetds/Makefile b/databases/freetds/Makefile
index 600fc09ef212..53635a8c1eb0 100644
--- a/databases/freetds/Makefile
+++ b/databases/freetds/Makefile
@@ -17,7 +17,7 @@ USE_ICONV= yes
USE_REINPLACE= yes
USE_GMAKE= yes
GNU_GONFIGURE= yes
-USE_LIBTOOL_VER= 13
+USE_INC_LIBTOOL_VER= 13
WANT_AUTOCONF_VER= 259
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"