aboutsummaryrefslogtreecommitdiffstats
path: root/databases/gdl2
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2006-09-17 14:15:54 +0800
committerDirk Meyer <dinoex@FreeBSD.org>2006-09-17 14:15:54 +0800
commit4b3480a11ad53709c584a0bd4fda993e58e91bfd (patch)
tree37e37ae07345774342977ba65544e7e683b3b2b5 /databases/gdl2
parentb4dee0b99fcbb9c9c9aa51a450487c837b3c57ae (diff)
downloadfreebsd-ports-gnome-4b3480a11ad53709c584a0bd4fda993e58e91bfd.tar.gz
freebsd-ports-gnome-4b3480a11ad53709c584a0bd4fda993e58e91bfd.tar.zst
freebsd-ports-gnome-4b3480a11ad53709c584a0bd4fda993e58e91bfd.zip
The GNUstep Database Library 2 (GDL2) is a set of libraries to map
Objective-C objects to rows of relational database management systems (RDBMS). It aims to be compatible with Enterprise Objects Framework (EOF) as released with WebObjects 4.5 from Apple Inc. This port also provides the GNUstep DBModeler and a Gorm GDL2 Palette. PR: 103294 Submitted by: Gürkan Sengün Reviewed by: alexbl
Diffstat (limited to 'databases/gdl2')
-rw-r--r--databases/gdl2/Makefile35
-rw-r--r--databases/gdl2/distinfo3
-rw-r--r--databases/gdl2/pkg-descr10
-rw-r--r--databases/gdl2/pkg-plist170
4 files changed, 218 insertions, 0 deletions
diff --git a/databases/gdl2/Makefile b/databases/gdl2/Makefile
new file mode 100644
index 000000000000..213dcf063677
--- /dev/null
+++ b/databases/gdl2/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: gdl2
+# Date created: 12 Sep 2006
+# Whom: gurkan@linuks.mine.nu
+#
+# $FreeBSD$
+#
+
+PORTNAME= gdl2
+PORTVERSION= 0.10.1
+CATEGORIES= databases
+MASTER_SITES= ${MASTER_SITE_GNUSTEP}
+MASTER_SITE_SUBDIR= libs
+DISTNAME= gnustep-dl2-${PORTVERSION}
+
+MAINTAINER= gurkan@linuks.mine.nu
+COMMENT= GNUstep Database Library 2 (Enterprise Objects Framework)
+
+WRKSRC= ${WRKDIR}/${DISTNAME}
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_GNUSTEP= yes
+USE_GNUSTEP_PREFIX= yes
+USE_GNUSTEP_BASE= yes
+USE_GNUSTEP_CONFIGURE= yes
+USE_GNUSTEP_BUILD= yes
+USE_GNUSTEP_INSTALL= yes
+USE_GNUSTEP_SYSTEM_LIBS+= Gorm:${GORM_PORT}
+# broken
+# USE_LDCONFIG= yes
+INSTALL_SHLIBS= yes
+MAKEFILE= GNUmakefile
+SLIDESHOWKIT_PORT?= devel/gorm
+USE_PGSQL= yes
+
+.include <bsd.port.mk>
diff --git a/databases/gdl2/distinfo b/databases/gdl2/distinfo
new file mode 100644
index 000000000000..f1a022cccdae
--- /dev/null
+++ b/databases/gdl2/distinfo
@@ -0,0 +1,3 @@
+MD5 (gnustep-dl2-0.10.1.tar.gz) = 59ce3b8407cfdc6d25901e97e17c9cc5
+SHA256 (gnustep-dl2-0.10.1.tar.gz) = e4b93e9680477ca4e8402048dcbaaa09fba841971ca2511f4781250a903e04d7
+SIZE (gnustep-dl2-0.10.1.tar.gz) = 594995
diff --git a/databases/gdl2/pkg-descr b/databases/gdl2/pkg-descr
new file mode 100644
index 000000000000..181298daa407
--- /dev/null
+++ b/databases/gdl2/pkg-descr
@@ -0,0 +1,10 @@
+The GNUstep Database Library 2 (GDL2) is a set of libraries to map
+Objective-C objects to rows of relational database management systems
+(RDBMS). It aims to be compatible with Enterprise Objects Framework (EOF)
+as released with WebObjects 4.5 from Apple Inc.
+
+This port also provides the GNUstep DBModeler and a Gorm GDL2 Palette.
+
+WWW: http://www.gnustep.org/experience/GDL2.html
+
+gurkan@linuks.mine.nu
diff --git a/databases/gdl2/pkg-plist b/databases/gdl2/pkg-plist
new file mode 100644
index 000000000000..f9bfb327fc7b
--- /dev/null
+++ b/databases/gdl2/pkg-plist
@@ -0,0 +1,170 @@
+Local/Library/Frameworks/Postgres95EOAdaptor.framework/Headers
+Local/Library/Frameworks/Postgres95EOAdaptor.framework/Resources
+Local/Library/Frameworks/Postgres95EOAdaptor.framework/Versions/A/Headers/Postgres95Adaptor.h
+Local/Library/Frameworks/Postgres95EOAdaptor.framework/Versions/A/Headers/Postgres95Channel.h
+Local/Library/Frameworks/Postgres95EOAdaptor.framework/Versions/A/Headers/Postgres95Context.h
+Local/Library/Frameworks/Postgres95EOAdaptor.framework/Versions/A/Headers/Postgres95SQLExpression.h
+Local/Library/Frameworks/Postgres95EOAdaptor.framework/Versions/A/Headers/Postgres95Values.h
+Local/Library/Frameworks/Postgres95EOAdaptor.framework/Versions/A/Postgres95EOAdaptor
+Local/Library/Frameworks/Postgres95EOAdaptor.framework/Versions/A/Resources/Info-gnustep.plist
+Local/Library/Frameworks/Postgres95EOAdaptor.framework/Versions/A/Resources/LoginPanel.bundle/LoginPanel
+Local/Library/Frameworks/Postgres95EOAdaptor.framework/Versions/A/Resources/LoginPanel.bundle/Resources/Info-gnustep.plist
+Local/Library/Frameworks/Postgres95EOAdaptor.framework/Versions/A/Resources/LoginPanel.bundle/Resources/postgreslogo.tif
+Local/Library/Frameworks/Postgres95EOAdaptor.framework/Versions/A/Resources/LoginPanel.bundle/stamp.make
+Local/Library/Frameworks/Postgres95EOAdaptor.framework/Versions/A/libPostgres95EOAdaptor.so
+Local/Library/Frameworks/Postgres95EOAdaptor.framework/Versions/A/libPostgres95EOAdaptor.so.%%MAJORVERSION%%
+Local/Library/Frameworks/Postgres95EOAdaptor.framework/Versions/A/libPostgres95EOAdaptor.so.%%VERSION%%
+Local/Library/Frameworks/Postgres95EOAdaptor.framework/Versions/Current
+Local/Library/Headers/Postgres95EOAdaptor
+Local/Library/Libraries/libPostgres95EOAdaptor.so
+Local/Library/Libraries/libPostgres95EOAdaptor.so.%%MAJORVERSION%%
+Local/Library/Libraries/libPostgres95EOAdaptor.so.%%VERSION%%
+System/Applications/DBModeler.app/DBModeler
+System/Applications/DBModeler.app/Resources/AttributeInspector.gorm/data.classes
+System/Applications/DBModeler.app/Resources/AttributeInspector.gorm/data.info
+System/Applications/DBModeler.app/Resources/AttributeInspector.gorm/objects.gorm
+System/Applications/DBModeler.app/Resources/ClassProperty_Header.tiff
+System/Applications/DBModeler.app/Resources/ClassProperty_On.tiff
+System/Applications/DBModeler.app/Resources/ConsistencyResults.gorm/data.classes
+System/Applications/DBModeler.app/Resources/ConsistencyResults.gorm/data.info
+System/Applications/DBModeler.app/Resources/ConsistencyResults.gorm/objects.gorm
+System/Applications/DBModeler.app/Resources/DBModeler.desktop
+System/Applications/DBModeler.app/Resources/DBModeler.tiff
+System/Applications/DBModeler.app/Resources/Info-gnustep.plist
+System/Applications/DBModeler.app/Resources/Key_Header.tiff
+System/Applications/DBModeler.app/Resources/Key_On.tiff
+System/Applications/DBModeler.app/Resources/Locking_Header.tiff
+System/Applications/DBModeler.app/Resources/Locking_On.tiff
+System/Applications/DBModeler.app/Resources/ModelDrag.tiff
+System/Applications/DBModeler.app/Resources/Preferences.gorm/data.classes
+System/Applications/DBModeler.app/Resources/Preferences.gorm/data.info
+System/Applications/DBModeler.app/Resources/Preferences.gorm/objects.gorm
+System/Applications/DBModeler.app/Resources/RelationshipInspector.gorm/data.classes
+System/Applications/DBModeler.app/Resources/RelationshipInspector.gorm/data.info
+System/Applications/DBModeler.app/Resources/RelationshipInspector.gorm/objects.gorm
+System/Applications/DBModeler.app/Resources/RelationshipInspector.tiff
+System/Applications/DBModeler.app/Resources/SQLGenerator.gorm/data.classes
+System/Applications/DBModeler.app/Resources/SQLGenerator.gorm/data.info
+System/Applications/DBModeler.app/Resources/SQLGenerator.gorm/objects.gorm
+System/Applications/DBModeler.app/library_paths.openapp
+System/Applications/DBModeler.app/stamp.make
+System/Library/ApplicationSupport/Palettes/GDL2.palette/GDL2
+System/Library/ApplicationSupport/Palettes/GDL2.palette/Resources/GDL2ConnectionInspector.gorm/data.classes
+System/Library/ApplicationSupport/Palettes/GDL2.palette/Resources/GDL2ConnectionInspector.gorm/data.info
+System/Library/ApplicationSupport/Palettes/GDL2.palette/Resources/GDL2ConnectionInspector.gorm/objects.gorm
+System/Library/ApplicationSupport/Palettes/GDL2.palette/Resources/GDL2Palette.tiff
+System/Library/ApplicationSupport/Palettes/GDL2.palette/Resources/Info-gnustep.plist
+System/Library/ApplicationSupport/Palettes/GDL2.palette/Resources/palette.table
+System/Library/Headers/EOAccess/EOAccess.h
+System/Library/Headers/EOAccess/EOAccessFault.h
+System/Library/Headers/EOAccess/EOAdaptor.h
+System/Library/Headers/EOAccess/EOAdaptorChannel.h
+System/Library/Headers/EOAccess/EOAdaptorContext.h
+System/Library/Headers/EOAccess/EOAttribute.h
+System/Library/Headers/EOAccess/EODatabase.h
+System/Library/Headers/EOAccess/EODatabaseChannel.h
+System/Library/Headers/EOAccess/EODatabaseContext.h
+System/Library/Headers/EOAccess/EODatabaseDataSource.h
+System/Library/Headers/EOAccess/EODatabaseOperation.h
+System/Library/Headers/EOAccess/EODefines.h
+System/Library/Headers/EOAccess/EODeprecated.h
+System/Library/Headers/EOAccess/EOEntity.h
+System/Library/Headers/EOAccess/EOJoin.h
+System/Library/Headers/EOAccess/EOModel.h
+System/Library/Headers/EOAccess/EOModelGroup.h
+System/Library/Headers/EOAccess/EOPropertyListEncoding.h
+System/Library/Headers/EOAccess/EORelationship.h
+System/Library/Headers/EOAccess/EOSQLExpression.h
+System/Library/Headers/EOAccess/EOSQLQualifier.h
+System/Library/Headers/EOAccess/EOSchemaGeneration.h
+System/Library/Headers/EOAccess/EOStoredProcedure.h
+System/Library/Headers/EOAccess/EOUtilities.h
+System/Library/Headers/EOControl/EOArrayDataSource.h
+System/Library/Headers/EOControl/EOClassDescription.h
+System/Library/Headers/EOControl/EOControl.h
+System/Library/Headers/EOControl/EODataSource.h
+System/Library/Headers/EOControl/EODebug.h
+System/Library/Headers/EOControl/EODefines.h
+System/Library/Headers/EOControl/EODeprecated.h
+System/Library/Headers/EOControl/EODetailDataSource.h
+System/Library/Headers/EOControl/EOEditingContext.h
+System/Library/Headers/EOControl/EOEvent.h
+System/Library/Headers/EOControl/EOEventCenter.h
+System/Library/Headers/EOControl/EOFault.h
+System/Library/Headers/EOControl/EOFetchSpecification.h
+System/Library/Headers/EOControl/EOGenericRecord.h
+System/Library/Headers/EOControl/EOGlobalID.h
+System/Library/Headers/EOControl/EOKeyGlobalID.h
+System/Library/Headers/EOControl/EOKeyValueArchiver.h
+System/Library/Headers/EOControl/EOKeyValueCoding.h
+System/Library/Headers/EOControl/EOMultiReaderLock.h
+System/Library/Headers/EOControl/EONSAddOns.h
+System/Library/Headers/EOControl/EONull.h
+System/Library/Headers/EOControl/EOObjectStore.h
+System/Library/Headers/EOControl/EOObjectStoreCoordinator.h
+System/Library/Headers/EOControl/EOObserver.h
+System/Library/Headers/EOControl/EOQualifier.h
+System/Library/Headers/EOControl/EOSharedEditingContext.h
+System/Library/Headers/EOControl/EOSortOrdering.h
+System/Library/Headers/EOInterface/EOActionAssociation.h
+System/Library/Headers/EOInterface/EOActionInsertionAssociation.h
+System/Library/Headers/EOInterface/EOAspectConnector.h
+System/Library/Headers/EOInterface/EOAssociation.h
+System/Library/Headers/EOInterface/EOColumnAssociation.h
+System/Library/Headers/EOInterface/EOComboBoxAssociation.h
+System/Library/Headers/EOInterface/EOControlAssociation.h
+System/Library/Headers/EOInterface/EODetailSelectionAssociation.h
+System/Library/Headers/EOInterface/EODisplayGroup.h
+System/Library/Headers/EOInterface/EOInterface.h
+System/Library/Headers/EOInterface/EOMasterCopyAssociation.h
+System/Library/Headers/EOInterface/EOMasterDetailAssociation.h
+System/Library/Headers/EOInterface/EOMatrixAssociation.h
+System/Library/Headers/EOInterface/EOPickTextAssociation.h
+System/Library/Headers/EOInterface/EOPopUpAssociation.h
+System/Library/Headers/EOInterface/EORadioMatrixAssociation.h
+System/Library/Headers/EOInterface/EORecursiveBrowserAssociation.h
+System/Library/Headers/EOInterface/EOTextAssociation.h
+System/Library/Headers/EOModeler/EODefines.h
+System/Library/Headers/EOModeler/EOMInspector.h
+System/Library/Headers/EOModeler/EOMInspectorController.h
+System/Library/Headers/EOModeler/EOModelExtensions.h
+System/Library/Headers/EOModeler/EOModelerApp.h
+System/Library/Headers/EOModeler/EOModelerDocument.h
+System/Library/Headers/EOModeler/EOModelerEditor.h
+System/Library/Libraries/libEOInterface.so
+System/Library/Libraries/libEOInterface.so.%%MAJORVERSION%%
+System/Library/Libraries/libEOInterface.so.%%VERSION%%
+System/Library/Libraries/libgnustep-db2.so
+System/Library/Libraries/libgnustep-db2.so.%%MAJORVERSION%%
+System/Library/Libraries/libgnustep-db2.so.%%VERSION%%
+System/Library/Libraries/libgnustep-db2control.so
+System/Library/Libraries/libgnustep-db2control.so.%%MAJORVERSION%%
+System/Library/Libraries/libgnustep-db2control.so.%%VERSION%%
+System/Library/Libraries/libgnustep-db2modeler.so
+System/Library/Libraries/libgnustep-db2modeler.so.%%MAJORVERSION%%
+System/Library/Libraries/libgnustep-db2modeler.so.%%VERSION%%
+System/Library/Makefiles/Auxiliary/gdl2.make
+System/Tools/eoutil
+System/Tools/gdlgsdoc
+@dirrm System/Library/Headers/EOModeler
+@dirrm System/Library/Headers/EOInterface
+@dirrm System/Library/Headers/EOControl
+@dirrm System/Library/Headers/EOAccess
+@dirrm System/Library/ApplicationSupport/Palettes/GDL2.palette/Resources/GDL2ConnectionInspector.gorm
+@dirrm System/Library/ApplicationSupport/Palettes/GDL2.palette/Resources
+@dirrm System/Library/ApplicationSupport/Palettes/GDL2.palette
+@dirrm System/Library/ApplicationSupport/Palettes
+@dirrm System/Applications/DBModeler.app/Resources/SQLGenerator.gorm
+@dirrm System/Applications/DBModeler.app/Resources/RelationshipInspector.gorm
+@dirrm System/Applications/DBModeler.app/Resources/Preferences.gorm
+@dirrm System/Applications/DBModeler.app/Resources/ConsistencyResults.gorm
+@dirrm System/Applications/DBModeler.app/Resources/AttributeInspector.gorm
+@dirrm System/Applications/DBModeler.app/Resources
+@dirrm System/Applications/DBModeler.app
+@dirrm Local/Library/Frameworks/Postgres95EOAdaptor.framework/Versions/A/Resources/LoginPanel.bundle/Resources
+@dirrm Local/Library/Frameworks/Postgres95EOAdaptor.framework/Versions/A/Resources/LoginPanel.bundle
+@dirrm Local/Library/Frameworks/Postgres95EOAdaptor.framework/Versions/A/Resources
+@dirrm Local/Library/Frameworks/Postgres95EOAdaptor.framework/Versions/A/Headers
+@dirrm Local/Library/Frameworks/Postgres95EOAdaptor.framework/Versions/A
+@dirrm Local/Library/Frameworks/Postgres95EOAdaptor.framework/Versions
+@dirrm Local/Library/Frameworks/Postgres95EOAdaptor.framework